Bug 248414 - "Run" crashes
Summary: "Run" crashes
Status: RESOLVED DUPLICATE of bug 241531
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 18:35 UTC by alexander
Modified: 2010-08-20 18:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexander 2010-08-19 18:35:30 UTC
Application: krunner (0.1)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2" (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I had written this command:

wine explorer /desktop=0,1024x768 "C:\Program Files\CCP\EVE\eve.exe


 -- Backtrace:
Application: Run Command Interface (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5563710 (LWP 6009))]

Thread 5 (Thread 0xa59a5b70 (LWP 6189)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6b5b125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6bd0710 in wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f7b24a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81a7e40, th=0x82744d0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f7e307 in waitForAvailableJob (this=0x819be50, th=0x82744d0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x819be50, th=0x82744d0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f7ab43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81a7e40, th=0x82744d0, previous=0x839ef90) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f7b744 in ThreadWeaver::ThreadRunHelper::run (this=0xa59a5314, parent=0x81a7e40, th=0x82744d0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f7b7fa in ThreadWeaver::Thread::run (this=0x82744d0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6bd004f in QThreadPrivate::start (arg=0x82744d0) at thread/qthread_unix.cpp:248
#11 0xb6b56b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5f4346e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa51a4b70 (LWP 6190)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6b5b125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6bd0710 in wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f7b24a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81a7e40, th=0xa5a00c58) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f7e307 in waitForAvailableJob (this=0x819be50, th=0xa5a00c58) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x819be50, th=0xa5a00c58) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f7ab43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81a7e40, th=0xa5a00c58, previous=0x833a280) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f7b744 in ThreadWeaver::ThreadRunHelper::run (this=0xa51a4314, parent=0x81a7e40, th=0xa5a00c58) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f7b7fa in ThreadWeaver::Thread::run (this=0xa5a00c58) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6bd004f in QThreadPrivate::start (arg=0xa5a00c58) at thread/qthread_unix.cpp:248
#11 0xb6b56b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5f4346e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa49a3b70 (LWP 6191)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6b5b125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6bd0710 in wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f7b24a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81a7e40, th=0x820cc98) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f7e307 in waitForAvailableJob (this=0x819be50, th=0x820cc98) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x819be50, th=0x820cc98) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f7ab43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81a7e40, th=0x820cc98, previous=0x8501ce0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f7b744 in ThreadWeaver::ThreadRunHelper::run (this=0xa49a3314, parent=0x81a7e40, th=0x820cc98) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f7b7fa in ThreadWeaver::Thread::run (this=0x820cc98) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6bd004f in QThreadPrivate::start (arg=0x820cc98) at thread/qthread_unix.cpp:248
#11 0xb6b56b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5f4346e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa41a2b70 (LWP 6192)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6b5b125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6bd0710 in wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81a7e58, mutex=0x817de90, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f7b24a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81a7e40, th=0x8200690) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f7e307 in waitForAvailableJob (this=0x819be50, th=0x8200690) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x819be50, th=0x8200690) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f7ab43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81a7e40, th=0x8200690, previous=0x82d0b08) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f7b744 in ThreadWeaver::ThreadRunHelper::run (this=0xa41a2314, parent=0x81a7e40, th=0x8200690) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f7b7fa in ThreadWeaver::Thread::run (this=0x8200690) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6bd004f in QThreadPrivate::start (arg=0x8200690) at thread/qthread_unix.cpp:248
#11 0xb6b56b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5f4346e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5563710 (LWP 6009)):
[KCrash Handler]
#6  ref (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qstring.h:715
#8  KRun::runCommand (cmd=..., window=0x0, workingDirectory=...) at /usr/src/debug/kdelibs-4.4.4/kio/kio/krun.cpp:1022
#9  0xb729d966 in KRun::runCommand (cmd=..., window=0x0) at /usr/src/debug/kdelibs-4.4.4/kio/kio/krun.cpp:1013
#10 0xa5bc0243 in ShellRunner::run (this=0x82d0be8, context=..., match=...) at /usr/src/debug/kdebase-workspace-4.4.4/plasma/generic/runners/shell/shellrunner.cpp:86
#11 0xb52a95df in Plasma::QueryMatch::run (this=0x8377170, context=...) at /usr/src/debug/kdelibs-4.4.4/plasma/querymatch.cpp:224
#12 0xb52b5837 in Plasma::RunnerContext::run (this=0x8196260, match=...) at /usr/src/debug/kdelibs-4.4.4/plasma/runnercontext.cpp:544
#13 0xb52b8dc4 in Plasma::RunnerManager::run (this=0x80fde70, match=...) at /usr/src/debug/kdelibs-4.4.4/plasma/runnermanager.cpp:528
#14 0xb1ec061d in run (this=0x8217cf8, item=0x8377158) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/resultitem.cpp:308
#15 ResultScene::run (this=0x8217cf8, item=0x8377158) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/resultscene.cpp:423
#16 0xb1ec06e1 in Interface::run (this=0x81a2450, item=0x8377158) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/interface.cpp:523
#17 0xb1ec0a6c in Interface::runDefaultResultItem (this=0x81a2450) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/interface.cpp:543
#18 0xb1ed3df4 in Interface::qt_metacall (this=0x81a2450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffe73fc)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/krunner/interface.moc:105
#19 0xb6ccfefd in QMetaObject::metacall (object=0x81a2450, cl=QMetaObject::InvokeMetaMethod, idx=89, argv=0xbffe73fc) at kernel/qmetaobject.cpp:237
#20 0xb6cdefe8 in QMetaObject::activate (sender=0x81578a0, m=0xb71a4760, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#21 0xb6f3e305 in KComboBox::returnPressed (this=0x81578a0) at /usr/src/debug/kdelibs-4.4.4/build/kdeui/kcombobox.moc:168
#22 0xb70bfa38 in KComboBox::qt_metacall (this=0x81578a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffe754c) at /usr/src/debug/kdelibs-4.4.4/build/kdeui/kcombobox.moc:111
#23 0xb70bfb82 in KHistoryComboBox::qt_metacall (this=0x81578a0, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbffe754c) at /usr/src/debug/kdelibs-4.4.4/build/kdeui/khistorycombobox.moc:83
#24 0xb6ccfefd in QMetaObject::metacall (object=0x81578a0, cl=QMetaObject::InvokeMetaMethod, idx=51, argv=0xbffe754c) at kernel/qmetaobject.cpp:237
#25 0xb6cdefe8 in QMetaObject::activate (sender=0x827a198, m=0xb6b38ac8, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3295
#26 0xb6668795 in QLineEdit::returnPressed (this=0x827a198) at .moc/release-shared/moc_qlineedit.cpp:258
#27 0xb6668c58 in QLineEdit::qt_metacall (this=0x827a198, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbffe76cc) at .moc/release-shared/moc_qlineedit.cpp:159
#28 0xb70bec72 in KLineEdit::qt_metacall (this=0x827a198, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbffe76cc) at /usr/src/debug/kdelibs-4.4.4/build/kdeui/klineedit.moc:134
#29 0xb6ccfefd in QMetaObject::metacall (object=0x827a198, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbffe76cc) at kernel/qmetaobject.cpp:237
#30 0xb6cdefe8 in QMetaObject::activate (sender=0x8266300, m=0xb6b46808, local_signal_index=6, argv=0x0) at kernel/qobject.cpp:3295
#31 0xb690edc5 in QLineControl::accepted (this=0x8266300) at .moc/release-shared/moc_qlinecontrol_p.cpp:150
#32 0xb666f9f7 in QLineControl::processKeyEvent (this=0x8266300, event=0xbffe81d4) at widgets/qlinecontrol.cpp:1528
#33 0xb6663b77 in QLineEdit::keyPressEvent (this=0x827a198, event=0xbffe81d4) at widgets/qlineedit.cpp:1667
#34 0xb70c0662 in KLineEdit::keyPressEvent (this=0x827a198, e=0xbffe81d4) at /usr/src/debug/kdelibs-4.4.4/kdeui/widgets/klineedit.cpp:1025
#35 0xb625cd7f in QWidget::event (this=0x827a198, event=0xbffe81d4) at kernel/qwidget.cpp:8079
#36 0xb666671b in QLineEdit::event (this=0x827a198, e=0xbffe81d4) at widgets/qlineedit.cpp:1480
#37 0xb6fdd6f2 in KLineEdit::event (this=0x827a198, ev=0xbffe81d4) at /usr/src/debug/kdelibs-4.4.4/kdeui/widgets/klineedit.cpp:1329
#38 0xb662a4e6 in QComboBox::keyPressEvent (this=0x81578a0, e=0xbffe81d4) at widgets/qcombobox.cpp:3000
#39 0xb6f8baa3 in KHistoryComboBox::keyPressEvent (this=0x81578a0, e=0xbffe81d4) at /usr/src/debug/kdelibs-4.4.4/kdeui/widgets/khistorycombobox.cpp:344
#40 0xb625cd7f in QWidget::event (this=0x81578a0, event=0xbffe81d4) at kernel/qwidget.cpp:8079
#41 0xb6626d24 in QComboBox::event (this=0x81578a0, event=0xbffe81d4) at widgets/qcombobox.cpp:2819
#42 0xb6203c64 in QApplicationPrivate::notify_helper (this=0x80b6528, receiver=0x81578a0, e=0xbffe81d4) at kernel/qapplication.cpp:4302
#43 0xb620c598 in QApplication::notify (this=0xbffe8098, receiver=0x81578a0, e=0xbffe81d4) at kernel/qapplication.cpp:3765
#44 0xb6f0d9d1 in KApplication::notify (this=0x80b6358, receiver=0x81578a0, event=0xbffe81d4) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#45 0xb6cc9e0e in QCoreApplication::notifyInternal (this=0x80b6358, receiver=0x81578a0, event=0xbffe81d4) at kernel/qcoreapplication.cpp:726
#46 0xb62013bd in sendSpontaneousEvent (receiver=0x81578a0, event=0xbffe81d4) at ../../src/corelib/kernel/qcoreapplication.h:218
#47 qt_sendSpontaneousEvent (receiver=0x81578a0, event=0xbffe81d4) at kernel/qapplication.cpp:5281
#48 0xb62b0cf3 in QKeyMapper::sendKeyEvent (keyWidget=0x81578a0, grab=false, type=QEvent::KeyPress, code=16777220, modifiers=) at kernel/qkeymapper_x11.cpp:1875
#49 0xb62b11c1 in QKeyMapperPrivate::translateKeyEvent (this=0x80dff10, keyWidget=0x81578a0, event=0xbffe887c, grab=false) at kernel/qkeymapper_x11.cpp:1845
#50 0xb628a7ca in QApplication::x11ProcessEvent (this=0x80b6358, event=0xbffe887c) at kernel/qapplication_x11.cpp:3406
#51 0xb62b4570 in x11EventSourceDispatch (s=0x80bbea8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#52 0xb594cb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#53 0xb594d350 in ?? () from /usr/lib/libglib-2.0.so.0
#54 0xb594d60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#55 0xb6cf5d4b in QEventDispatcherGlib::processEvents (this=0x80b5ad8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#56 0xb62b419a in QGuiEventDispatcherGlib::processEvents (this=0x80b5ad8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb6cc911d in QEventLoop::processEvents (this=0xbffe8b34, flags=...) at kernel/qeventloop.cpp:149
#58 0xb6cc9319 in QEventLoop::exec (this=0xbffe8b34, flags=...) at kernel/qeventloop.cpp:201
#59 0xb6ccdc70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#60 0xb6201164 in QApplication::exec () at kernel/qapplication.cpp:3581
#61 0xb1ed219d in kdemain (argc=1, argv=0x80adf08) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/main.cpp:65
#62 0x0804e5b1 in _start ()

Possible duplicates by query: bug 243835, bug 241531.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-20 18:47:21 UTC

*** This bug has been marked as a duplicate of bug 241531 ***