Bug 251434 - plasma-netbook powerdevil does not recognize ACPI events anymore and does not lock screen
Summary: plasma-netbook powerdevil does not recognize ACPI events anymore and does not...
Status: RESOLVED NOT A BUG
Alias: None
Product: plasma4
Classification: Unclassified
Component: plasma-netbook (show other bugs)
Version: 4.5 and older
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-16 12:58 UTC by Niclas
Modified: 2012-05-17 18:10 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas 2010-09-16 12:58:21 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Starting with KDE 4.5.0 ACPI events like close lid or press of powerbutton are not recognized by powerdevil anymore. Locking of the screen is also not possible. If you try to lock the screen nothing happens.

After switching back to plasma-desktop everything works fine.

This applies to KDE SC 4.5.0 and 4.5.1. Architecture is Arch Linux.

Bug is even reproducible with the KDE Four live ISO image KDE-Four-Live.i686-4.5.0.iso from http://home.kde.org/~kdelive/.

Reproducible: Always

Steps to Reproduce:
Start KDE Four live ISO image KDE-Four-Live.i686-4.5.0.iso from http://home.kde.org/~kdelive/. Switch workspace type to "Netbook". Try to lock screen or to press the powerbutton.

Actual Results:  
ACPI events are not recognized by powerdevil. Locking of screen does nothing.

Expected Results:  
Triggering of ACPI events should fire actions defined in powerdevil. Locking of screen should make it blank requesting a passsword to unlock.
Comment 1 mich.delbianco 2010-09-16 21:18:51 UTC
this bug affect me too, but I've no powerdevil installed
I'm using Kubuntu-10.04_64 with KDE 4.4.2
After a time period KDE doesn't notice any ACPI event, even where calling acpi from the command line displays the correct status, this bug is particularly annoying because on a laptop, when I unplug the cable, it keep on running until the battery power is totally down, causing the machine immediate power off
Comment 2 Marco Martin 2010-12-19 16:37:01 UTC
doe it happen only immediately after switching to netbook or also at subsequent boots?
also, is still happening in recent betas of 4.6 ?
Comment 3 Niclas 2011-01-05 09:42:52 UTC
It happens also at subsequent boots. Yesterday I tried KDE 2.6 RC1 (Distribution Arch Linux). The behaviour got even worse. Locking of screen and ACPI events do not work with plasma-netbook as before. But now plasma-desktop does not handle ACPI either.
Comment 4 Andras Bibok 2011-02-20 22:52:55 UTC
I can confirm this _since_ 4.5. For me (HP Mini 5102; Kubuntu 10.10 @ amd64; now KDE SC 4.6.0 from backports PPA)

For me only happens with Netbook UI, but in this case, I can't lock the screen (even not with the right click->lock screen method), the machine won't sleep on the close event, won't detect the push of the power button.

With the normal plasma (!netbook) everything is OK.
Comment 5 spam 2011-11-01 21:53:52 UTC
I can reproduce this bug too. Locking the screen does not work, pressing the power button freezes the desktop environment for a few seconds, then resumes without any further notice.
Switching to normal desktop mode solves the problem without any reboot necessary.
Comment 6 Thijs 2012-01-20 13:23:31 UTC
Three bugs with close, but slightly different descriptions:
bug 290063 locking never works (can confirm for 4.7.4)
bug 268437 locking only works for newspaper layout 
bug 251434 also ACPI issues (cannot confirm)

So, question here: Can people still confirm the acpi issues? My laptop goes to sleep and wakes up when closing the lid. It does not however lock.
Comment 7 Myriam Schweingruber 2012-05-17 18:10:41 UTC
Closing for lack of feedback. Please feel free to reopen this report if you can still reproduce this with KDE 4.8.3 or later.