Bug 244620 - Klipper shortcut (Ctrl-Alt-V) not working
Summary: Klipper shortcut (Ctrl-Alt-V) not working
Status: RESOLVED DUPLICATE of bug 254994
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal with 202 votes (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
: 240587 246308 250829 251299 252360 253872 254141 257935 272385 272610 275916 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-14 17:19 UTC by Christian González
Modified: 2011-12-25 14:51 UTC (History)
44 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Klipper keys (22.82 KB, image/gif)
2010-08-15 15:58 UTC, Vasileios P. Lourdas
Details
the reliable way to configure that shortcut (165.65 KB, image/png)
2011-11-08 18:07 UTC, Jekyll Wu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian González 2010-07-14 17:19:36 UTC
Version:           unspecified (using Devel) 
OS:                Linux

After upgrading KDE to 4.5rc2 in Fedora (from kde-unstable repo), Ctrl-Alt-V shortcut for Klipper popup is not working.

Others shorcuts are working (eg. Alt-F1 for Kickoff, Alt-F2 for Krunner).

Reproducible: Always

Steps to Reproduce:
1. kcmshell4 keys
2. Verify that Ctrl-Alt-V is defined as global shortcut for Klipper popup.
3. Press Ctrl-Alt-V

Actual Results:  
Nothing happens.

Expected Results:  
Klipper popup should appear.

Fedora 13
Klipper 0.9.7
kdebase-4.4.92-1.fc13.i686
qt-4.7.0-0.26.beta2.fc13.i686 (also happens with qt-4.6.3-8.fc13.i686.rpm)
Comment 1 Rolf Offermanns 2010-07-14 18:52:32 UTC
Same here on Kubuntu 10.04 + kde ppa

klipper                              4:4.4.92-0ubuntu1~lucid1~ppa3
libqt*                               4:4.7.0~beta2-0ubuntu1~lucid1~ppa1
Comment 2 Eike Hein 2010-07-18 11:51:54 UTC
I'm CC'ing Marco here because I talked with him about this around beta1 time when a friend of mine first noticed it, and Marco mentioned he was going to fix it. I assume it got lost in the Akademy shuffle.
Comment 3 Eike Hein 2010-07-19 17:15:24 UTC
Note: On a system upgraded from 4.4 to 4.5, the action is still shown in System Settings's global shortcut prefs (probably because the global shortcut db still contains it), but it's gone from Klipper's own shortcut prefs.
Comment 4 Stefan Radermacher 2010-07-19 19:14:52 UTC
Another problem with the shortcut. If I set a keyboard shortcut via the System Tray Settings dialog on the Entries page, the menu comes up on using the shortcut, but does not accept pressing Return, i.e. nothing happens - the entry is not selected, and the menu does not lose. If the menu is brought up via mouse click in the tray, it behaves as expected, i.e. selected entry is copied to clipboard, and the menu closes.
Comment 5 Marcus Furlong 2010-07-20 09:59:05 UTC
Same issue here on opensuse with KDE Platform Version 4.4.93 (KDE 4.4.93 (KDE 4.5 >= 20100713))
Comment 6 Marco Martin 2010-07-20 11:26:59 UTC
this now depends from the systray, no more from klipper.

half of this is fixed in revision 1152063 (and backported), now the shortcut is assigned to klipper on the first systray run.
still needing to kill the klipper show popup menu action from the global shortcuts
Comment 7 Eike Hein 2010-07-20 11:29:41 UTC
How about the interaction model prob from #4?
Comment 8 Eike Hein 2010-07-20 11:30:43 UTC
Also, what if someone changed the shortcut from Ctrl+Alt+V to something else previously?
Comment 9 Marco Martin 2010-07-20 11:34:59 UTC
about #4, for some reason in that case the clientside menu is triggered, instead of the dbusmenu one, that is a separate bug
Comment 10 Marco Martin 2010-07-20 11:39:14 UTC
about the custom shortcut, the systray could read the settings of klipper, that seems to become a bit overkill...
Comment 11 Eike Hein 2010-07-20 11:45:18 UTC
Not sure avoiding a bona fide bug (losing the shortcut setting) can be characterized overkill, though ... and there's a certain support cost involved in not fixing it, because people who changed their Klipper shortcut in the past will look in the same place again, and won't necessarily find the new tray settings way to do it IMHO.
Comment 12 Marco Martin 2010-07-20 14:27:43 UTC
SVN commit 1152153 by mart:

 read from the global shortcut config file the (eventual) current klipper popup configuiration before assigning the default
BUG:244620


 M  +17 -0     dbussystemtraytask.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1152153
Comment 13 Marco Martin 2010-07-20 15:00:10 UTC
SVN commit 1152168 by mart:

if the item is a menu, start ContextMenu operation instead of Activate
CCBUG:244620


 M  +9 -2      dbussystemtraywidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1152168
Comment 14 Marco Martin 2010-07-20 15:01:58 UTC
with the last commit the enter issue is fixed as well
Comment 15 Christian González 2010-07-27 14:43:51 UTC
Thank you guys! After upgrading to 4.5rc3 Ctrl-Alt-V is working fine again.
Comment 16 Silver Salonen 2010-07-27 14:59:45 UTC
4.5rc3 is 4.4.95, right? It still does not work for me here :(
Comment 17 Christian González 2010-07-27 15:03:39 UTC
Did you go to systray settings -> shortcuts and set Ctrl-Alt-V for Klipper?

And yes, I'm using 4.4.95 from Fedora kde-unstable repo.
Comment 18 Silver Salonen 2010-07-27 15:19:32 UTC
Yes, I have set Ctrl-Alt-V under "Global Keyboard Shortcuts -> Klipper" as "Show Klipper Popup-Menu".

PS. I'm using openSUSE.
Comment 19 Christian González 2010-07-27 15:24:00 UTC
According to #4, you must set the shortcut via the System Tray Settings dialog on the Entries page, NOT the Global Keyboard Shortcuts page.
Comment 20 Silver Salonen 2010-07-27 15:47:58 UTC
Ah, OK, sorry, I missed that. It works from there. Will the "Global Keyboard Shortcuts -> Klipper -> Show Klipper Popup-Menu" be removed?
Comment 21 Joseph Reagle 2010-08-11 17:35:38 UTC
I just upgraded to KDE 4.5 Kubuntu PPA and this was driving me nuts. This is a big problem given the option is still in the Global settings. Also, if I move off or select an option, I have to hit ctrl-alt-V again to make the pop-up go away?
Comment 22 Silver Salonen 2010-08-11 21:37:51 UTC
I have similar use-case problem as Joseph - when the menu is opened by system tray shortcut, clicking on entries in the menu does not seem to do nothing, but actually it changes the current clipboard contents. The result can be seen when closing the menu (hitting ctrl+alt+v) and then opening it again. Very uncomfortable.
Comment 23 Michele Dal Corso 2010-08-13 18:09:53 UTC
Just upgraded Kde 4.4.4 to 4.5.0 in OpenSuse 11.1 and CTRL+ALT+V Klipper shortcut stopped working...

The settings is not available in Klipper shortcuts config, but Global Keyboard
Shortcuts -> Klipper -> Show Klipper Popup-Menu is still there...

Please fix this problem or write here a step-by-step workaround!
Comment 24 Vasileios P. Lourdas 2010-08-13 20:29:05 UTC
Gentoo packages here.

The problem persists. Ctrl+Alt+V does not work, the shortcut does not exist in Klipper settings, but it does exist in the Global shortcuts menu.
Comment 25 jos poortvliet 2010-08-15 15:12:28 UTC
Step-by-step work-around:
go to systemtray settings
go to Entries
Change keyboard shortcut of Klipper to random other shortcut
Change it back to the shortcut you want
(choose reassign)
Done
Comment 26 Vasileios P. Lourdas 2010-08-15 15:58:23 UTC
Created attachment 50580 [details]
Klipper keys

Which shortcut should I change? Here's what I have in my case.
Comment 27 Jörg Afflerbach 2010-08-16 14:48:46 UTC
> Step-by-step work-around:
> go to systemtray settings
> go to Entries

OK, so far, but...

> Change keyboard shortcut of Klipper to random other shortcut

I can't do that because the button for changing the shortcut is disabled/grayed out. Ohters like kopete, kwalletmanager are disabled, too. A few entries like notifications or battery monitor are enabled. openSUSE 11.3 here. Any suggestions?
Comment 28 András Manţia 2010-08-16 16:34:29 UTC
*** Bug 240587 has been marked as a duplicate of this bug. ***
Comment 29 Vasileios P. Lourdas 2010-08-17 23:14:08 UTC
OK, I've found how to apply the workaround. However, this is terrible, why should I assign the key from the system tray settings to make this work? And I suppose the popup menu works because it just happens to be the default action for klipper. Still, the mouse click does not work with the clipboard items.

I'm wondering if klipper from 4.4.5 would work in 4.5.0.
Comment 30 Eike Hein 2010-08-18 13:11:54 UTC
Yes, Klipper from 4.4.5 would work in 4.5.0.
Comment 31 Niklas Laxström 2010-08-31 17:49:00 UTC
Not working for me in 4.5.0 either. Should this bug be reopened?
Comment 32 Piotr Budny 2010-08-31 19:10:38 UTC
There is no such shortcut either Klipper settings, nor global keyboard shortcuts.
kde 4.5.1, please reopen.
Comment 33 frank 2010-09-05 15:09:45 UTC
i also don't have a "Show Klipper Popup-Menu" shortcut under systray -> Configure Klipper -> Shortcuts but on "Grlobal Keyboard Shortcuts" which doesn't work.
kde-4.5.1
Comment 34 Jakub Zakrzewski 2010-09-09 00:17:47 UTC
I confirm that in the KDE 4.5.1 installed from the kubuntu backports repository for the 10.04 distribution the shortcut for the klipper popup menu doesn't work.
Last time it worked for me in the 4.4 branch.
Comment 35 Raphael Kubo da Costa 2010-09-10 23:36:37 UTC
*** Bug 250829 has been marked as a duplicate of this bug. ***
Comment 36 jos poortvliet 2010-09-16 12:10:17 UTC
Actually, it DOES work, it just has been moved. Do a right-click on the system tray (on the left or right) to configure the systray applet. Go to 'Entries' and choose your keyboard shortcut for Klipper there.

So this option has been moved to being a systray shortcut and not a klipper shortcut. Imho the old settings should've been moved over to the Systray settings upon first start of the new Klipper, and I propose to add that for the Plasma 4.5.2 release so distributions pick this up. Because the next time a major distribution (eg Fedora, Ubuntu or openSUSE) will start shipping the 4.5 workspace, it will result in hundreds of bugreports on this subject. In other words, it would save a lot of time...
Comment 37 Esben Mose Hansen 2010-09-26 18:12:33 UTC
*** Bug 252360 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Feck 2010-10-11 13:43:34 UTC
*** Bug 246308 has been marked as a duplicate of this bug. ***
Comment 39 Christoph Feck 2010-10-11 13:45:03 UTC
*** Bug 251299 has been marked as a duplicate of this bug. ***
Comment 40 Christoph Feck 2010-10-11 20:50:07 UTC
*** Bug 253872 has been marked as a duplicate of this bug. ***
Comment 41 Oded Arbel 2010-11-08 16:16:03 UTC
Seems that the "hundreds of bug reports" have started. Fedora 14 and Kubuntu 10.10 ship with the 4.5 default - that is no default keyboard shortcut for the Klipper system tray action.

Regardless of this and the proposed fix, I still think its broken, for of two reasons:

1) I think Klipper is brilliant and I use it a lot with other desktop environment and starting with Klipper 4.5 there is no way to trigger the Klipper menu unless you are also using the Plasma workspace! This is not good interoperability.

2) There's no way users are going to find this configuration - its neither in the global shortcut configuration nor in the Klipper configuration dialog. Unless someone reads this bug report there is no way someone will think about looking in the system tray settings dialog (I didn't even know there is one until now).

The functionality of having the system tray trigger icons in response to shortcuts is great, but it shouldn't come instead of Klipper's internal global shortcut.
Comment 42 Christoph Lange 2010-11-16 18:45:05 UTC
Setting the system tray shortcut works for me.  However: As long as there is, in the system settings under "global keyboard shortcuts", the component "Klipper", particularly with an action "show Klipper popup menu", I wouldn't consider this bug fixed.
Comment 43 Christoph Feck 2010-11-26 05:24:33 UTC
*** Bug 257935 has been marked as a duplicate of this bug. ***
Comment 44 ultr 2010-11-26 09:13:58 UTC
While the tray icon shortcut works for me, I still miss the option of showing the menu under the current mouse position. It was much more handy.
Comment 45 Christopher Yeleighton 2011-02-13 23:10:46 UTC
It is not fixed at all.
It will be fixed when the shortcut will work as documented out of the box.
And +1 to #41.
Comment 46 Federico Sacerdoti 2011-04-30 06:24:34 UTC
+1 to #41 and #42. This bug is the sole reason I upgraded fedora twice in search of its resolution. The shortcut is in my muscle memory, there is no way to work without it! It seems from the number of duplicate bugs, other users feel the same. It's not right to have to read a bug report to figure out how to set a shortcut that has worked for years.

Please keep the KDE brand high-quality by fixing this bug. At the time of this update:
Status:	RESOLVED
Resolution:	FIXED
Comment 47 Kevin Kofler 2011-05-01 18:28:51 UTC
So, while there definitely IS a way to set the Klipper shortcut (which is consistent with all the other systray applets), I see 2 issues needing fixing:
1. The global shortcut settings in System Settings list an action which has no effect.
2. There's no (working) mechanism to migrate the setting on upgrades. The commits from comments #12 and #13 don't seem to work: I still have the shortcut set in the old place and not in the new one (which means it doesn't work anymore). (KDE SC 4.6.2 on Fedora 14.)
Comment 48 Christoph Feck 2011-05-04 00:27:58 UTC
*** Bug 272385 has been marked as a duplicate of this bug. ***
Comment 49 András Manţia 2011-05-11 17:38:13 UTC
Aside of what was mentioned, the current way of assigning a shortcut has another issue: if you remove the systray and add it again, the klipper shortcut is "lost". I understand the technical reasons, but for the user this is just unexpected. So one more vote to have a real global klipper shortcut.
Comment 50 fleg 2011-05-24 07:52:24 UTC
Same on gentoo with klipper 4.6.2. The workaround didn't work for me. I'm going to use 4.4.5 until this issue is solved.
Comment 51 Aurélien 2011-06-09 12:39:47 UTC
I use klipper with awesome.
How can I display the popup with history ?
Comment 52 Kevin Kofler 2011-06-09 12:42:18 UTC
Probably not at all. Setting shortcuts in the system tray is a feature of the Plasma system tray.
Comment 53 Chusslove Illich 2011-06-11 18:53:44 UTC
On 4.6.3 from Debian packages, the interaction problem mentioned in #4 still remains. When the menu comes up,  I cannot activate any of the clipboard entries (Return does nothing), though I can activate the action items below them.
Comment 54 Philippe Cloutier 2011-06-11 18:59:27 UTC
Chusslove, for the Enter issue, see #258749.
Comment 55 Attila 2011-07-08 07:57:06 UTC
I can reproduce the bug on Fedora 14. Ctrl-Alt-V doesn't work.
One possible workaround is to delete my kde-profile, but the bug returns sometimes after upgrading kde.
Comment 56 Marian Kyral 2011-08-26 08:45:50 UTC
(In reply to comment #53)
> On 4.6.3 from Debian packages, the interaction problem mentioned in #4 still
> remains. When the menu comes up,  I cannot activate any of the clipboard
> entries (Return does nothing), though I can activate the action items below
> them.

I can confirm on Gentoo, KDE 4.7.0. Enter does nothing in this case.

Also, I have a problem with the previous/next item shortcuts. These were not set and I set default shortcuts (CTRL + ALT + Down / Up) via klipper setting. But after clipper restart, shortcuts disappears. And I cannot set then again, as error message that the CTRL + ALT + Down / Up) combination is already assigned to Klipper. Choosing of different shotcurt has no effect, the menu does not show.

Also is strange, that the change of Shortcuts does not enable the 'Apply' button. It is still gray.
Comment 57 Marian Kyral 2011-08-26 11:15:20 UTC
It is really confusing. CTRL+ALT+Down/Up changes the entry without enter (I can see in context menu of klipper), but the content of clipboard is not updated, previous content is pasted.
Comment 58 Pascal d'Hermilly 2011-09-26 07:57:03 UTC
This is still present in KDE 4.7.1 - Kubuntu packages
Comment 59 Hans Meine 2011-10-25 10:42:51 UTC
Same problem as in the last comments here with klipper 0.9.7 under KDE 4.7.1 on Ubuntu 11.04 (natty):

I can open the popup using Ctrl-Alt-V, even change between menu entries with Ctrl-Alt-Up/Down, but I can only "activate" menu entries and let the popup disappear using the mouse.

I liked the old method (just up/down without modifiers, then enter) a lot better.  Even if there are technical reasons for this change (focus / global accel system / …), it is worth finding a way around that IMHO!
Comment 60 Jekyll Wu 2011-11-08 18:07:42 UTC
Created attachment 65407 [details]
the reliable way to configure that shortcut

Well, allow me to sum up my observation and thought about this bug.

First, that shortcut(Ctrl+Alt+V) works out-of-box when using a clean account(~/.kde or ~/.kde4 is empty) in KDE 4.7.3. That shortcut is configurable through "Global keyboard shortcut -> Plasma Desktop Shell -> Systemtray-Klipper-###", or systray settings(not always).

So, technically this bug is already fixed. However, I think it is still practically broken for most users.

1. It is hard for normal users to find or realize where to configure that shortcut. Without reading this bug report, I have no idea about the right place.

2. The shortcut is bounded with the systray, so after removing and adding systray again, the shortcut does not work and the result is quite messy(see the screenshot). What does "Systemtray-Kilpper-###" mean to a normal user, especially when there are multiple such actions? 

3. It makes klipper less useful in non-KDE environments.

I am not familiar with the development of klipper. Could someone take a look at that commit and reconsider the decision? 

commit ce11be50d421f3ed107565c07c6cdf3cf80257fa
Author: Fredrik Höglund <fredrik@kde.org>
Date:   1 year, 6 months ago

    - Port Klipper to KStatusNotifierItem.
    - Remove the shortcut for showing the menu, and the option for showing
      the menu at the cursor position when the shortcut is triggered.
      (The shortcut is now configured in the systray settings.)
    
    svn path=/trunk/KDE/kdebase/workspace/; revision=1125178
Comment 61 Hans Meine 2011-11-08 18:42:54 UTC
I think there are several problems mixed up in this report; sorry if I added to the confusion by stating wrong things myself.  This is the current situation that I face:

0) Ctrl-Alt-V opens the klipper menu.  I think it works for most people now and is no longer what people complain about.

1) I can also highlight an entry with the cursor keys, with or without pressing Ctrl-Alt (as found in a shortcut dialog) in addition.  HOWEVER, I cannot 'activate' an entry with Enter anymore, i.e. in order to close the popup menu.  This is the most serious problem and is reflected in many  of the above comments (starting with #4), even if the bug title does not describe this at all (yet).  Actually, I only found a workaround some minutes ago, when reading comment #21: Obviously, one can dismiss the menu by pressing Ctrl-Alt-V again, and the currently highlighted entry will be the active selection! :-)  (No, this is not good usability.)

2) It is no longer possible to have the menu at the mouse position.  As long as the keyboard use is as difficult (unintuitive) as it is now, this is a big problem, since you forced to move the mouse to the screen’s corner and back afterwards.  Even if that’s fixed, it is still unconvenient to have to move your gaze back and forth.
Comment 62 Jekyll Wu 2011-11-08 19:19:55 UTC
(In reply to comment #61)
> I think there are several problems mixed up in this report; sorry if I added to
> the confusion by stating wrong things myself.  This is the current situation
> that I face:
> 
> 0) Ctrl-Alt-V opens the klipper menu.  I think it works for most people now and
> is no longer what people complain about.

Yes, it works by default. But it is VERY easy to make it broken:

1). login using a clean user accout
2). the shortcut works
3). remove the default panel(in the bottom)
4). add the default panel again
5). the shortcut does not work 
 
> 1) I can also highlight an entry with the cursor keys, with or without pressing
> Ctrl-Alt (as found in a shortcut dialog) in addition.  HOWEVER, I cannot
> 'activate' an entry with Enter anymore...

That would be bug 258749.


> 2) It is no longer possible to have the menu at the mouse position.
That seems caused by the same commit, and is tracked in bug 254994.
Comment 63 Jekyll Wu 2011-11-09 19:30:54 UTC
*** Bug 275916 has been marked as a duplicate of this bug. ***
Comment 64 Jekyll Wu 2011-11-09 19:40:54 UTC
*** Bug 254141 has been marked as a duplicate of this bug. ***
Comment 65 Jekyll Wu 2011-11-09 19:41:46 UTC
*** Bug 272610 has been marked as a duplicate of this bug. ***
Comment 66 Vincent de Phily 2011-11-09 23:10:29 UTC
I agree this bug is still valid, for all the reasons mentioned in comment #60 (unintuitive, easy to break, and specific to plasma systray).

But let's keep in mind the original intent, which was (I think) to present a consistent "configure popup shortcut" for all items of the systray. That's valuable too. The problem is that we'd now have two shortcuts for the same action: one from the application and one from the systray (that somehow simulates a click on the application icon ?).

What would be great would be to :
1) put the shortcut back in the klipper application (so it is together with the other klipper shortcuts, doesn't get reset when you remove klipper from systray, and works with non-kde systrays).
2) let the systray settings configure klipper's shortcut directly, instead of configuring a systray shortcut.

Doing that last bit may be tricky (I do not know the code so I'm guessing). We'd need the systray protocol to allow declaration of the application shortcut that is to be used for the "default action". And a portable way to change the application shortcut from the systray (let the systray ask the application via dbus to change its shortcut ?).

I feel that 1) needs to be done, as it is The Right Thing. Even having redundant shortcuts in klipper and the systray would be better than the current situation.
Doing 2) however might be much more work (again, just guessing), the 90% of work that bring the 10% of polish.
Comment 67 Silver Salonen 2011-11-10 07:00:28 UTC
Why do we have to worry about the shortcut being assigned in system tray settings at all? If a user can assign it (and if it's assigned by default already) in Klipper, then that's enough, isn't it? If a user has for some reason removed the shortcut from Klipper, then it's his free choice which shortcut will he use now.
Comment 68 Vincent de Phily 2011-11-11 10:37:51 UTC
I think the issue is consistency : since the systray provides a keyboard shorcut to all its applets, you'd expect it to be the case for klipper as well. But that led to the "two shortcuts for one action" problem which was resolved by removing the of the shortcuts (the klipper one), leading to further problems.

Note that the "two shortcuts for one action" problem is not specific to klipper. It's easy for example to setup the keyboard layout changer with two same-purpose shortcuts. Thankfully, nobody has decided to fix that by removing a shortcut from the keyboard app yet.

So once we've restored the klipper shortcut (we agree on this one ?) we have 3 options :
1) remove all shortcuts from the systray (pity)
2) accept the duplication between systray shortcuts and apps shortcuts (annoying)
3) make the systray smart enough to use/setup/foobar the app's shortcut (complicated)
Comment 69 Silver Salonen 2011-11-11 10:41:30 UTC
To me the 2nd option does not seem annoying - KDE is known for many-many configuration options and it's very cool :)
Comment 70 Jekyll Wu 2011-12-25 13:48:40 UTC
Well, I just realize bug 254994 has been fixed. So if I understand it correctly, in the upcoming KDE SC 4.8, there will be TWO similar but different ways of opening the popup menu.

1). A global shortcut provided by systray, which is Ctrl-Alt-V by default and "opens popup menu under systray icon"
2). A global shortcut provided by klipper, which is Ctrl-Shift-V by default and "opens popup menu at mouse position"

That is interesting, but I'm not sure whether the situation becomes better or worse ...
Comment 71 Silver Salonen 2011-12-25 14:45:43 UTC
Yup, the menu popup works in 4.8 beta2. Bug 254994 is duplicate of this one, isn't it (as this one is older)? But as the other one has been marked as FIXED, this one should be marked as duplicate of 254994 now?
Comment 72 Kevin Kofler 2011-12-25 14:51:50 UTC

*** This bug has been marked as a duplicate of bug 254994 ***