Bug 243148 - Plasma crash after 100% CPU usage
Summary: Plasma crash after 100% CPU usage
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 243828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-29 13:08 UTC by Raúl A V
Modified: 2010-07-07 12:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl A V 2010-06-29 13:08:55 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Plasma crash after 100% CPU usage
Plasma crash after 100% CPU usage

 -- Backtrace:
Application: Área de trabajo de Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f19438a0760 (LWP 1928))]

Thread 3 (Thread 0x7f19180cf710 (LWP 1931)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f19180ceaa0 in ?? ()
#2  0x00007fff31462852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f190f5da710 (LWP 1945)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f193953bd76 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f193953bdb9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f1941ae99ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f19408986cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f19438a0760 (LWP 1928)):
[KCrash Handler]
#5  0x00007f194236e0f7 in QString (this=0x48, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x48, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007f1942379e68 in KIconLoader::loadIcon (this=0x6f71d20, _name=..., group=<value optimized out>, size=19, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007f19423725fc in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x00007f19410b8f8c in QIcon::actualSize (this=<value optimized out>, size=..., mode=QIcon::Normal, state=QIcon::On) at image/qicon.cpp:709
#10 0x00007f193a91c7b7 in Plasma::IconWidgetPrivate::decoration (this=0x7304630, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x00007f193a91de1c in Plasma::IconWidget::paint (this=0x637a890, painter=0x7fff31439f30, option=0x14aefb8, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x00007f19416157aa in _q_paintItem (item=<value optimized out>, painter=0x7fff31439f30, option=0x14aefb8, widget=0x0, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4258
#13 0x00007f1941615a3c in _q_paintIntoCache (pix=0x7fff3143a5c0, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=)
    at graphicsview/qgraphicsscene.cpp:4296
#14 0x00007f194162a115 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x637a8a0, painter=0x7fff3143c470, option=0x14aefb8, widget=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4594
#15 0x00007f194162aa25 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x637a8a0, painter=0x7fff3143c470, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x3fafdb0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4835
#16 0x00007f194162b662 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x637a8a0, painter=0x7fff3143c470, viewTransform=0x7fff3143c200, exposedRegion=0x4290dd0, 
    widget=0x3fafdb0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4757
#17 0x00007f194162aac0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x24a5720, painter=0x7fff3143c470, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x3fafdb0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4849
#18 0x00007f194162b662 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x24a5720, painter=0x7fff3143c470, viewTransform=0x7fff3143c200, exposedRegion=0x4290dd0, 
    widget=0x3fafdb0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4757
#19 0x00007f194162aac0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x252c7a0, painter=0x7fff3143c470, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x3fafdb0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4849
#20 0x00007f194162b662 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x252c7a0, painter=0x7fff3143c470, viewTransform=0x7fff3143c200, exposedRegion=0x4290dd0, 
    widget=0x3fafdb0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4757
#21 0x00007f194162aac0 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x22b8f50, painter=0x7fff3143c470, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x3fafdb0, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4849
#22 0x00007f194162b662 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x22b8f50, painter=0x7fff3143c470, viewTransform=0x7fff3143c200, exposedRegion=0x4290dd0, 
    widget=0x3fafdb0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4757
#23 0x00007f194162be94 in QGraphicsScenePrivate::drawItems (this=0x14aed60, painter=0x7fff3143c470, viewTransform=0x7fff3143c200, exposedRegion=0x4290dd0, widget=0x3fafdb0)
    at graphicsview/qgraphicsscene.cpp:4639
#24 0x00007f194164b57c in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3387
#25 0x00007f19356a9b09 in PanelView::paintEvent (this=0x7fff314395a0, event=0x48) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#26 0x00007f194105caf2 in QWidget::event (this=0x2e8b040, event=0x7fff3143cdb0) at kernel/qwidget.cpp:8190
#27 0x00007f1941405646 in QFrame::event (this=0x2e8b040, e=0x7fff3143cdb0) at widgets/qframe.cpp:557
#28 0x00007f194164814b in QGraphicsView::viewportEvent (this=0x2e8b040, event=0x7fff3143cdb0) at graphicsview/qgraphicsview.cpp:2787
#29 0x00007f1941e691b7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x3fafdb0, event=0x7fff3143cdb0) at kernel/qcoreapplication.cpp:841
#30 0x00007f1941006bdc in QApplicationPrivate::notify_helper (this=0x13ce380, receiver=0x3fafdb0, e=0x7fff3143cdb0) at kernel/qapplication.cpp:4298
#31 0x00007f194100d0eb in QApplication::notify (this=0x13b7b90, receiver=0x3fafdb0, e=0x7fff3143cdb0) at kernel/qapplication.cpp:4185
#32 0x00007f19423b2a16 in KApplication::notify (this=0x13b7b90, receiver=0x3fafdb0, event=0x7fff3143cdb0) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007f1941e69d9c in QCoreApplication::notifyInternal (this=0x13b7b90, receiver=0x3fafdb0, event=0x7fff3143cdb0) at kernel/qcoreapplication.cpp:726
#34 0x00007f19410650ed in QCoreApplication::sendSpontaneousEvent (this=0x42a5e30, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x27b3850) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=0x42a5e30, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x27b3850)
    at kernel/qwidget.cpp:5363
#36 0x00007f1941065d88 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x27b3850) at kernel/qwidget.cpp:5476
#37 0x00007f1941064e4a in QWidgetPrivate::drawWidget (this=0x4290910, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x27b3850) at kernel/qwidget.cpp:5412
#38 0x00007f194121fc75 in QWidgetBackingStore::sync (this=0x27b3850) at painting/qbackingstore.cpp:1300
#39 0x00007f1941056a60 in QWidgetPrivate::syncBackingStore (this=0x4290910) at kernel/qwidget.cpp:1688
#40 0x00007f194105d1f5 in QWidget::event (this=0x2e8b040, event=0x668c0c0) at kernel/qwidget.cpp:8337
#41 0x00007f1941405646 in QFrame::event (this=0x2e8b040, e=0x668c0c0) at widgets/qframe.cpp:557
#42 0x00007f1941490c4b in QAbstractScrollArea::event (this=0x2e8b040, e=0x668c0c0) at widgets/qabstractscrollarea.cpp:989
#43 0x00007f19356ac590 in PanelView::event (this=0x2e8b040, event=0x668c0c0) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#44 0x00007f1941006c0c in QApplicationPrivate::notify_helper (this=0x13ce380, receiver=0x2e8b040, e=0x668c0c0) at kernel/qapplication.cpp:4302
#45 0x00007f194100d0eb in QApplication::notify (this=0x13b7b90, receiver=0x2e8b040, e=0x668c0c0) at kernel/qapplication.cpp:4185
#46 0x00007f19423b2a16 in KApplication::notify (this=0x13b7b90, receiver=0x2e8b040, event=0x668c0c0) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x00007f1941e69d9c in QCoreApplication::notifyInternal (this=0x13b7b90, receiver=0x2e8b040, event=0x668c0c0) at kernel/qcoreapplication.cpp:726
#48 0x00007f1941e6d454 in QCoreApplication::sendEvent (receiver=0x2e8b040, event_type=<value optimized out>, data=0x1343c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x2e8b040, event_type=<value optimized out>, data=0x1343c30) at kernel/qcoreapplication.cpp:1367
#50 0x00007f1941632dca in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x14aed60) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#51 QGraphicsScenePrivate::_q_processDirtyItems (this=0x14aed60) at graphicsview/qgraphicsscene.cpp:509
#52 0x00007f1941633352 in QGraphicsScene::qt_metacall (this=0x14a1d60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x6875c00) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#53 0x00007f193a86cdf5 in Plasma::Corona::qt_metacall (this=0x7fff314395a0, _c=72, _id=0, _a=0x0) at ./corona.moc:107
#54 0x00007f193569bbd3 in DesktopCorona::qt_metacall (this=0x7fff314395a0, _c=72, _id=0, _a=0x0) at ./desktopcorona.moc:86
#55 0x00007f1941e79b79 in QObject::event (this=0x14a1d60, e=0x6588e70) at kernel/qobject.cpp:1248
#56 0x00007f194162efe0 in QGraphicsScene::event (this=0x14a1d60, event=0x6588e70) at graphicsview/qgraphicsscene.cpp:3509
#57 0x00007f1941006c0c in QApplicationPrivate::notify_helper (this=0x13ce380, receiver=0x14a1d60, e=0x6588e70) at kernel/qapplication.cpp:4302
#58 0x00007f194100d0eb in QApplication::notify (this=0x13b7b90, receiver=0x14a1d60, e=0x6588e70) at kernel/qapplication.cpp:4185
#59 0x00007f19423b2a16 in KApplication::notify (this=0x13b7b90, receiver=0x14a1d60, event=0x6588e70) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x00007f1941e69d9c in QCoreApplication::notifyInternal (this=0x13b7b90, receiver=0x14a1d60, event=0x6588e70) at kernel/qcoreapplication.cpp:726
#61 0x00007f1941e6d454 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1343c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1343c30) at kernel/qcoreapplication.cpp:1367
#63 0x00007f1941e93873 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#65 0x00007f193d24a8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#66 0x00007f193d24e748 in ?? () from /lib/libglib-2.0.so.0
#67 0x00007f193d24e8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#68 0x00007f1941e933b3 in QEventDispatcherGlib::processEvents (this=0x1345140, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#69 0x00007f19410b718e in QGuiEventDispatcherGlib::processEvents (this=0x7fff314395a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x00007f1941e686c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#71 0x00007f1941e68a9c in QEventLoop::exec (this=0x7fff3143eea0, flags=) at kernel/qeventloop.cpp:201
#72 0x00007f1941e6d73b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#73 0x00007f19356a2fb2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#74 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#75 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#76 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#77 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 242076.

Possible duplicates by query: bug 242076, bug 241487, bug 238133, bug 237830, bug 234299.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-06-29 13:36:19 UTC

*** This bug has been marked as a duplicate of bug 226596 ***
Comment 2 Beat Wolf 2010-07-07 12:21:18 UTC
*** Bug 243828 has been marked as a duplicate of this bug. ***