Bug 236041 - Crased while doing Ctrl+X
Summary: Crased while doing Ctrl+X
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: part (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-02 16:40 UTC by Eduardo Sánchez Muñoz
Modified: 2010-05-09 04:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Sánchez Muñoz 2010-05-02 16:40:16 UTC
Application: kdevelop (3.9.98 (using KDevPlatform 0.9.98))
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Crased while doing Ctrl+X

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KDevelop (kdevelop.bin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8a3e5f0760 (LWP 13223))]

Thread 2 (Thread 0x7f8a21fa7710 (LWP 13226)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007f8a3cd94692 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x3170a60, time=200000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x3170a60, time=200000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f8a385013ce in KDevelop::DUChainPrivate::CleanupThread::run (this=0x3170a40) at ../../language/duchain/duchain.cpp:286
#4  0x00007f8a3cd93775 in QThreadPrivate::start (arg=0x3170a40) at thread/qthread_unix.cpp:248
#5  0x00007f8a3b7d69ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f8a3bad369d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8a3e5f0760 (LWP 13223)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f8a137cce2a in KateLayoutCache::viewLine (this=0x4477b40, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f8a137cd421 in KateLayoutCache::textLayout (this=0x4477b40, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007f8a1383294f in KateViewInternal::makeVisible (this=0x447ab70, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:690
#9  0x00007f8a13833009 in KateViewInternal::updateCursor (this=0x447ab70, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007f8a13833c39 in KateViewInternal::editEnd (this=0x447ab70, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007f8a1378bd11 in KateDocument::editEnd (this=0x4628790) at ../../kate/document/katedocument.cpp:977
#12 0x00007f8a13792aa6 in KateDocument::removeText (this=0x4628790, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007f8a1379461a in KateDocument::backspace (this=0x4628790, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007f8a13819a5c in KateView::backspace (this=0x4661a90) at ../../kate/view/kateview.cpp:2295
#15 0x00007f8a1381ebbd in KateView::qt_metacall (this=0x4661a90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4f8e7a10) at ./kateview.moc:373
#16 0x00007f8a3ce9ae3f in QMetaObject::activate (sender=0x47362d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f8a3c23b032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f8a3c23d0ab in QAction::activate (this=0x47362d0, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f8a3c23e9b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f8a3d2f9f3d in KAction::event (this=0x0, event=0x7fff4f8e8080) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007f8a3c24122c in QApplicationPrivate::notify_helper (this=0x2c5b5d0, receiver=0x47362d0, e=0x7fff4f8e8080) at kernel/qapplication.cpp:4300
#22 0x00007f8a3c2476fb in QApplication::notify (this=0x7fff4f8e96b0, receiver=0x47362d0, e=0x7fff4f8e8080) at kernel/qapplication.cpp:4183
#23 0x00007f8a3d3cf526 in KApplication::notify (this=0x7fff4f8e96b0, receiver=0x47362d0, event=0x7fff4f8e8080) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f8a3ce8806c in QCoreApplication::notifyInternal (this=0x7fff4f8e96b0, receiver=0x47362d0, event=0x7fff4f8e8080) at kernel/qcoreapplication.cpp:704
#25 0x00007f8a3c27ce86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff4f8e8680) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff4f8e8680) at kernel/qshortcutmap.cpp:879
#27 0x00007f8a3c27ec97 in QShortcutMap::tryShortcutEvent (this=0x2c5b6f8, o=<value optimized out>, e=0x7fff4f8e8680) at kernel/qshortcutmap.cpp:364
#28 0x00007f8a3c249268 in QApplication::notify (this=0x7fff4f8e96b0, receiver=0x447ab70, e=0x7fff4f8e8680) at kernel/qapplication.cpp:3746
#29 0x00007f8a3d3cf526 in KApplication::notify (this=0x7fff4f8e96b0, receiver=0x447ab70, event=0x7fff4f8e8680) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f8a3ce8806c in QCoreApplication::notifyInternal (this=0x7fff4f8e96b0, receiver=0x447ab70, event=0x7fff4f8e8680) at kernel/qcoreapplication.cpp:704
#31 0x00007f8a3c2ec16a in QKeyMapper::sendKeyEvent (keyWidget=0x447ab70, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f8a3c2ee6f0 in QKeyMapperPrivate::translateKeyEvent (this=0x2c956d0, keyWidget=0x447ab70, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f8a3c2c5904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff4f8e9250) at kernel/qapplication_x11.cpp:3394
#34 0x00007f8a3c2f1882 in x11EventSourceDispatch (s=0x2c5f3b0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f8a3599e8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f8a359a2748 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f8a359a28fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f8a3ceb1513 in QEventDispatcherGlib::processEvents (this=0x2412f50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007f8a3c2f146e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f8a3ce86992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f8a3ce86d6c in QEventLoop::exec (this=0x7fff4f8e9580, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f8a3ce8aaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00000000004060d7 in _start ()

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-05-09 04:59:24 UTC
fixed in kde 4.5

*** This bug has been marked as a duplicate of bug 226409 ***