Bug 239078 - Doesn't remember defined shortcuts
Summary: Doesn't remember defined shortcuts
Status: RESOLVED FIXED
Alias: None
Product: knotes
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 254076 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-28 01:52 UTC by Kiril Vladimiroff
Modified: 2011-12-26 00:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kiril Vladimiroff 2010-05-28 01:52:42 UTC
Version:           unspecified (using KDE 4.4.3) 
OS:                Linux

Simple issue. Now matter hoy many times I've defined my keyboard shortcuts for showing and hiding all notes, they just doesn't stay configured after next starting of knotes.

P.S: My Knotes version is 3.9 (wasn't listed in bug tool)

Reproducible: Didn't try

Steps to Reproduce:
1. Start Knotes
2. Click on the tray icon and choose "Configure Shortcuts"
3. Define some global shortcuts(Show all notes for example)
4. Quit Knotes
5. Start it again.


Actual Results:  
I don't have my previously configured global keyboard shortcuts.

Expected Results:  
I want to have global keyboard shortcuts for showing and hiding all notes

OS: Linux (x86_64) release 2.6.33-ARCH
Compiler: gcc
Comment 1 Kiril Vladimiroff 2010-05-28 01:53:53 UTC
Forgot to point it out: This bug reproduces all over again. Didn't noticed the drop-down form for this one.
Comment 2 BryanFRitt 2010-06-19 21:16:19 UTC
I have the exact same problem, and was about to report it, but I saw your bug report, and decided not to have duplicate bug reports.

Steps to reproduce:
Assign global shorts to 'show all notes', and 'hide all notes'.
Apply, try the shortcuts out, and they'll work.
Exit out of knotes.
Restart knotes.
Try the shortcuts again, they won't work.
The keyboard shortcuts must reassigned again to make them work.

Getting these messages:

The shortcut 'Alt+Shift+S' conflicts with the following key combination:
Shortcut 'Alt+Shift+S' in Application KNotes for action Show All Notes

The shortcut 'Alt+Shift+H' conflicts with the following key combination:
Shortcut 'Alt+Shift+H' in Application KNotes for action Hide All Notes

Then it may go back to working.
The shortcuts are also gone after a reboot.

KNotes
Version 3.9
Using KDE Development Platform 4.4.2 (KDE 4.4.2)
KUbuntu 10.04 LTS Lucid 64 bit
OS: Linux (x86_64) release 2.6.32-22-generic
Compiler: cc
installed via repositories or DVD
Comment 3 BryanFRitt 2010-06-20 05:51:26 UTC
Maybe this bug is related to this bug:
http://bugs.kde.org/show_bug.cgi?id=198155
which is about the kmenu
Comment 4 BryanFRitt 2010-06-20 16:00:39 UTC
When 'KNotes' starts up the shortcuts for 'hide all notes' and 'show all notes' don't work. If I edit those shortcuts they will start working again. I don't even have to click OK on the 'Configure Shortcuts - KNotes' dialog box for the shortcuts to go back to working. I could just do the shortcut changes and even leave the 'Configure Shortcuts - KNotes' dialog box up, and the shortcuts will start working again, even if I hit cancel on the 'Configure Shortcuts - KNotes' dialog box the shortcuts will still be back to working.
Comment 5 BryanFRitt 2010-08-02 19:38:43 UTC
It seams that global shortcuts work for klipper, maybe klipper could be used in a comparison with knotes to help fix this knotes global shortcuts problem.
Comment 6 BryanFRitt 2011-06-01 08:31:49 UTC
*** Bug 254076 has been marked as a duplicate of this bug. ***
Comment 7 ermonnezza 2011-10-11 16:48:45 UTC
FOr me both klipper and knotes global shortcuts do not work, they never woirked in KDE4. WIth klipper I have the same problem described with knotes in COmment #2 from Bryian
Comment 8 BryanFRitt 2011-12-15 18:13:55 UTC
This 'KNotes Global Shortcuts aren't remembered between KNotes Sessions' problem still exists in KUbuntu 11.10
Comment 9 Jekyll Wu 2011-12-26 00:34:25 UTC
Git commit 845789de032d5d2c4826d57a2a0c94a5438c5ddc by Jekyll Wu.
Committed on 25/12/2011 at 14:58.
Pushed by jekyllwu into branch 'master'.

Fix the problme of global shortcuts getting reset to 'None' on restart

REVIEW:103531
Related: bug 208641
Related: bug 239078
Related: bug 268897
FIXED-IN:4.8.0

M  +4    -9    knotes/knotesapp.cpp

http://commits.kde.org/kdepim/845789de032d5d2c4826d57a2a0c94a5438c5ddc
Comment 10 Jekyll Wu 2011-12-26 00:36:46 UTC
Git commit dbcfebc0e6b72a80ba34019457915560bc9d633e by Jekyll Wu.
Committed on 25/12/2011 at 14:58.
Pushed by jekyllwu into branch 'origin/KDE/4.8'.

Fix the problme of global shortcuts getting reset to 'None' on restart

REVIEW:103531
Related: bug 208641
Related: bug 239078
Related: bug 268897
FIXED-IN:4.8.0
(cherry picked from commit 845789de032d5d2c4826d57a2a0c94a5438c5ddc)

M  +4    -9    knotes/knotesapp.cpp

http://commits.kde.org/kdepim/dbcfebc0e6b72a80ba34019457915560bc9d633e