Bug 268897 - Global Shortcuts do not work
Summary: Global Shortcuts do not work
Status: RESOLVED FIXED
Alias: None
Product: knotes
Classification: Unclassified
Component: general (show other bugs)
Version: 3.5
Platform: Pardus PiSi Packages Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-19 14:06 UTC by kranthi
Modified: 2011-12-26 00:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kranthi 2011-03-19 14:06:22 UTC
Version:           3.5 (using KDE 4.5.5) 
OS:                Linux

I put global shortcuts in the systems setting>Shortcuts and gestures>Global Keyboard Shortcuts. But the shortcuts won't work. 
I have tried to put the shortcuts in the shortcuts properties in knotes itself and remove them in the global keyboard shortcuts settings but it does not work.
The keyboard shortcuts that i have put are 
Hide notes     : meta+Shift+H
New Note       : Meta+Shift+N
Show all notes : Meta+Shift+T


Reproducible: Always




OS: Linux (i686) release 2.6.37
Compiler: i686-pc-linux-gnu-gcc
Comment 1 Burkhard Lück 2011-06-01 06:51:53 UTC
@ kranthi:
Isn't this a duplicate of https://bugs.kde.org/show_bug.cgi?id=239078
Comment 2 Jekyll Wu 2011-12-26 00:34:25 UTC
Git commit 845789de032d5d2c4826d57a2a0c94a5438c5ddc by Jekyll Wu.
Committed on 25/12/2011 at 14:58.
Pushed by jekyllwu into branch 'master'.

Fix the problme of global shortcuts getting reset to 'None' on restart

REVIEW:103531
Related: bug 208641
Related: bug 239078
Related: bug 268897
FIXED-IN:4.8.0

M  +4    -9    knotes/knotesapp.cpp

http://commits.kde.org/kdepim/845789de032d5d2c4826d57a2a0c94a5438c5ddc
Comment 3 Jekyll Wu 2011-12-26 00:36:46 UTC
Git commit dbcfebc0e6b72a80ba34019457915560bc9d633e by Jekyll Wu.
Committed on 25/12/2011 at 14:58.
Pushed by jekyllwu into branch 'origin/KDE/4.8'.

Fix the problme of global shortcuts getting reset to 'None' on restart

REVIEW:103531
Related: bug 208641
Related: bug 239078
Related: bug 268897
FIXED-IN:4.8.0
(cherry picked from commit 845789de032d5d2c4826d57a2a0c94a5438c5ddc)

M  +4    -9    knotes/knotesapp.cpp

http://commits.kde.org/kdepim/dbcfebc0e6b72a80ba34019457915560bc9d633e