Bug 254076 - KNotes Global Shortcuts aren't remember between KNotes Sessions
Summary: KNotes Global Shortcuts aren't remember between KNotes Sessions
Status: RESOLVED DUPLICATE of bug 239078
Alias: None
Product: knotes
Classification: Applications
Component: general (show other bugs)
Version: 0.9.15
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 16:40 UTC by BryanFRitt
Modified: 2011-06-01 08:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BryanFRitt 2010-10-13 16:40:43 UTC
Version:           0.9.15 (using KDE 4.4.2) 
OS:                Linux

Global Shortcuts aren't remember between KNotes Sessions
Set up global shortcuts for KNotes
exit KNotes
Restart KNotes
All global shortcuts KNotes aren't remembered
I also this on the KUubutu 10.10, and KNotes still has this problem

Reproducible: Always

Steps to Reproduce:
Set up global shortcuts for KNotes
exit KNotes
Restart KNotes
All KNotes global shortcuts KNotes aren't remembered

Actual Results:  
All KNotes global shortcuts KNotes aren't remembered between KNotes sessions

Expected Results:  
All KNotes global shortcuts KNotes are remembered

OS: Linux (x86_64) release 2.6.32-23-generic
Compiler: cc
KUbuntu 10.04.1, 64 bit

The default Configure Shortcuts box is too small it should be at least 654 pixels wide, and taller too
If I edit the shortcuts by clicking defaults, for the ones that have global defaults, the first thing I get something like this:
"
The shortcut 'Alt+Shift+H' conflicts with the following key combination:
Shortcut 'Alt+Shift+H' in Application KNotes for action Hide All Notes
"
After that, if I click the Reassign button It'll reassign the shortcut without having what it is displayed in the Global column
If I give the shortcut a temporary different keyboard shortcut, I can click on default, and the shortcut will work, and show up in the Global column, without displaying the previous message
In either of cases, if I exit KNotes, and restart it, then the global keyboard shortcuts I set up don't work

The global shortcuts for Klipper seam to work for me, just not the global shortcuts for KNotes

The shortcuts are enabled BEFORE I press OK
Why isn't there an APPLY button?
Looks like All changes take effect even if I hit the Cancel button
Comment 1 BryanFRitt 2010-10-31 03:19:35 UTC
I tried KNotes in Gnome, and it looks like the global shortcuts are remembered if I start KNotes from Gnome instead of KDE.
Comment 2 Burkhard Lück 2011-06-01 06:51:08 UTC
@ Bryan:
Isn't this a duplicate of https://bugs.kde.org/show_bug.cgi?id=239078 ?
Comment 3 BryanFRitt 2011-06-01 08:31:49 UTC
Seams to be a duplicate, not sure why I posted it again, maybe it was something about it being the 'Global' shortcuts?

*** This bug has been marked as a duplicate of bug 239078 ***