Bug 235199 - Crash when deleting lines at the end of a file
Summary: Crash when deleting lines at the end of a file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-23 19:26 UTC by Lothar Werzinger
Modified: 2010-05-09 04:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lothar Werzinger 2010-04-23 19:26:09 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Kate crashed when I tried to remove some lines at the end of a file. I tried it 3 times and it always crashed.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe15f70e760 (LWP 30455))]

Thread 2 (Thread 0x7fe14a198710 (LWP 30456)):
#0  0x00007fe15c700f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe1590c64a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fe1590c68fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fe15dd08566 in QEventDispatcherGlib::processEvents (this=0x24d99f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fe15dcdd992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fe15dcddd6c in QEventLoop::exec (this=0x7fe14a197db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fe15dbe7d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fe15dcbe178 in QInotifyFileSystemWatcherEngine::run (this=0x262e840) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe15dbea775 in QThreadPrivate::start (arg=0x262e840) at thread/qthread_unix.cpp:248
#9  0x00007fe15d95a9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fe15c70d69d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe15f70e760 (LWP 30455)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007fe14fc49e2a in KateLayoutCache::viewLine (this=0x363b8b0, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007fe14fc4a421 in KateLayoutCache::textLayout (this=0x363b8b0, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007fe14fcaf94f in KateViewInternal::makeVisible (this=0x2080e40, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:690
#9  0x00007fe14fcb0009 in KateViewInternal::updateCursor (this=0x2080e40, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007fe14fcb0c39 in KateViewInternal::editEnd (this=0x2080e40, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007fe14fc08d11 in KateDocument::editEnd (this=0x2924a80) at ../../kate/document/katedocument.cpp:977
#12 0x00007fe14fc0faa6 in KateDocument::removeText (this=0x2924a80, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007fe14fc1161a in KateDocument::backspace (this=0x2924a80, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007fe14fc96a5c in KateView::backspace (this=0x1fa9b90) at ../../kate/view/kateview.cpp:2295
#15 0x00007fe14fc9bbbd in KateView::qt_metacall (this=0x1fa9b90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff490e8760) at ./kateview.moc:373
#16 0x00007fe15dcf1e3f in QMetaObject::activate (sender=0x39b1e30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007fe15ce75032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007fe15ce770ab in QAction::activate (this=0x39b1e30, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007fe15ce789b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007fe15e150f3d in KAction::event (this=0x0, event=0x7fff490e8dd0) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007fe15ce7b22c in QApplicationPrivate::notify_helper (this=0x183b9c0, receiver=0x39b1e30, e=0x7fff490e8dd0) at kernel/qapplication.cpp:4300
#22 0x00007fe15ce816fb in QApplication::notify (this=0x7fff490ea410, receiver=0x39b1e30, e=0x7fff490e8dd0) at kernel/qapplication.cpp:4183
#23 0x00007fe15e226526 in KApplication::notify (this=0x7fff490ea410, receiver=0x39b1e30, event=0x7fff490e8dd0) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007fe15dcdf06c in QCoreApplication::notifyInternal (this=0x7fff490ea410, receiver=0x39b1e30, event=0x7fff490e8dd0) at kernel/qcoreapplication.cpp:704
#25 0x00007fe15ceb6e86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff490e93d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff490e93d0) at kernel/qshortcutmap.cpp:879
#27 0x00007fe15ceb8c97 in QShortcutMap::tryShortcutEvent (this=0x183bae8, o=<value optimized out>, e=0x7fff490e93d0) at kernel/qshortcutmap.cpp:364
#28 0x00007fe15ce83268 in QApplication::notify (this=0x7fff490ea410, receiver=0x2080e40, e=0x7fff490e93d0) at kernel/qapplication.cpp:3746
#29 0x00007fe15e226526 in KApplication::notify (this=0x7fff490ea410, receiver=0x2080e40, event=0x7fff490e93d0) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007fe15dcdf06c in QCoreApplication::notifyInternal (this=0x7fff490ea410, receiver=0x2080e40, event=0x7fff490e93d0) at kernel/qcoreapplication.cpp:704
#31 0x00007fe15cf2616a in QKeyMapper::sendKeyEvent (keyWidget=0x2080e40, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007fe15cf286f0 in QKeyMapperPrivate::translateKeyEvent (this=0x187b3a0, keyWidget=0x2080e40, event=<value optimized out>, grab=144) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007fe15ceff904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff490e9fa0) at kernel/qapplication_x11.cpp:3394
#34 0x00007fe15cf2b882 in x11EventSourceDispatch (s=0x186cb80, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007fe1590c28c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007fe1590c6748 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007fe1590c68fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007fe15dd08513 in QEventDispatcherGlib::processEvents (this=0x186cef0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007fe15cf2b46e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fe15dcdd992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007fe15dcddd6c in QEventLoop::exec (this=0x7fff490ea2d0, flags=) at kernel/qeventloop.cpp:201
#42 0x00007fe15dce1aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00007fe152c7deed in kdemain () from /usr/lib/libkdeinit4_kate.so
#44 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#45 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#46 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#47 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

Possible duplicates by query: bug 234382, bug 230006, bug 230001, bug 229071, bug 227979.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-05-09 04:43:34 UTC
Fixed in KDE 4.5.

*** This bug has been marked as a duplicate of bug 226409 ***