Bug 230001 - kate crashes on deletion
Summary: kate crashes on deletion
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 230006 231107 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-08 22:09 UTC by Peter
Modified: 2010-03-17 21:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2010-03-08 22:09:05 UTC
Application: kate (3.4.1)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I had several files opened, changed their encoding and editing them by removing some lines from the beginning and from the end of the file. Just after deletion of a piece of text Kate crashed...

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f66ef2187f0 (LWP 2110))]

Thread 2 (Thread 0x7f66de4d9910 (LWP 2125)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f66de818396 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f66deaf6220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f66de8183d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f66deb042ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f66ed460a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f66ec22480d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f66ef2187f0 (LWP 2110)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f66dee5826a in KateLayoutCache::viewLine (this=0x1cb0740, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f66dee58861 in KateLayoutCache::textLayout (this=0x1cb0740, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007f66deebddff in KateViewInternal::makeVisible (this=0x19e1280, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:690
#9  0x00007f66deebe4b9 in KateViewInternal::updateCursor (this=0x19e1280, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007f66deebf099 in KateViewInternal::editEnd (this=0x19e1280, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007f66dee16b71 in KateDocument::editEnd (this=0x20d0970) at ../../kate/document/katedocument.cpp:981
#12 0x00007f66dee1d8a0 in KateDocument::removeText (this=0x20d0970, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:825
#13 0x00007f66dee1f3da in KateDocument::backspace (this=0x20d0970, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2910
#14 0x00007f66deea570c in KateView::backspace (this=0x29e1e50) at ../../kate/view/kateview.cpp:2295
#15 0x00007f66deea9f4d in KateView::qt_metacall (this=0x29e1e50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0a3e4df0) at ./kateview.moc:373
#16 0x00007f66ed7f6c0f in QMetaObject::activate (sender=0x3172b20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007f66ec97c022 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007f66ec97e09b in QAction::activate (this=0x3172b20, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007f66ec97f9a7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007f66edc55ead in KAction::event (this=0x0, event=0x7fff0a3e5460) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007f66ec98212c in QApplicationPrivate::notify_helper (this=0xbf26b0, receiver=0x3172b20, e=0x7fff0a3e5460) at kernel/qapplication.cpp:4300
#22 0x00007f66ec98871b in QApplication::notify (this=0x7fff0a3e6aa0, receiver=0x3172b20, e=0x7fff0a3e5460) at kernel/qapplication.cpp:4183
#23 0x00007f66edd2bd76 in KApplication::notify (this=0x7fff0a3e6aa0, receiver=0x3172b20, event=0x7fff0a3e5460) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f66ed7e3e0c in QCoreApplication::notifyInternal (this=0x7fff0a3e6aa0, receiver=0x3172b20, event=0x7fff0a3e5460) at kernel/qcoreapplication.cpp:704
#25 0x00007f66ec9bde76 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff0a3e5a60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff0a3e5a60) at kernel/qshortcutmap.cpp:879
#27 0x00007f66ec9bfc77 in QShortcutMap::tryShortcutEvent (this=0xbf27d8, o=<value optimized out>, e=0x7fff0a3e5a60) at kernel/qshortcutmap.cpp:364
#28 0x00007f66ec98a273 in QApplication::notify (this=0x7fff0a3e6aa0, receiver=0x19e1280, e=0x7fff0a3e5a60) at kernel/qapplication.cpp:3746
#29 0x00007f66edd2bd76 in KApplication::notify (this=0x7fff0a3e6aa0, receiver=0x19e1280, event=0x7fff0a3e5a60) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f66ed7e3e0c in QCoreApplication::notifyInternal (this=0x7fff0a3e6aa0, receiver=0x19e1280, event=0x7fff0a3e5a60) at kernel/qcoreapplication.cpp:704
#31 0x00007f66eca2cc1a in QKeyMapper::sendKeyEvent (keyWidget=0x19e1280, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007f66eca2f190 in QKeyMapperPrivate::translateKeyEvent (this=0xc26bd0, keyWidget=0x19e1280, event=<value optimized out>, grab=128) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007f66eca06734 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff0a3e6630) at kernel/qapplication_x11.cpp:3394
#34 0x00007f66eca32322 in x11EventSourceDispatch (s=0xbf63d0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007f66e89e6bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f66e89ea598 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f66e89ea6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f66ed80d333 in QEventDispatcherGlib::processEvents (this=0xb6d1c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007f66eca31f0e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f66ed7e2732 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f66ed7e2b0c in QEventLoop::exec (this=0x7fff0a3e6960, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f66ed7e684b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00007f66e1dbdead in kdemain () from /usr/lib/libkdeinit4_kate.so
#44 0x0000000000406fb8 in launch (argc=3, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=24, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a499 "0") at ../../kinit/kinit.cpp:717
#45 0x0000000000407c70 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#46 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#47 0x0000000000408df2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 226409.

Possible duplicates by query: bug 229071, bug 227979, bug 224373, bug 223985, bug 223583.

Reported using DrKonqi
Comment 1 Anders Lund 2010-03-08 22:31:32 UTC
*** Bug 230006 has been marked as a duplicate of this bug. ***
Comment 2 Dominik Haumann 2010-03-08 23:03:21 UTC
cannot reproduce, probably fixed in trunk for 4.5, correct Christoph?
Comment 3 Dominik Haumann 2010-03-17 21:44:51 UTC
*** Bug 231107 has been marked as a duplicate of this bug. ***
Comment 4 Dominik Haumann 2010-03-17 21:46:34 UTC
should be fixed in kde 4.5.

*** This bug has been marked as a duplicate of bug 226409 ***