Bug 234382 - Kate crashing on triple click
Summary: Kate crashing on triple click
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-14 21:00 UTC by Sophie Huiberts
Modified: 2010-04-14 21:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie Huiberts 2010-04-14 21:00:40 UTC
Application that crashed: kate
Version of the application: 3.3.5
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-21-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kate crashes when triple clicking empty text area.
It doesn't matter when you try, or in what file, it just crashes every time you triple click there.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f5471f8121a in KateLayoutCache::viewLine (this=0x123d720, realCursor=...) at ../../kate/render/katelayoutcache.cpp:392
#7  0x00007f5471f817f1 in KateLayoutCache::textLayout (this=0x123d720, realCursor=...) at ../../kate/render/katelayoutcache.cpp:334
#8  0x00007f5471fd4779 in KateViewInternal::makeVisible (this=0xe8d7d0, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:684
#9  0x00007f5471fd4e39 in KateViewInternal::updateCursor (this=0xe8d7d0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1876
#10 0x00007f5471fd947d in KateViewInternal::mousePressEvent (this=0xe8d7d0, e=0x7fff88f6cd20) at ../../kate/view/kateviewinternal.cpp:2539
#11 0x00007f547db3d9a6 in QWidget::event (this=0xe8d7d0, event=0x7fff88f6cd20) at kernel/qwidget.cpp:7545
#12 0x00007f547daeeefc in QApplicationPrivate::notify_helper (this=0xdfbef0, receiver=0xe8d7d0, e=0x7fff88f6cd20) at kernel/qapplication.cpp:4056
#13 0x00007f547daf6011 in QApplication::notify (this=<value optimized out>, receiver=0xe8d7d0, e=0x7fff88f6cd20) at kernel/qapplication.cpp:3758
#14 0x00007f547e725f46 in KApplication::notify (this=0x7fff88f6ec80, receiver=0xe8d7d0, event=0x7fff88f6cd20) at ../../kdeui/kernel/kapplication.cpp:302
#15 0x00007f547fb44c2c in QCoreApplication::notifyInternal (this=0x7fff88f6ec80, receiver=0xe8d7d0, event=0x7fff88f6cd20) at kernel/qcoreapplication.cpp:610
#16 0x00007f547daf58e0 in QCoreApplication::sendSpontaneousEvent (receiver=0xe8d7d0, event=0x7fff88f6cd20, alienWidget=0xe8d7d0, nativeWidget=0x1071890, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#17 QApplicationPrivate::sendMouseEvent (receiver=0xe8d7d0, event=0x7fff88f6cd20, alienWidget=0xe8d7d0, nativeWidget=0x1071890, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at kernel/qapplication.cpp:2924
#18 0x00007f547db5ba0e in QETWidget::translateMouseEvent (this=0x1071890, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#19 0x00007f547db5aaa9 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff88f6e850) at kernel/qapplication_x11.cpp:3550
#20 0x00007f547db83d0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#21 0x00007f547ca1fbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f547ca23598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f547ca236c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f547fb6d1a6 in QEventDispatcherGlib::processEvents (this=0xd5c040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x00007f547db834be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f547fb43532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#27 0x00007f547fb43904 in QEventLoop::exec (this=0x7fff88f6eb80, flags=) at kernel/qeventloop.cpp:201
#28 0x00007f547fb45ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x00007f547531cd2d in kdemain () from /usr/lib/libkdeinit4_kate.so
#30 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0xdb70cb "kees;1271271076;841744;6937_TIME89651263") at ../../kinit/kinit.cpp:677
#31 0x0000000000407aa0 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#32 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#33 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 219853

Reported using DrKonqi
Comment 1 Andreas Pakulat 2010-04-14 21:17:49 UTC

*** This bug has been marked as a duplicate of bug 226409 ***