Bug 242693 - kmail crash when reading pdf attachments and replying
Summary: kmail crash when reading pdf attachments and replying
Status: RESOLVED DUPLICATE of bug 231768
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.13.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-24 15:17 UTC by AWillms
Modified: 2010-11-02 21:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AWillms 2010-06-24 15:17:02 UTC
Application: kmail (1.13.3)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I was replying to an email that had pdf attachments and also opening the attachments a the same time.  It crashed twice doing this, but doesn't seem to do it every time.

 -- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b4780 (LWP 2168))]

Thread 2 (Thread 0xb3b7db70 (LWP 2170)):
#0  0x021f0e14 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x006a8f5b in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x006ae085 in QTimerInfoList::updateCurrentTime (this=0xb3201a34) at kernel/qeventdispatcher_unix.cpp:340
#3  0x006ae0ca in QTimerInfoList::timerWait (this=0xb3201a34, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x006ac078 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb3b7d05c) at kernel/qeventdispatcher_glib.cpp:136
#5  0x006ac105 in timerSourcePrepare (source=0x109, timeout=0x21f4ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x02377aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x02377ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x023784b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x006abe6f in QEventDispatcherGlib::processEvents (this=0xb3200468, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0067e759 in QEventLoop::processEvents (this=0xb3b7d220, flags=) at kernel/qeventloop.cpp:149
#11 0x0067ebaa in QEventLoop::exec (this=0xb3b7d220, flags=...) at kernel/qeventloop.cpp:201
#12 0x0057ffc9 in QThread::exec (this=0x8b11d10) at thread/qthread.cpp:487
#13 0x0065e1db in QInotifyFileSystemWatcherEngine::run (this=0x8b11d10) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x0058297e in QThreadPrivate::start (arg=0x8b11d10) at thread/qthread_unix.cpp:248
#15 0x008b696e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x044cca4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b4780 (LWP 2168)):
[KCrash Handler]
#6  DwString::data (aStr=..., aCstr=0x511956c "content-type") at ../../mimelib/mimelib/string.h:627
#7  DwStrcasecmp (aStr=..., aCstr=0x511956c "content-type") at ../../mimelib/dwstring.cpp:1771
#8  0x05105812 in DwHeaders::FindField (this=0x511bd00, aFieldName=0x511956c "content-type") at ../../mimelib/headers.cpp:316
#9  0x051058f7 in DwHeaders::HasContentType (this=0x511bd00) at ../../mimelib/headers.cpp:725
#10 0x01085c96 in applyHeadersToMessagePart (headers=<value optimized out>, aPart=<value optimized out>) at ../../kmail/kmmessage.cpp:2605
#11 0x01086895 in KMMessage::bodyPart (aDwBodyPart=0x8b284e0, aPart=0x8b80454, withBody=true) at ../../kmail/kmmessage.cpp:2681
#12 0x013ebb15 in partNode::msgPart (this=0x8bbe938, url=..., w=0x8441f00) at ../../kmail/partNode.h:103
#13 statusBarMessage (this=0x8bbe938, url=..., w=0x8441f00) at ../../kmail/urlhandlermanager.cpp:688
#14 0x013ea20c in KMail::URLHandlerManager::statusBarMessage (this=0x86ff480, url=..., w=0x8441f00) at ../../kmail/urlhandlermanager.cpp:355
#15 0x0118a44a in KMReaderWin::slotUrlOn (this=0x8441f00, aUrl=...) at ../../kmail/kmreaderwin.cpp:1966
#16 0x0118c523 in KMReaderWin::qt_metacall (this=0x8441f00, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfc0e0c8) at ./kmreaderwin.moc:189
#17 0x0068547a in QMetaObject::metacall (object=0x8441f00, cl=85050672, idx=43, argv=0xbfc0e0c8) at kernel/qmetaobject.cpp:237
#18 0x00693fbb in QMetaObject::activate (sender=0x87e1aa8, m=0x4c372a8, local_signal_index=0, argv=0xbfc0e0c8) at kernel/qobject.cpp:3295
#19 0x0471bb83 in KHTMLPart::onURL (this=0x87e1aa8, _t1=...) at ./khtml_part.moc:406
#20 0x0473fbfd in KHTMLPart::overURL (this=0x87e1aa8, url=..., target=...) at ../../khtml/khtml_part.cpp:3523
#21 0x04742153 in KHTMLPart::handleMouseMoveEventOver (this=0x87e1aa8, event=0xbfc0edb0) at ../../khtml/khtml_part.cpp:6360
#22 0x0474260c in KHTMLPart::khtmlMouseMoveEvent (this=0x87e1aa8, event=0xbfc0edb0) at ../../khtml/khtml_part.cpp:6408
#23 0x0471c5cf in KHTMLPart::customEvent (this=0x87e1aa8, event=0xbfc0edb0) at ../../khtml/khtml_part.cpp:5955
#24 0x00690c6c in QObject::event (this=0x87e1aa8, e=0xc35dec89) at kernel/qobject.cpp:1279
#25 0x038a5e8c in QApplicationPrivate::notify_helper (this=0x83ca138, receiver=0x87e1aa8, e=0xbfc0edb0) at kernel/qapplication.cpp:4302
#26 0x038aca0e in QApplication::notify (this=0xbfc10000, receiver=0x87e1aa8, e=0xbfc0edb0) at kernel/qapplication.cpp:3706
#27 0x00e11ffa in KApplication::notify (this=0xbfc10000, receiver=0x87e1aa8, event=0xbfc0edb0) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0068013b in QCoreApplication::notifyInternal (this=0xbfc10000, receiver=0x87e1aa8, event=0xbfc0edb0) at kernel/qcoreapplication.cpp:726
#29 0x04713f51 in QCoreApplication::sendEvent (this=0x880bd18, _mouse=0xbfc0f6a0) at /usr/include/qt4/QtCore/qcoreapplication.h:215
#30 KHTMLView::mouseMoveEvent (this=0x880bd18, _mouse=0xbfc0f6a0) at ../../khtml/khtmlview.cpp:1551
#31 0x03903ffa in QWidget::event (this=0x880bd18, event=0xbfc0f6a0) at kernel/qwidget.cpp:8029
#32 0x03d02423 in QFrame::event (this=0x880bd18, e=0xbfc0f6a0) at widgets/qframe.cpp:557
#33 0x0470f9bc in KHTMLView::widgetEvent (this=0x880bd18, e=0x5d8918ec) at ../../khtml/khtmlview.cpp:2362
#34 0x0470fcb5 in KHTMLView::eventFilter (this=0x880bd18, o=0x8810818, e=0xbfc0f6a0) at ../../khtml/khtmlview.cpp:2207
#35 0x0067f3da in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x83ca138, receiver=0x8810818, event=0xbfc0f6a0) at kernel/qcoreapplication.cpp:841
#36 0x038a5e69 in QApplicationPrivate::notify_helper (this=0x83ca138, receiver=0x8810818, e=0xbfc0f6a0) at kernel/qapplication.cpp:4298
#37 0x038ad3a7 in QApplication::notify (this=0xbfc10000, receiver=0x8810818, e=0xbfc0f6a0) at kernel/qapplication.cpp:3867
#38 0x00e11ffa in KApplication::notify (this=0xbfc10000, receiver=0x8810818, event=0xbfc0f6a0) at ../../kdeui/kernel/kapplication.cpp:302
#39 0x0068013b in QCoreApplication::notifyInternal (this=0xbfc10000, receiver=0x8810818, event=0xbfc0f6a0) at kernel/qcoreapplication.cpp:726
#40 0x038ac302 in QCoreApplication::sendEvent (receiver=0x8810818, event=0xbfc0f6a0, alienWidget=0x8810818, nativeWidget=0x853e968, buttonDown=0x41ec058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QApplicationPrivate::sendMouseEvent (receiver=0x8810818, event=0xbfc0f6a0, alienWidget=0x8810818, nativeWidget=0x853e968, buttonDown=0x41ec058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2967
#42 0x03937d58 in QETWidget::translateMouseEvent (this=0x853e968, event=0xbfc0fbbc) at kernel/qapplication_x11.cpp:4380
#43 0x039371e1 in QApplication::x11ProcessEvent (this=0xbfc10000, event=0xbfc0fbbc) at kernel/qapplication_x11.cpp:3391
#44 0x039662ea in x11EventSourceDispatch (s=0x8273308, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#45 0x023745e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#46 0x023782d8 in ?? () from /lib/libglib-2.0.so.0
#47 0x023784b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#48 0x006abe35 in QEventDispatcherGlib::processEvents (this=0x8242278, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#49 0x03965e15 in QGuiEventDispatcherGlib::processEvents (this=0x8242278, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x0067e759 in QEventLoop::processEvents (this=0xbfc0feb4, flags=) at kernel/qeventloop.cpp:149
#51 0x0067ebaa in QEventLoop::exec (this=0xbfc0feb4, flags=...) at kernel/qeventloop.cpp:201
#52 0x00683e3f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#53 0x038a5f27 in QApplication::exec () at kernel/qapplication.cpp:3581
#54 0x0804ab0e in main (argc=1, argv=0xbfc101c4) at ../../kmail/main.cpp:156

Possible duplicates by query: bug 237130, bug 224663, bug 197807.

Reported using DrKonqi
Comment 1 Björn Ruberg 2010-08-07 18:53:03 UTC

*** This bug has been marked as a duplicate of bug 231768 ***
Comment 2 Thomas Lübking 2010-11-02 21:33:20 UTC
SVN commit 1192387 by luebking:

* replace qhash by qmap and avoid side-effect prone QHash::operator[]
* use TimeLine data memeber instead pointer to prevent leaking
* only setTransformed() if there's really a current animation, not if "a window we know is mapped"
* therefore use a poperty to know whether the effect manages a deleted window
* set the TRANSFORMED flag in prePaintWindow as it should be

BUG: 242693



 M  +92 -74    glide.cpp  
 M  +5 -9      glide.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1192387
Comment 3 Thomas Lübking 2010-11-02 21:34:53 UTC
SVN commit 1192388 by luebking:

* replace qhash by qmap and avoid side-effect prone QHash::operator[]
* use TimeLine data memeber instead pointer to prevent leaking
* only setTransformed() if there's really a current animation, not if "a window we know is mapped"
* therefore use a poperty to know whether the effect manages a deleted window
* set the TRANSFORMED flag in prePaintWindow as it should be

CCBUG: 242693



 M  +58 -50    sheet.cpp  
 M  +3 -4      sheet.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1192388
Comment 4 Thomas Lübking 2010-11-02 21:47:50 UTC
sorry, wrong bug :-(

*** This bug has been marked as a duplicate of bug 231768 ***