Bug 219624 - Plazma crashes after moving a folder from desktop widget to removable media
Summary: Plazma crashes after moving a folder from desktop widget to removable media
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 236094 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-22 02:46 UTC by Dmytro
Modified: 2010-05-03 09:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmytro 2009-12-22 02:46:16 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Робочий простір Плазми (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb777c700 (LWP 1971))]

Thread 2 (Thread 0xaaf64b70 (LWP 2282)):
#0  0x00ed5422 in __kernel_vsyscall ()
#1  0x009afe15 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x0598378d in __pthread_cond_wait (cond=0x9038910, mutex=0x90388f8) at forward.c:139
#3  0x0015fe67 in QWaitConditionPrivate::wait (this=0x9006430, mutex=0x900642c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x9006430, mutex=0x900642c, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x0525e922 in QHostInfoAgent::run (this=0x9006420) at kernel/qhostinfo.cpp:260
#6  0x0015ee32 in QThreadPrivate::start (arg=0x9006420) at thread/qthread_unix.cpp:188
#7  0x009ab80e in start_thread (arg=0xaaf64b70) at pthread_create.c:300
#8  0x059767ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb777c700 (LWP 1971)):
[KCrash Handler]
#6  0x00818038 in KFileItem::isDir (this=0xb13e678) at ../../kio/kio/kfileitem.cpp:969
#7  0x00806192 in KDirModelPrivate::removeFromNodeHash (this=0xb4349c8, node=0xb13e678, url=...) at ../../kio/kio/kdirmodel.cpp:200
#8  0x0080708a in KDirModelPrivate::_k_slotDeleteItems (this=0xb4349c8, items=...) at ../../kio/kio/kdirmodel.cpp:487
#9  0x00808d50 in KDirModel::qt_metacall (this=0xb434b60, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbf8a6f18) at ./kdirmodel.moc:83
#10 0x00265263 in QMetaObject::activate (sender=0xb3ecd68, from_signal_index=17, to_signal_index=17, argv=0xbf8a6f18) at kernel/qobject.cpp:3113
#11 0x00265ec2 in QMetaObject::activate (sender=0xb3ecd68, m=0x97d03c, local_signal_index=13, argv=0xbf8a6f18) at kernel/qobject.cpp:3187
#12 0x007eb373 in KDirLister::itemsDeleted (this=0xb3ecd68, _t1=...) at ./kdirlister.moc:289
#13 0x007ec3f9 in KDirLister::Private::emitItemsDeleted (this=0xb3657c0, _items=...) at ../../kio/kio/kdirlister.cpp:2351
#14 0x007fbee6 in KDirListerCache::itemsDeleted (this=0x8c62580, listers=..., deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#15 0x007fda12 in KDirListerCache::slotFilesRemoved (this=0x8c62580, fileList=...) at ../../kio/kio/kdirlister.cpp:808
#16 0x007fde48 in KDirListerCache::slotFilesRemoved (this=0x8c62580, fileList=...) at ../../kio/kio/kdirlister.cpp:763
#17 0x007fe885 in KDirListerCache::qt_metacall (this=0x8c62580, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf8a7238) at ./kdirlister_p.moc:92
#18 0x00265263 in QMetaObject::activate (sender=0x8c639b8, from_signal_index=9, to_signal_index=9, argv=0xbf8a7238) at kernel/qobject.cpp:3113
#19 0x00265ec2 in QMetaObject::activate (sender=0x8c639b8, m=0x97d294, local_signal_index=4, argv=0xbf8a7238) at kernel/qobject.cpp:3187
#20 0x0080a4b3 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x8c639b8, _t1=...) at ./kdirnotify.moc:125
#21 0x0080a6b5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x8c639b8, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbf8a73bc) at ./kdirnotify.moc:83
#22 0x07f767b4 in QDBusConnectionPrivate::deliverCall (this=0x86cb928, object=0x8c639b8, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:891
#23 0x07f7e197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#24 0x0025f5fe in QObject::event (this=0x8c639b8, e=0xb3be7e0) at kernel/qobject.cpp:1111
#25 0x00ff6f54 in QApplicationPrivate::notify_helper (this=0x86f1b30, receiver=0x8c639b8, e=0xb3be7e0) at kernel/qapplication.cpp:4056
#26 0x00ffe67c in QApplication::notify (this=0x86caca0, receiver=0x8c639b8, e=0xb3be7e0) at kernel/qapplication.cpp:3603
#27 0x00c1fbfa in KApplication::notify (this=0x86caca0, receiver=0x8c639b8, event=0xb3be7e0) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0024f6cb in QCoreApplication::notifyInternal (this=0x86caca0, receiver=0x8c639b8, event=0xb3be7e0) at kernel/qcoreapplication.cpp:610
#29 0x002502b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8675e48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8675e48) at kernel/qcoreapplication.cpp:1247
#31 0x0025047d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#32 0x0027a3ff in QCoreApplication::sendPostedEvents (s=0x86f3b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#33 postEventSourceDispatch (s=0x86f3b10) at kernel/qeventdispatcher_glib.cpp:210
#34 0x055cae88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x055ce730 in ?? () from /lib/libglib-2.0.so.0
#36 0x055ce863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x0027a02c in QEventDispatcherGlib::processEvents (this=0x86f1920, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#38 0x01097be5 in QGuiEventDispatcherGlib::processEvents (this=0x86f1920, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#39 0x0024dc79 in QEventLoop::processEvents (this=0xbf8a7b24, flags=) at kernel/qeventloop.cpp:149
#40 0x0024e0ca in QEventLoop::exec (this=0xbf8a7b24, flags=...) at kernel/qeventloop.cpp:201
#41 0x0025053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#42 0x00ff6dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#43 0x06f0980d in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#44 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x86966c8 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#45 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#46 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#47 0x0804fbaf in main (argc=2, argv=0xbf8a8384, envp=0xbf8a8390) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 209465

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-12-22 05:53:33 UTC

*** This bug has been marked as a duplicate of bug 196695 ***
Comment 2 Beat Wolf 2010-05-03 09:30:07 UTC
*** Bug 236094 has been marked as a duplicate of this bug. ***