Bug 236094 - Plasma crashed while moving files from the "Folder View" widget
Summary: Plasma crashed while moving files from the "Folder View" widget
Status: RESOLVED DUPLICATE of bug 219624
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-03 00:01 UTC by kmagkos
Modified: 2010-05-03 09:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kmagkos 2010-05-03 00:01:22 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
The crashed occured while moving a folder of 22MB to a removable usb drive. It seems that plasma crashed after the copying had finished and while the folder was removed.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f4ff79dd750 (LWP 1972))]

Thread 2 (Thread 0x7f4fd1660910 (LWP 1975)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f4ff741b4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x14e9dd8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x14e9dd8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f4ff385278c in QHostInfoAgent::run (this=0x14e9dc0) at kernel/qhostinfo.cpp:260
#4  0x00007f4ff741a445 in QThreadPrivate::start (arg=0x14e9dc0) at thread/qthread_unix.cpp:188
#5  0x00007f4ff4190a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f4ff4d7080d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4ff79dd750 (LWP 1972)):
[KCrash Handler]
#5  0x00007f4ff6623d03 in KFileItem::isDir (this=0x21c7750) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f4ff6613198 in KDirModelPrivate::removeFromNodeHash (this=0x2000340, node=0x21c7750, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f4ff66140ab in KDirModelPrivate::_k_slotDeleteItems (this=0x2000340, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f4ff6615b82 in KDirModel::qt_metacall (this=0x2272690, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00c1f2e0) at ./kdirmodel.moc:83
#9  0x00007f4ff7515ddc in QMetaObject::activate (sender=0x219f150, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f4ff65f9895 in KDirLister::itemsDeleted (this=0x21c7750, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f4ff65fa5d1 in KDirLister::Private::emitItemsDeleted (this=0x1f08310, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f4ff660957e in KDirListerCache::itemsDeleted (this=0x95c250, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f4ff660afca in KDirListerCache::slotFilesRemoved (this=0x95c250, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f4ff660b454 in KDirListerCache::slotFilesRemoved (this=0x95c250, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f4ff660bdb0 in KDirListerCache::qt_metacall (this=0x95c250, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00c1f760) at ./kdirlister_p.moc:92
#16 0x00007f4ff7515ddc in QMetaObject::activate (sender=0xa52500, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f4ff6617115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x21c7750, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f4ff6617290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0xa52500, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00c1fa20) at ./kdirnotify.moc:83
#19 0x00007f4ff3583ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f4ff358adef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f4ff75100f9 in QObject::event (this=0xa52500, e=0x237cfb0) at kernel/qobject.cpp:1111
#22 0x00007f4ff54b0efc in QApplicationPrivate::notify_helper (this=0x6db360, receiver=0xa52500, e=0x237cfb0) at kernel/qapplication.cpp:4056
#23 0x00007f4ff54b81ce in QApplication::notify (this=0x6d2180, receiver=0xa52500, e=0x237cfb0) at kernel/qapplication.cpp:4021
#24 0x00007f4ff60e7ab6 in KApplication::notify (this=0x6d2180, receiver=0xa52500, event=0x237cfb0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f4ff7500c2c in QCoreApplication::notifyInternal (this=0x6d2180, receiver=0xa52500, event=0x237cfb0) at kernel/qcoreapplication.cpp:610
#26 0x00007f4ff750180a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x6484d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x6484d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f4ff7529533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f4ff43e1bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f4ff43e5598 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f4ff43e56c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f4ff75291a6 in QEventDispatcherGlib::processEvents (this=0x64b040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f4ff55454be in QGuiEventDispatcherGlib::processEvents (this=0x21c7750, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f4ff74ff532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f4ff74ff904 in QEventLoop::exec (this=0x7fff00c20310, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f4ff7501ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x00007f4feb8814cf in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#39 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#40 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#41 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#42 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 219624

Reported using DrKonqi
Comment 1 Beat Wolf 2010-05-03 09:30:07 UTC

*** This bug has been marked as a duplicate of bug 219624 ***