Bug 209465 - plasma crashed after moving folder
Summary: plasma crashed after moving folder
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-05 00:23 UTC by Samuel
Modified: 2009-10-05 01:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel 2009-10-05 00:23:51 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
When I moved a folder from the Desktop (folder view) to my external Hard Drive and then startd to move a second one plasma crashed

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 0 (LWP 4120)]

Thread 2 (Thread 0xa7e98b90 (LWP 4127)):
#0  0xb80de430 in __kernel_vsyscall ()
#1  0xb65f60e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb67d62ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7edc172 in QWaitCondition::wait (this=0x8d90f38, mutex=0x8d90f34, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb7819ac2 in QHostInfoAgent::run (this=0x8d90f28) at kernel/qhostinfo.cpp:260
#5  0xb7edb132 in QThreadPrivate::start (arg=0x8d90f28) at thread/qthread_unix.cpp:188
#6  0xb65f24ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb67c749e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb60ffa10 (LWP 4120)):
[KCrash Handler]
#6  0xb79c2548 in KFileItem::isDir (this=0x8d88658) at /build/buildd/kde4libs-4.3.1/kio/kio/kfileitem.cpp:969
#7  0xb79b0262 in KDirModelPrivate::removeFromNodeHash (this=0xa27fae0, node=0x8d88658, url=@0xbfdf9494) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirmodel.cpp:200
#8  0xb79b1320 in KDirModelPrivate::_k_slotDeleteItems (this=0xa27fae0, items=@0xbfdf95f8) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirmodel.cpp:487
#9  0xb79b2d05 in KDirModel::qt_metacall (this=0xaea1358, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfdf95bc) at /build/buildd/kde4libs-4.3.1/obj-i486-linux-gnu/kio/kdirmodel.moc:83
#10 0xb7fe51b8 in QMetaObject::activate (sender=0x9179b58, from_signal_index=17, to_signal_index=17, argv=0xbfdf95bc) at kernel/qobject.cpp:3113
#11 0xb7fe5e42 in QMetaObject::activate (sender=0x9179b58, m=0xb7b2101c, local_signal_index=13, argv=0xbfdf95bc) at kernel/qobject.cpp:3187
#12 0xb79956c3 in KDirLister::itemsDeleted (this=0x9179b58, _t1=@0xbfdf95f8) at /build/buildd/kde4libs-4.3.1/obj-i486-linux-gnu/kio/kdirlister.moc:289
#13 0xb79965d1 in KDirLister::Private::emitItemsDeleted (this=0xa14a550, _items=@0x8aad1b4) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirlister.cpp:2351
#14 0xb79a0d70 in KDirListerCache::itemsDeleted (this=0x8b646e0, listers=@0xb6ed360, deletedItems=@0x8aad1b4) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirlister.cpp:1697
#15 0xb79a1592 in KDirListerCache::slotFilesRemoved (this=0x8b646e0, fileList=@0xbfdf97ec) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirlister.cpp:808
#16 0xb79a19b8 in KDirListerCache::slotFilesRemoved (this=0x8b646e0, fileList=@0x8b38a00) at /build/buildd/kde4libs-4.3.1/kio/kio/kdirlister.cpp:763
#17 0xb79a8e5a in KDirListerCache::qt_metacall (this=0x8b646e0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfdf98ec) at /build/buildd/kde4libs-4.3.1/obj-i486-linux-gnu/kio/kdirlister_p.moc:92
#18 0xb7fe51b8 in QMetaObject::activate (sender=0x8aadc08, from_signal_index=9, to_signal_index=9, argv=0xbfdf98ec) at kernel/qobject.cpp:3113
#19 0xb7fe5e42 in QMetaObject::activate (sender=0x8aadc08, m=0xb7b21274, local_signal_index=4, argv=0xbfdf98ec) at kernel/qobject.cpp:3187
#20 0xb79b4893 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x8aadc08, _t1=@0x8b38a00) at /build/buildd/kde4libs-4.3.1/obj-i486-linux-gnu/kio/kdirnotify.moc:125
#21 0xb79b4a92 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x8aadc08, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfdf9a88)
    at /build/buildd/kde4libs-4.3.1/obj-i486-linux-gnu/kio/kdirnotify.moc:83
#22 0xb7386e5a in QDBusConnectionPrivate::deliverCall (this=0x867d998, object=0x8aadc08, msg=@0xb66cf2c, metaTypes=@0xb66cf30, slotIdx=9) at qdbusintegrator.cpp:891
#23 0xb738eeb7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xb66cf00, object=0x8aadc08) at qdbusintegrator_p.h:101
#24 0xb7fe03b0 in QObject::event (this=0x8aadc08, e=0xb66cf00) at kernel/qobject.cpp:1111
#25 0xb6a8cd3c in QApplicationPrivate::notify_helper (this=0x8682880, receiver=0x8aadc08, e=0xb66cf00) at kernel/qapplication.cpp:4056
#26 0xb6a9503e in QApplication::notify (this=0x867cdc8, receiver=0x8aadc08, e=0xb66cf00) at kernel/qapplication.cpp:3603
#27 0xb759d85d in KApplication::notify (this=0x867cdc8, receiver=0x8aadc08, event=0xb66cf00) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#28 0xb7fcfbcb in QCoreApplication::notifyInternal (this=0x867cdc8, receiver=0x8aadc08, event=0xb66cf00) at kernel/qcoreapplication.cpp:610
#29 0xb7fd0825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8602b38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#30 0xb7fd0a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#31 0xb7ffb6af in postEventSourceDispatch (s=0x8684910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 0xb663fb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb66430eb in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb6643268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb7ffb2f8 in QEventDispatcherGlib::processEvents (this=0x8682598, flags={i = -1075863416}) at kernel/qeventdispatcher_glib.cpp:327
#36 0xb6b2ea75 in QGuiEventDispatcherGlib::processEvents (this=0x8682598, flags={i = -1075863368}) at kernel/qguieventdispatcher_glib.cpp:202
#37 0xb7fce1fa in QEventLoop::processEvents (this=0xbfdfa130, flags={i = -1075863304}) at kernel/qeventloop.cpp:149
#38 0xb7fce642 in QEventLoop::exec (this=0xbfdfa130, flags={i = -1075863240}) at kernel/qeventloop.cpp:201
#39 0xb7fd0ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#40 0xb6a8cbb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#41 0xb3cf3310 in kdemain (argc=1, argv=0x866a150) at /build/buildd/kdebase-workspace-4.3.1/plasma/shells/desktop/main.cpp:50
#42 0x0804e27d in launch (argc=1, _name=0x864a474 "/usr/bin/plasma-desktop", args=0x864a48c "", cwd=0x0, envc=0, envs=0x864a490 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805136d "0") at /build/buildd/kde4libs-4.3.1/kinit/kinit.cpp:677
#43 0x0804ea5d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.3.1/kinit/kinit.cpp:1169
#44 0x0804efe5 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.3.1/kinit/kinit.cpp:1362
#45 0x0804fbca in main (argc=2, argv=0xbfdfa924, envp=0xbfdfa930) at /build/buildd/kde4libs-4.3.1/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-05 01:25:31 UTC
Merging with bug 196695. Thanks

*** This bug has been marked as a duplicate of bug 196695 ***