Bug 218942 - Kwin crashes randomily (click on button in dolphin, moseover the aplications on panel..) [KWin::Scene::Window::buildQuads, KWin::Scene::paintGenericScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashes randomily (click on button in dolphin, moseover the aplications ...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-16 16:19 UTC by Tom Kijas
Modified: 2009-12-16 16:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Kijas 2009-12-16 16:19:06 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.32-020632-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
When I move over the aplication in the aplication bar in the panel, the kwin sometime crashes, also when I crash on some buttons in dolphin, don't know what can be the problem :(

The crash can be reproduced some of the times.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x2c6eda0, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007fea8d96f08e in KWin::Scene::paintGenericScreen (this=0x2688c70, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:193
#7  0x00007fea8d96e24a in KWin::Scene::finalPaintScreen (this=0x2688c70, mask=32, region=<value optimized out>, data=...) at ../../kwin/scene.cpp:174
#8  0x00007fea8d985096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=) at ../../kwin/effects.cpp:126
#9  0x00007fea7c5bfdc8 in KWin::SnowEffect::paintScreen (this=0x2770fd0, mask=32, region=) at ../../../kwin/effects/snow/snow.cpp:120
#10 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#11 0x00007fea7c56b42f in KWin::LogoutEffect::paintScreen (this=0x263c820, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#12 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#13 0x00007fea7c58a610 in KWin::ShadowEffect::paintScreen (this=0x270cc30, mask=32, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#14 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#15 0x00007fea7c571b02 in KWin::PresentWindowsEffect::paintScreen (this=0x2731fc0, mask=32, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#16 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#17 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#19 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#21 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#23 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#24 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#25 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#27 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#29 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#31 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#33 0x00007fea7c557772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#34 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#35 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#36 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#37 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#39 0x00007fea7c5a40c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=32, region=) at ../../../kwin/effects/cube/cube.cpp:697
#40 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#41 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#43 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#45 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#47 0x00007fea7c59b534 in KWin::CoverSwitchEffect::paintScreen (this=0x2767a30, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#48 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#49 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#51 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#53 0x00007fea7c5b99da in KWin::MouseMarkEffect::paintScreen (this=0x26eb780, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/mousemark/mousemark.cpp:78
#54 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#55 0x00007fea8c1a201f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#56 0x00007fea8d98512e in KWin::EffectsHandlerImpl::paintScreen (this=0x2671d00, mask=32, region=) at ../../kwin/effects.cpp:122
#57 0x00007fea8d9702f5 in KWin::Scene::paintScreen (this=0x2688c70, mask=0x7fff2461266c, region=0x7fff24612790) at ../../kwin/scene.cpp:134
#58 0x00007fea8d97e9c0 in KWin::SceneOpenGL::paint (this=0x2688c70, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#59 0x00007fea8d96ac97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#60 0x00007fea8d8f63ce in KWin::Workspace::qt_metacall (this=0x259c500, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24612940) at ./workspace.moc:535
#61 0x00007fea89541dc3 in QMetaObject::activate (sender=0x259c970, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1c4) at kernel/qobject.cpp:3294
#62 0x00007fea8953ea33 in QObject::event (this=0x259c970, e=0x7fff24613000) at kernel/qobject.cpp:1224
#63 0x00007fea89c7be8c in QApplicationPrivate::notify_helper (this=0x24a9e10, receiver=0x259c970, e=0x7fff24613000) at kernel/qapplication.cpp:4242
#64 0x00007fea89c8248d in QApplication::notify (this=0x7fff24613360, receiver=0x259c970, e=0x7fff24613000) at kernel/qapplication.cpp:4125
#65 0x00007fea8d13d666 in KApplication::notify (this=0x7fff24613360, receiver=0x259c970, event=0x7fff24613000) at ../../kdeui/kernel/kapplication.cpp:302
#66 0x00007fea8952f04c in QCoreApplication::notifyInternal (this=0x7fff24613360, receiver=0x259c970, event=0x7fff24613000) at kernel/qcoreapplication.cpp:704
#67 0x00007fea8955bd52 in QCoreApplication::sendEvent (this=0x24adc30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x24adc30) at kernel/qeventdispatcher_unix.cpp:603
#69 0x00007fea89558958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#70 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#71 0x00007fea82400bbe in g_main_dispatch (context=0x24ac8e0) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#72 IA__g_main_context_dispatch (context=0x24ac8e0) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#73 0x00007fea82404588 in g_main_context_iterate (context=0x24ac8e0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#74 0x00007fea824046b0 in IA__g_main_context_iteration (context=0x24ac8e0, may_block=1) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#75 0x00007fea89558623 in QEventDispatcherGlib::processEvents (this=0x24904e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#76 0x00007fea89d2a2fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff246107d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#77 0x00007fea8952d972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#78 0x00007fea8952dd4c in QEventLoop::exec (this=0x7fff246132a0, flags=) at kernel/qeventloop.cpp:201
#79 0x00007fea89531a8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#80 0x00007fea8d90f98e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#81 0x00007fea8d570abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff24613868) at libc-start.c:220
#82 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 218936, bug 217671.

Reported using DrKonqi
Comment 1 Thomas Lübking 2009-12-16 16:25:51 UTC

*** This bug has been marked as a duplicate of bug 216908 ***