Bug 218936 - Kwin crashed after open kpackagekit [KWin::Scene::Window::buildQuads, KWin::Scene::paintGenericScreen, KWin::Scene::finalPaintScreen]
Summary: Kwin crashed after open kpackagekit [KWin::Scene::Window::buildQuads, KWin::S...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-16 16:06 UTC by Tom Kijas
Modified: 2009-12-16 20:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Kijas 2009-12-16 16:06:41 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.32-020632-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
Kwin crashed and showed me this bug report when I start kpackagekit in ubuntu, I have compositing effects enabled, NVIDIA 9600 card...

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x1f35690, force=<value optimized out>) at ../../kwin/scene.cpp:485
#6  0x00007ff88cd8b08e in KWin::Scene::paintGenericScreen (this=0x10bf890, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:193
#7  0x00007ff88cd8a24a in KWin::Scene::finalPaintScreen (this=0x10bf890, mask=32, region=<value optimized out>, data=...) at ../../kwin/scene.cpp:174
#8  0x00007ff88cda1096 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=) at ../../kwin/effects.cpp:126
#9  0x00007ff87ad82dc8 in KWin::SnowEffect::paintScreen (this=0x1598a20, mask=32, region=) at ../../../kwin/effects/snow/snow.cpp:120
#10 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#11 0x00007ff87ad2e42f in KWin::LogoutEffect::paintScreen (this=0x189a290, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:196
#12 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#13 0x00007ff87ad4d610 in KWin::ShadowEffect::paintScreen (this=0x1589380, mask=32, region=) at ../../../kwin/effects/shadow/shadow.cpp:182
#14 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#15 0x00007ff87ad34b02 in KWin::PresentWindowsEffect::paintScreen (this=0x15451b0, mask=32, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:191
#16 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#17 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#19 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#20 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#21 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#23 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#24 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#25 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#27 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#29 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#31 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#33 0x00007ff87ad1a772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:151
#34 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#35 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#36 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#37 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#39 0x00007ff87ad670c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=32, region=) at ../../../kwin/effects/cube/cube.cpp:697
#40 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#41 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#43 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#45 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#47 0x00007ff87ad5e534 in KWin::CoverSwitchEffect::paintScreen (this=0x1593790, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:124
#48 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#49 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#51 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#53 0x00007ff87ad7c9da in KWin::MouseMarkEffect::paintScreen (this=0x1056850, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/mousemark/mousemark.cpp:78
#54 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#55 0x00007ff88b5be01f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#56 0x00007ff88cda112e in KWin::EffectsHandlerImpl::paintScreen (this=0x17fcf80, mask=32, region=) at ../../kwin/effects.cpp:122
#57 0x00007ff88cd8c2f5 in KWin::Scene::paintScreen (this=0x10bf890, mask=0x7fff21f5cb2c, region=0x7fff21f5cc50) at ../../kwin/scene.cpp:134
#58 0x00007ff88cd9a9c0 in KWin::SceneOpenGL::paint (this=0x10bf890, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:747
#59 0x00007ff88cd86c97 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:424
#60 0x00007ff88cd123ce in KWin::Workspace::qt_metacall (this=0xf11270, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff21f5ce00) at ./workspace.moc:535
#61 0x00007ff88895ddc3 in QMetaObject::activate (sender=0xf116e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x15b) at kernel/qobject.cpp:3294
#62 0x00007ff88895aa33 in QObject::event (this=0xf116e0, e=0x7fff21f5d4c0) at kernel/qobject.cpp:1224
#63 0x00007ff889097e8c in QApplicationPrivate::notify_helper (this=0xe447b0, receiver=0xf116e0, e=0x7fff21f5d4c0) at kernel/qapplication.cpp:4242
#64 0x00007ff88909e48d in QApplication::notify (this=0x7fff21f5d820, receiver=0xf116e0, e=0x7fff21f5d4c0) at kernel/qapplication.cpp:4125
#65 0x00007ff88c559666 in KApplication::notify (this=0x7fff21f5d820, receiver=0xf116e0, event=0x7fff21f5d4c0) at ../../kdeui/kernel/kapplication.cpp:302
#66 0x00007ff88894b04c in QCoreApplication::notifyInternal (this=0x7fff21f5d820, receiver=0xf116e0, event=0x7fff21f5d4c0) at kernel/qcoreapplication.cpp:704
#67 0x00007ff888977d52 in QCoreApplication::sendEvent (this=0xe48540) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0xe48540) at kernel/qeventdispatcher_unix.cpp:603
#69 0x00007ff888974958 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#70 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#71 0x00007ff88181cbbe in g_main_dispatch (context=0xe47200) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#72 IA__g_main_context_dispatch (context=0xe47200) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#73 0x00007ff881820588 in g_main_context_iterate (context=0xe47200, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#74 0x00007ff8818206b0 in IA__g_main_context_iteration (context=0xe47200, may_block=1) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#75 0x00007ff888974623 in QEventDispatcherGlib::processEvents (this=0xe2b0f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#76 0x00007ff8891462fe in QGuiEventDispatcherGlib::processEvents (this=0x7fff21f5ac90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#77 0x00007ff888949972 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#78 0x00007ff888949d4c in QEventLoop::exec (this=0x7fff21f5d760, flags=) at kernel/qeventloop.cpp:201
#79 0x00007ff88894da8b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#80 0x00007ff88cd2b98e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:526
#81 0x00007ff88c98cabd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff21f5dd28) at libc-start.c:220
#82 0x0000000000400679 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 217671.

Reported using DrKonqi
Comment 1 Thomas Lübking 2009-12-16 16:21:52 UTC

*** This bug has been marked as a duplicate of bug 216908 ***
Comment 2 Tom Kijas 2009-12-16 20:16:30 UTC
But I didn't use konqueror.... ? So how can it be duplicate of the bug 216908?
Comment 3 Thomas Lübking 2009-12-16 20:32:57 UTC
the actual client is not important - the segfault happens due to an invalid and not catched typecast in the buildQuads() function, pretty nasty and famous bug ;-)