Bug 217671 - kwin crashs after closing a dialog [KWin::Scene::Window::buildQuads, KWin::Scene::paintGenericScreen, KWin::Scene::finalPaintScreen]
Summary: kwin crashs after closing a dialog [KWin::Scene::Window::buildQuads, KWin::Sc...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-07 01:48 UTC by Marcel
Modified: 2009-12-08 09:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel 2009-12-07 01:48:45 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 196")
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)) "release 196"
Qt Version: 4.6.0
Operating System: Linux 2.6.31.5-0.1-default x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
I closed a dialog-window from kbluetooth and kwin crashes. I have the desktop-effect activated which is floating modal windows (in german the effect is called: Schweben).

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x116e950, force=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#6  0x00007f27e0362fbe in KWin::Scene::paintGenericScreen (this=0x7d8100, orig_mask=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:193
#7  0x00007f27e036217a in KWin::Scene::finalPaintScreen (this=0x7d8100, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:174
#8  0x00007f27e0378fc6 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#9  0x00007f27cfb95d88 in KWin::SnowEffect::paintScreen (this=0x8b51d0, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/snow/snow.cpp:120
#10 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#11 0x00007f27cfb4140f in KWin::LogoutEffect::paintScreen (this=0x9f6ed0, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#12 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#13 0x00007f27cfb605f0 in KWin::ShadowEffect::paintScreen (this=0x8b2700, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#14 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#15 0x00007f27cfb47ae2 in KWin::PresentWindowsEffect::paintScreen (this=0x941790, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#16 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#17 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#18 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#19 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#20 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#21 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#22 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#23 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#24 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#25 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#26 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#27 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#28 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#29 0x00007f27cfb2d752 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#30 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#31 0x00007f27cfb65245 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/slide/slide.cpp:86
#32 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#33 0x00007f27cfb7a0a2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/cube/cube.cpp:697
#34 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#35 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#36 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#37 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#38 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#39 0x00007f27cfb71514 in KWin::CoverSwitchEffect::paintScreen (this=0x98d4f0, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/coverswitch/coverswitch.cpp:124
#40 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#41 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#42 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#43 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#44 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#45 0x00007f27cfb8f99a in KWin::MouseMarkEffect::paintScreen (this=0x891bf0, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/mousemark/mousemark.cpp:78
#46 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#47 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#48 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#49 0x00007f27cfb6c333 in KWin::ThumbnailAsideEffect::paintScreen (this=0x933310, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/thumbnailaside/thumbnailaside.cpp:56
#50 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#51 0x00007f27cfb96fd5 in KWin::TrackMouseEffect::paintScreen (this=0x982690, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/trackmouse/trackmouse.cpp:71
#52 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#53 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#54 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#55 0x00007f27debbb11f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#56 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#57 0x00007f27cfb6e141 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/zoom/zoom.cpp:73
#58 0x00007f27e037905e in KWin::EffectsHandlerImpl::paintScreen (this=0x850090, mask=32, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#59 0x00007f27e0364225 in KWin::Scene::paintScreen (this=0x7d8100, mask=0x7fff2c82c73c, region=0x7fff2c82c860) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#60 0x00007f27e03728f0 in KWin::SceneOpenGL::paint (this=0x7d8100, damage=<value optimized out>, toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#61 0x00007f27e035ebc7 in KWin::Workspace::performCompositing (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#62 0x00007f27e02ea2fe in KWin::Workspace::qt_metacall (this=0x834a20, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2c82ca10)
    at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#63 0x00007f27dbf6e2b3 in QMetaObject::activate (sender=0x834e90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x192) at kernel/qobject.cpp:3294
#64 0x00007f27dbf6af23 in QObject::event (this=0x834e90, e=0x7fff2c82d110) at kernel/qobject.cpp:1224
#65 0x00007f27dc6a5bcc in QApplicationPrivate::notify_helper (this=0x62a460, receiver=0x834e90, e=0x7fff2c82d110) at kernel/qapplication.cpp:4242
#66 0x00007f27dc6ac1ed in QApplication::notify (this=0x7fff2c82d520, receiver=0x834e90, e=0x7fff2c82d110) at kernel/qapplication.cpp:4125
#67 0x00007f27dfb498f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#68 0x00007f27dbf5b53c in QCoreApplication::notifyInternal (this=0x7fff2c82d520, receiver=0x834e90, event=0x7fff2c82d110) at kernel/qcoreapplication.cpp:704
#69 0x00007f27dbf882b5 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#70 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:617
#71 0x00007f27dbf84e48 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#72 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#73 0x00007f27d5b26dde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#74 0x00007f27d5b2a7a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#75 0x00007f27d5b2a8d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#76 0x00007f27dbf84b13 in QEventDispatcherGlib::processEvents (this=0x610ae0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#77 0x00007f27dc75294e in QGuiEventDispatcherGlib::processEvents (this=0x7fff2c82a4c0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#78 0x00007f27dbf59e52 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#79 0x00007f27dbf5a22c in QEventLoop::exec (this=0x7fff2c82d460, flags=) at kernel/qeventloop.cpp:201
#80 0x00007f27dbf5df7b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#81 0x00007f27e03038be in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#82 0x00007f27dff78a7d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff2c82da28) at libc-start.c:220
#83 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113
Warning: the current language does not match this frame.
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Martin Flöser 2009-12-07 09:18:35 UTC
This crash report has a small difference compared to the other crashers: it was called from paintGenericScreen instead of paintSimpleScreeen.

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:45:12 UTC

*** This bug has been marked as a duplicate of bug 216908 ***