Bug 211304 - Collapse menu bar into "Control" button (like Dolphin) when menubar is hidden
Summary: Collapse menu bar into "Control" button (like Dolphin) when menubar is hidden
Status: RESOLVED DUPLICATE of bug 424126
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR wishlist with 175 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 216535 278866 329330 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-21 09:29 UTC by Dotan Cohen
Modified: 2020-07-13 01:01 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-10-21 09:29:02 UTC
Version:            (using KDE 4.3.2)
Installed from:    Ubuntu Packages

Please add an option to collapse the menu bar into a toolbar icon. This saves space for small screens. KDE 4 already has precedent in the Cashew menu on the Plasma Panel and Desktop.

An example of a non-KDE application with this feature is the Mozilla add-on Tiny Menu:
https://addons.mozilla.org/en-US/firefox/addon/1455

Tiny Menu Screenshot:
https://addons.mozilla.org/en-US/firefox/images/p/5729/1248469931

MS Office also has this feature.
Comment 1 Dotan Cohen 2009-10-21 09:29:27 UTC
This bug is related:
https://bugs.kde.org/show_bug.cgi?id=169043
Comment 2 Dotan Cohen 2009-10-25 16:34:12 UTC
The icon for the collapsed menu could be the Cashew icon, as currently found on the panel and on the desktop. That would lend consistency to all of KDE.
Comment 3 Christoph Feck 2009-11-28 18:17:51 UTC
*** Bug 216535 has been marked as a duplicate of this bug. ***
Comment 4 Dotan Cohen 2010-05-13 20:30:38 UTC
It seems that a lot of people like the idea of this feature request. See here:
http://agateau.wordpress.com/2010/05/10/getting-menus-out-of-application-windows/
Comment 5 Kai Uwe Broulik 2010-08-31 01:59:47 UTC
Would be nice, if there's then a cashew icon in the top left corner of the icon, moving the menubar a bit to the side, or so. Or better: integrate the thing into the titlebar (which should be possible by now using aurorae) like Office 2007/2010 does.
Comment 6 Kai Uwe Broulik 2010-09-04 02:48:26 UTC
Look, the plasma netbook panel features a bit similar thing:
https://wiki.kubuntu.org/MaverickMeerkat/Beta/Kubuntu?action=AttachFile&do=get&target=maverick-global-menu.png
Would be nice as an option for default KDE for each application though. And please do not entitle it “Menu”, use an icon instead.
Comment 7 Cédric Bellegarde 2011-02-18 13:19:08 UTC
https://bugs.kde.org/show_bug.cgi?id=266596

Another similar idea
Comment 8 Dotan Cohen 2011-04-05 11:11:47 UTC
There seems to be terrific support in the KDE community for this feature:
http://blog.zx2c4.com/548
Comment 9 nschubach 2011-05-26 23:10:24 UTC
I use(d) a similar feature in XP that is missing in Vista/7 ... having it in KDE4 would be a step above and would be great as well:
http://i.imgur.com/b2WD9.png
Comment 10 Kai Uwe Broulik 2011-05-26 23:15:10 UTC
Seems this Menu in Windeco wasn’t finished for 4.7? =(
Comment 11 Christoph Feck 2011-07-30 18:12:10 UTC
*** Bug 278866 has been marked as a duplicate of this bug. ***
Comment 12 Mark 2011-07-30 18:48:27 UTC
(In reply to comment #11)
> *** Bug 278866 has been marked as a duplicate of this bug. ***

that issue might be closed, but it's not a duplicate of this. Just highly related to this. In short the concern remains the same. If this is done/implemented it should work the same in all applications that ship with KDE SC and not one app that has it followed by a dozen apps that don't have it or don't even listen to the CTRL + m command.
Comment 13 Christoph Feck 2013-12-29 14:17:16 UTC
*** Bug 329330 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2020-07-13 01:01:43 UTC

*** This bug has been marked as a duplicate of bug 424126 ***