Bug 169043 - Ability to place a toolbar on the right of the menu bar
Summary: Ability to place a toolbar on the right of the menu bar
Status: RESOLVED INTENTIONAL
Alias: None
Product: HIG
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 120 votes (vote)
Target Milestone: ---
Assignee: Frans Englich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-13 17:24 UTC by Ismael Barros
Modified: 2009-10-21 22:25 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of Thunderbird and Firefox with icons on same row as menubar (52.91 KB, image/png)
2008-09-13 18:28 UTC, Dotan Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ismael Barros 2008-08-13 17:24:35 UTC
Version:           4.1.1 (KDE 4.1.0 (4.1 >= 20080722)) (using 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)), Arch Linux)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25-ARCH

For small desktops, is often very convenient to be able to place a toolbar right next to the menu bar, like firefox does: http://img168.imageshack.us/img168/4299/wishtoolbarho7.png

Right now in konqueror half of the place allocated for the menu bar is being wasted: http://img363.imageshack.us/img363/1008/wishtoolbarrc0.png
Comment 1 FiNeX 2008-08-13 18:28:57 UTC
If I remember correctly, the KDE UI policy is to avoid to have toolbars next the menu bar.

Probably this is a WONTFIX.
Comment 2 Ismael Barros 2008-08-13 18:44:37 UTC
It's a pity.

If is technically possible, I really can't see why it should be avoided. It's a feature that some users will find very helpful, while it won't confuse other users as long as it's not a default.

It's like the ability to remove the text from the icons in the toolbar. Is a bad default for novice users, but for advanced users that want to take the most of their screens, big icons with text are just annoying, and its REALLY helpful being able to switch to small-without-text buttons. That's the traditional configurability that makes KDE my DE of choice.
Comment 3 Christophe Marin 2008-08-13 22:54:32 UTC
Changing product to HIG
Comment 4 Dotan Cohen 2008-09-13 18:28:15 UTC
Created attachment 27401 [details]
Screenshot of Thunderbird and Firefox with icons on same row as menubar

As my laptop has very limited vertical space, I do this with my Mozilla applications. I find it very, very helpful to have the icons on the same row as the menubar, and it is one of two reasons that I use Thunderbird instead of Kmail. Note that in Mozilla applications one can add an extension which saves even more space my replacing the entire Menubar with a single top-level menu, I enabled this feature in one of the applications in my screenshot.
Comment 5 Celeste Lyn Paul 2008-09-14 02:23:18 UTC
Not something we are considering doing ATM
Comment 6 Maciej Pilichowski 2009-02-03 23:05:34 UTC
100% reasonable wish. For me it should be rather even more flexible -- toolbar, menubar, titlebar decorations should be just "blocks" from which user is able to build "bars" as the user see it fits.
Comment 7 Dotan Cohen 2009-02-03 23:19:02 UTC
@Maciej:
The bug is closed because KDE is not considering doing something like this. Sorry.
Comment 8 Dotan Cohen 2009-02-20 22:34:07 UTC
The next version of Ubuntu (9.10) specifically intends to be "...tuned to work even better on screens that are vertically challenged" in the words of Mark Shuttleworth:
https://lists.ubuntu.com/archives/ubuntu-devel-announce/2009-February/000536.html
(second paragraph under Desktop)

Issues like these are very real usability issues today. I suggest that KDE start "consider doing" this because screens are getting smaller, not larger.
Comment 9 Maciej Pilichowski 2009-02-20 23:10:39 UTC
My 2 cents, if anything it should be here set as NEW and closed as WONTFIX at kdelibs level. Because if it is WONTFIX here nobody will touch this -- designing&implementing such feature would be immediately violating HIG, so it would be a buggy software by design. Logic.
Comment 10 Christoph Feck 2009-06-01 17:19:51 UTC
Qt currently does not allow QMenuBar to be placed next to QToolBar widgets. With the more open Qt repository, we might have luck to get some patch accepted for Qt 4.6 (or later). Somebody has to code it, though.
Comment 11 Dotan Cohen 2009-06-02 13:28:48 UTC
Thanks, Christoph. Is there an open Qt feature request? If not, could a dev please file one. Thanks!
Comment 12 Dotan Cohen 2009-10-21 09:29:51 UTC
This bug is related:
https://bugs.kde.org/show_bug.cgi?id=211304
Comment 13 Stefan Endrullis 2009-10-21 22:25:06 UTC
*** This bug has been confirmed by popular vote. ***