Bug 210146 - [Fixed in Qt4.6.1] Plasma crashed after closing grouped window / KRunner crashes when entering a command / (and other situations) [QGraphicsScenePrivate::processDirtyItemsRecursive, QGraphicsScenePrivate::_q_processDirtyItems]
Summary: [Fixed in Qt4.6.1] Plasma crashed after closing grouped window / KRunner cras...
Status: RESOLVED UPSTREAM
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 208338 211183 211429 211438 211591 212031 212958 213102 213253 213870 215065 215823 215850 216055 216096 216102 216267 216335 216544 216772 216903 217041 217166 217250 217602 217798 218255 218259 218931 218950 219109 219366 219379 219664 219673 219972 219982 220032 220237 220247 220279 220527 220620 221098 221430 221523 221586 221852 221854 221954 222001 222293 222310 222394 222415 222460 222525 222554 222558 222695 222720 222792 222876 223041 223230 223327 223399 223949 224063 224082 224273 224471 224499 224522 224524 224538 224660 224801 225476 226165 226205 226276 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-11 05:14 UTC by Christoph Feck
Modified: 2010-03-24 15:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi: --- krunner crashed when i try to launch some application (for example konsole) (10.22 KB, text/plain)
2010-01-08 09:30 UTC, omega
Details
New crash information added by DrKonqi (10.43 KB, text/plain)
2010-01-15 21:19 UTC, omega
Details
New crash information added by DrKonqi (12.52 KB, text/plain)
2010-01-19 14:44 UTC, Lukas Dolezal
Details
New crash information added by DrKonqi (5.39 KB, text/plain)
2010-01-28 14:52 UTC, Peter
Details
New crash information added by DrKonqi (4.91 KB, text/plain)
2010-03-24 15:44 UTC, akibukis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2009-10-11 05:14:24 UTC
Application: plasma-desktop (0.3)
KDE Version: 4.3.71 (KDE 4.3.71 (KDE 4.4 >= 20091007)) (Compiled from sources)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-10-desktop i686

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  QGraphicsScenePrivate::processDirtyItemsRecursive (this=0x819c3e0, item=0x8bd6918, dirtyAncestorContainsChildren=false, parentOpacity=1)
    at /local/git/Qt/qt/src/gui/graphicsview/qgraphicsscene.cpp:4798
#7  0xb6c73d9d in QGraphicsScenePrivate::_q_processDirtyItems (this=0x819c3e0) at /local/git/Qt/qt/src/gui/graphicsview/qgraphicsscene.cpp:455
#8  0xb6c7422e in QGraphicsScene::qt_metacall (this=0x80ec130, _c=InvokeMetaMethod, _id=14, _a=0x812d040) at .moc/release-shared/moc_qgraphicsscene.cpp:128
#9  0xb57f1c84 in Plasma::Corona::qt_metacall (this=0x80ec130, _c=InvokeMetaMethod, _id=18, _a=0x812d040) at /local/build/KDE/kdelibs/plasma/corona.moc:107
#10 0xb3dd1aac in DesktopCorona::qt_metacall (this=0x80ec130, _c=InvokeMetaMethod, _id=18, _a=0x812d040) at /local/build/KDE/kdebase/workspace/plasma/desktop/shell/desktopcorona.moc:78
#11 0xb7dfaeca in QMetaObject::metacall (object=0x80ec130, cl=InvokeMetaMethod, idx=18, argv=0x812d040) at /local/git/Qt/qt/src/corelib/kernel/qmetaobject.cpp:237
#12 0xb7e053f6 in QMetaCallEvent::placeMetaCall (this=0x82e64c8, object=0x80ec130) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:562
#13 0xb7e0644e in QObject::event (this=0x80ec130, e=0x82e64c8) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1238
#14 0xb6c70084 in QGraphicsScene::event (this=0x80ec130, event=0x82e64c8) at /local/git/Qt/qt/src/gui/graphicsview/qgraphicsscene.cpp:3366
#15 0xb660919c in QApplicationPrivate::notify_helper (this=0x80a3928, receiver=0x80ec130, e=0x82e64c8) at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:4251
#16 0xb660fede in QApplication::notify (this=0x809c080, receiver=0x80ec130, e=0x82e64c8) at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:3676
#17 0xb71a5f48 in KApplication::notify (this=0x809c080, receiver=0x80ec130, event=0x82e64c8) at /local/svn/kde/trunk/KDE/kdelibs/kdeui/kernel/kapplication.cpp:302
#18 0xb7df5cbb in QCoreApplication::notifyInternal (this=0x809c080, receiver=0x80ec130, event=0x82e64c8) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:704
#19 0xb7df8693 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../include/QtCore/../../../../git/Qt/qt/src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:1345
#21 0xb7df87fd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:1238
#22 0xb7e21b2f in sendPostedEvents () at ../../include/QtCore/../../../../git/Qt/qt/src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch () at /local/git/Qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:276
#24 0xb6183522 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb6186df8 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb6186f1e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0xb7e21625 in QEventDispatcherGlib::processEvents (this=0x809f5c8, flags=...) at /local/git/Qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:407
#28 0xb66bbf45 in QGuiEventDispatcherGlib::processEvents (this=0x809f5c8, flags=...) at /local/git/Qt/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:202
#29 0xb7df4319 in QEventLoop::processEvents (this=0xbfc6a8a4, flags=) at /local/git/Qt/qt/src/corelib/kernel/qeventloop.cpp:149
#30 0xb7df476a in QEventLoop::exec (this=0xbfc6a8a4, flags=...) at /local/git/Qt/qt/src/corelib/kernel/qeventloop.cpp:201
#31 0xb7df88bf in QCoreApplication::exec () at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:981
#32 0xb6609237 in QApplication::exec () at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:3590
#33 0xb3ddb634 in kdemain (argc=1, argv=0x8098878) at /local/svn/kde/trunk/KDE/kdebase/workspace/plasma/desktop/shell/main.cpp:112
#34 0x0804d8c6 in launch (argc=1, _name=0x809835c "/local/kde4/bin/plasma-desktop", args=0x809837b "", cwd=0x0, envc=0, envs=0x809837f "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805247f "0") at /local/svn/kde/trunk/KDE/kdelibs/kinit/kinit.cpp:705
#35 0x0804e95b in handle_launcher_request (sock=7, who=0x8052718 "launcher") at /local/svn/kde/trunk/KDE/kdelibs/kinit/kinit.cpp:1197
#36 0x0804f086 in handle_requests (waitForPid=0) at /local/svn/kde/trunk/KDE/kdelibs/kinit/kinit.cpp:1390
#37 0x08050501 in main (argc=4, argv=0xbfc6b024, envp=0xbfc6b038) at /local/svn/kde/trunk/KDE/kdelibs/kinit/kinit.cpp:1825

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-11 18:39:01 UTC
I also got this crash on trunk+Qt4.6 but I can really tell about the situation, it may involve closing a window...
Comment 2 Christoph Feck 2009-10-14 01:52:56 UTC
More info: I had five Konqueror windows open. The taskbar groups them to a single button. I could close three of the windows. When I closed the fourth, it crashed again with that error. So I guess it has something to do with a "group" becoming a single item. I get this quite frequently, and it is only annoying because of bug 208733.
Comment 3 Aaron J. Seigo 2009-10-15 03:56:46 UTC
QGraphicsScenePrivate::processDirtyItemsRecursive

this is an upstream bug in Qt. please report it there (but make sure you are running current 4.6 codebase first :)
Comment 4 Dario Andres 2009-10-22 14:37:45 UTC
*** Bug 211183 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-10-22 14:37:59 UTC
*** Bug 211429 has been marked as a duplicate of this bug. ***
Comment 6 Alexis MENARD 2009-10-22 16:53:06 UTC
I cannot reproduce the crash using steps involving konqueror... I need more info or a test case...
Comment 7 Christoph Feck 2009-10-28 01:57:26 UTC
*** Bug 212031 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-11-04 14:25:34 UTC
I have added a detailed stepcase in order to reproduce bug 211591 (which seems to be quite related to this report...) : bug 211591 comment 2 . It is in fact related with grouped taskbar entries requiring attention (flashing)
Regards
Comment 9 Dario Andres 2009-11-04 16:53:16 UTC
*** Bug 213102 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2009-11-05 15:06:19 UTC
*** Bug 213253 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2009-11-05 23:51:41 UTC
Since this is probably related to grouping, here are my taskbar settings: Grouping by Program Name, No Sorting, and all check boxes off.

Still get this crash multiple times a day (I don't use tabs on Konqueror, but use multiple windows). Recompiling Qt 4.6 and KDE trunk daily. I have to remember to keep at least two Konqueror windows open :)

After the last crash right now, I simply opened two Konqueror windows again, visit kde.org on both of them, closed one window -> Plasma crashes. No attention "flashing" was needed.

It also is unrelated to Konqueror, as I get this crash with Dolphin and KGet, too, after closing the last but one window. Hope someone can reproduce :)
Comment 12 Dario Andres 2009-11-06 00:20:22 UTC
@Christoph: have you checked the steps I posted ? Thanks
Comment 13 Dario Andres 2009-11-06 03:47:44 UTC
*** Bug 212958 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2009-11-10 00:16:25 UTC
*** Bug 213870 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-11-18 11:48:59 UTC
*** Bug 215065 has been marked as a duplicate of this bug. ***
Comment 16 Johannes Obermayr 2009-11-21 11:48:09 UTC
Did anyone report this bug upstream?

Related part of bug 211439 is not fixed with Qt 4.6_20091118 and KDE 4.3.75.
Comment 17 Dario Andres 2009-11-23 14:51:28 UTC
*** Bug 215823 has been marked as a duplicate of this bug. ***
Comment 18 Dario Andres 2009-11-24 12:28:02 UTC
*** Bug 215850 has been marked as a duplicate of this bug. ***
Comment 19 Dario Andres 2009-11-25 04:07:42 UTC
Updating: this is still valid in:

Qt: 4.6.0 (kde-qt master commit cd8595efe9aace2afdaa5db37af7cfe82b87e4aa
        Date:   Wed Nov 18 01:33:21 2009 +0100)
KDE: 4.3.77 (KDE 4.3.77 (KDE 4.4 >= 20091123))
kdelibs svn rev. 1053388 / kdebase svn rev. 1053388

---

BTW, I just checked some of the moc code:

the call in Plasma::Corona::qt_metacall is:

case 18: d->offscreenWidgetDestroyed((*reinterpret_cast< QObject*(*)>(_a[1]))); break;
Comment 20 Dario Andres 2009-11-25 12:49:16 UTC
*** Bug 216055 has been marked as a duplicate of this bug. ***
Comment 21 Alexis MENARD 2009-11-25 12:59:28 UTC
I'm on it since two days now...It seems to be a problem with the sibling index attribute in QGraphicsItemPrivate. For some reason the value is wrong so the item is not properly removed from the top levels list in QGraphicsScene, which means when the next processDirtyItem is called, there is a stale pointer in the list. I'm still unable to reproduce it outside plasma, the task manager code is "interessting", reparenting stuff all over the place + the offscreen thingy. I wouldn't say no to help to reproduce it outside Plasma, which will help me to debug and to fix it...
Comment 22 Dario Andres 2009-11-25 15:37:37 UTC
*** Bug 216096 has been marked as a duplicate of this bug. ***
Comment 23 Dario Andres 2009-11-25 15:37:40 UTC
*** Bug 216102 has been marked as a duplicate of this bug. ***
Comment 24 Alexis MENARD 2009-11-26 15:24:59 UTC
Ok Fixed commit 705880f0045ac39140f980d69aec68869213e379

I'll try to snake it into 4.6.0. Worst case i put it on kde-qt repo.

Please report the bug in our public bugtracker next time. Not only me :D, so if i'm in vacations somebody can look at it quicly.
Comment 25 Anne-Marie Mahfouf 2009-11-26 15:51:56 UTC
*** Bug 216267 has been marked as a duplicate of this bug. ***
Comment 26 Dario Andres 2009-11-27 17:43:41 UTC
*** Bug 216335 has been marked as a duplicate of this bug. ***
Comment 27 Dario Andres 2009-11-27 17:44:10 UTC
@Alexis: is bug 211591 the same as this ? Regards
Comment 28 Michael Pyne 2009-11-27 20:32:11 UTC
*** Bug 211591 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2009-11-30 18:32:25 UTC
*** Bug 216544 has been marked as a duplicate of this bug. ***
Comment 30 Dario Andres 2009-11-30 18:32:47 UTC
*** Bug 216772 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2009-12-01 05:00:11 UTC
Latest 4.6 branch has the commit. I only tried four a couple of minutes, but could no longer reproduce it, so it looks fixed.

Thanks Alexis! Usually I only file bug reports for Qt when I am sure the bug is really in Qt, but I will be more blatant next time ;)
Comment 32 Dario Andres 2009-12-01 13:18:34 UTC
*** Bug 216903 has been marked as a duplicate of this bug. ***
Comment 33 Andrey Borzenkov 2009-12-01 19:37:28 UTC
(In reply to comment #31)
> Latest 4.6 branch has the commit.

Is it supposed to be fixed in 4.6.0 or later? Because I just had it again there.

Could someone give URL to commit? Thank you!
Comment 34 Anne-Marie Mahfouf 2009-12-01 20:08:17 UTC
Still present today on trunk with kde-git master
v4.6.0-37-g48a2af2
Comment 35 Alexis MENARD 2009-12-01 20:25:03 UTC
Please read the history, i gave the sha key (705880f0045ac39140f980d69aec68869213e379).Please check your Qt repo.If the commit is not yet in your repo then you'll get the crash.No need to post it again.And no the commit is not in 4.6.0.It was too late so 4.6.1. Otherwise please also read the QT-BUG report where i have posted the patch.
Comment 36 Anne-Marie Mahfouf 2009-12-02 13:39:32 UTC
Alexis: so how do distros get the patch in so we're not flooded by such reports?
Comment 37 Dario Andres 2009-12-04 00:56:26 UTC
*** Bug 217250 has been marked as a duplicate of this bug. ***
Comment 38 Dario Andres 2009-12-04 00:57:31 UTC
*** Bug 217166 has been marked as a duplicate of this bug. ***
Comment 39 Dario Andres 2009-12-04 00:58:43 UTC
*** Bug 217041 has been marked as a duplicate of this bug. ***
Comment 40 Dario Andres 2009-12-06 21:35:07 UTC
*** Bug 217602 has been marked as a duplicate of this bug. ***
Comment 41 Beat Wolf 2009-12-08 00:15:42 UTC
*** Bug 217798 has been marked as a duplicate of this bug. ***
Comment 42 Dario Andres 2009-12-11 12:04:04 UTC
*** Bug 218259 has been marked as a duplicate of this bug. ***
Comment 43 Dario Andres 2009-12-11 12:04:40 UTC
*** Bug 218255 has been marked as a duplicate of this bug. ***
Comment 44 Dario Andres 2009-12-16 18:30:53 UTC
*** Bug 218931 has been marked as a duplicate of this bug. ***
Comment 45 Alexis MENARD 2009-12-17 21:37:53 UTC
*** Bug 211438 has been marked as a duplicate of this bug. ***
Comment 46 Dario Andres 2009-12-18 00:39:12 UTC
*** Bug 219109 has been marked as a duplicate of this bug. ***
Comment 47 Dario Andres 2009-12-20 13:36:20 UTC
*** Bug 219366 has been marked as a duplicate of this bug. ***
Comment 48 Dario Andres 2009-12-20 13:36:22 UTC
*** Bug 219379 has been marked as a duplicate of this bug. ***
Comment 49 Dario Andres 2009-12-22 14:54:47 UTC
*** Bug 219673 has been marked as a duplicate of this bug. ***
Comment 50 Dario Andres 2009-12-24 17:38:43 UTC
*** Bug 219972 has been marked as a duplicate of this bug. ***
Comment 51 Dario Andres 2009-12-24 20:41:00 UTC
*** Bug 219982 has been marked as a duplicate of this bug. ***
Comment 52 Dario Andres 2009-12-24 20:46:54 UTC
*** Bug 219982 has been marked as a duplicate of this bug. ***
Comment 53 Dario Andres 2009-12-25 14:09:38 UTC
*** Bug 220032 has been marked as a duplicate of this bug. ***
Comment 54 Christoph Feck 2009-12-27 14:13:22 UTC
*** Bug 220237 has been marked as a duplicate of this bug. ***
Comment 55 Christoph Feck 2009-12-27 14:13:40 UTC
*** Bug 220247 has been marked as a duplicate of this bug. ***
Comment 56 Jonathan Thomas 2009-12-27 16:19:40 UTC
*** Bug 220279 has been marked as a duplicate of this bug. ***
Comment 57 Jonathan Thomas 2009-12-29 14:53:17 UTC
*** Bug 220527 has been marked as a duplicate of this bug. ***
Comment 58 Dario Andres 2009-12-30 01:37:33 UTC
*** Bug 220620 has been marked as a duplicate of this bug. ***
Comment 59 Dario Andres 2010-01-03 19:28:12 UTC
*** Bug 221098 has been marked as a duplicate of this bug. ***
Comment 60 Dario Andres 2010-01-06 14:46:30 UTC
*** Bug 221523 has been marked as a duplicate of this bug. ***
Comment 61 Jonathan Thomas 2010-01-06 23:24:56 UTC
*** Bug 221586 has been marked as a duplicate of this bug. ***
Comment 62 Jacopo De Simoi 2010-01-08 00:23:32 UTC
*** Bug 221430 has been marked as a duplicate of this bug. ***
Comment 63 omega 2010-01-08 09:30:27 UTC
Created attachment 39681 [details]
New crash information added by DrKonqi:
---
krunner crashed when i try to launch some application (for example konsole)
Comment 64 Dario Andres 2010-01-08 13:02:17 UTC
@omega: the crash is fixed in Qt 4.6.1 and kde-qt. Thanks
Comment 65 Aaron J. Seigo 2010-01-08 23:56:14 UTC
*** Bug 208338 has been marked as a duplicate of this bug. ***
Comment 66 Helio Chissini de Castro 2010-01-09 02:07:07 UTC
Aaron, my qt is 4.6.0 with kde-qt patches
Comment 67 Dario Andres 2010-01-09 02:24:06 UTC
*** Bug 221854 has been marked as a duplicate of this bug. ***
Comment 68 Dario Andres 2010-01-09 02:48:51 UTC
According to http://qt.gitorious.org/+kde-developers/qt/kde-qt/ , the patch was included on December 15... does your build contain that commit (63839f0c and cec34b01) ? If it does, may be there is a new version of the issue...
Comment 69 Jacopo De Simoi 2010-01-09 11:30:43 UTC
*** Bug 218950 has been marked as a duplicate of this bug. ***
Comment 70 Dario Andres 2010-01-09 19:16:15 UTC
*** Bug 221954 has been marked as a duplicate of this bug. ***
Comment 71 Tomas Vavra 2010-01-09 19:24:56 UTC
I can prove that latest version from http://qt.gitorious.org/+kde-developers/qt/kde-qt/ fixing the problem. Thanks to all involved.
Comment 72 Andrey Borzenkov 2010-01-09 19:39:03 UTC
(In reply to comment #68)
> According to http://qt.gitorious.org/+kde-developers/qt/kde-qt/ , the patch was
> included on December 15... does your build contain that commit (63839f0c and
> cec34b01) ? If it does, may be there is a new version of the issue...

Mandriva Qt includes commit 705880f0 which was cherry-picked by 63839f0c.
Comment 73 Dario Andres 2010-01-10 16:21:36 UTC
*** Bug 222001 has been marked as a duplicate of this bug. ***
Comment 74 Helio Chissini de Castro 2010-01-11 12:28:31 UTC
Confirmed with patch 4.4 RC1 not crashes anymore. ( Both compiled and Fedora 12 )
For me is closed bug
Comment 75 Jonathan Thomas 2010-01-11 22:29:20 UTC
*** Bug 222293 has been marked as a duplicate of this bug. ***
Comment 76 Christoph Feck 2010-01-12 01:10:53 UTC
*** Bug 222310 has been marked as a duplicate of this bug. ***
Comment 77 Jonathan Thomas 2010-01-12 16:12:55 UTC
*** Bug 222394 has been marked as a duplicate of this bug. ***
Comment 78 Dario Andres 2010-01-12 18:48:08 UTC
*** Bug 222415 has been marked as a duplicate of this bug. ***
Comment 79 Dario Andres 2010-01-13 13:26:04 UTC
*** Bug 219664 has been marked as a duplicate of this bug. ***
Comment 80 Dario Andres 2010-01-13 13:26:19 UTC
*** Bug 222525 has been marked as a duplicate of this bug. ***
Comment 81 Dario Andres 2010-01-13 14:13:59 UTC
*** Bug 222460 has been marked as a duplicate of this bug. ***
Comment 82 Dario Andres 2010-01-13 17:26:22 UTC
*** Bug 222558 has been marked as a duplicate of this bug. ***
Comment 83 Dario Andres 2010-01-13 17:27:43 UTC
*** Bug 222554 has been marked as a duplicate of this bug. ***
Comment 84 Jonathan Thomas 2010-01-14 17:19:30 UTC
*** Bug 222720 has been marked as a duplicate of this bug. ***
Comment 85 Dario Andres 2010-01-14 23:25:40 UTC
*** Bug 222695 has been marked as a duplicate of this bug. ***
Comment 86 Dario Andres 2010-01-15 00:30:29 UTC
*** Bug 222792 has been marked as a duplicate of this bug. ***
Comment 87 omega 2010-01-15 21:19:17 UTC
Created attachment 39924 [details]
New crash information added by DrKonqi

plasma crashes on closing window of konsole
Comment 88 Dario Andres 2010-01-16 01:10:26 UTC
*** Bug 222876 has been marked as a duplicate of this bug. ***
Comment 89 Dario Andres 2010-01-18 00:54:27 UTC
*** Bug 223041 has been marked as a duplicate of this bug. ***
Comment 90 Dario Andres 2010-01-18 12:20:23 UTC
*** Bug 223230 has been marked as a duplicate of this bug. ***
Comment 91 Dario Andres 2010-01-18 21:35:22 UTC
*** Bug 223327 has been marked as a duplicate of this bug. ***
Comment 92 Dario Andres 2010-01-19 13:47:11 UTC
*** Bug 223399 has been marked as a duplicate of this bug. ***
Comment 93 Lukas Dolezal 2010-01-19 14:44:02 UTC
Created attachment 40037 [details]
New crash information added by DrKonqi

I'm not sure why it crashed (I was dragging file from dolphin to kopete directly - not throught window tab on panel - but it has no deal with this crash IMHO) . I have wheater and two news widgets on desktop and messaging widget on panel. Only one activity.

Hope that report can help you.
Comment 94 Dario Andres 2010-01-24 22:19:57 UTC
*** Bug 224082 has been marked as a duplicate of this bug. ***
Comment 95 Dario Andres 2010-01-25 00:35:51 UTC
*** Bug 224063 has been marked as a duplicate of this bug. ***
Comment 96 Dario Andres 2010-01-26 12:34:22 UTC
*** Bug 224273 has been marked as a duplicate of this bug. ***
Comment 97 Dario Andres 2010-01-26 12:48:33 UTC
*** Bug 223949 has been marked as a duplicate of this bug. ***
Comment 98 Dario Andres 2010-01-27 17:13:55 UTC
*** Bug 224471 has been marked as a duplicate of this bug. ***
Comment 99 Dario Andres 2010-01-27 23:14:40 UTC
*** Bug 224538 has been marked as a duplicate of this bug. ***
Comment 100 Dario Andres 2010-01-27 23:14:47 UTC
*** Bug 224524 has been marked as a duplicate of this bug. ***
Comment 101 Dario Andres 2010-01-27 23:15:07 UTC
*** Bug 224522 has been marked as a duplicate of this bug. ***
Comment 102 Dario Andres 2010-01-27 23:16:39 UTC
*** Bug 224499 has been marked as a duplicate of this bug. ***
Comment 103 m.wege 2010-01-28 00:09:21 UTC
If this bug is fixed in Qt 4.6.1 will KDE 4.4 have a dependency on this Version of Qt so that distros which provides packages for KDE 4.4 also deliver Qt 4.6.1?
Comment 104 Dario Andres 2010-01-28 00:20:24 UTC
You can refer to this thread: http://old.nabble.com/KDE-4.4-Qt-version-td27120421.html
Comment 105 Peter 2010-01-28 14:52:37 UTC
Created attachment 40315 [details]
New crash information added by DrKonqi

Closing grouped window causes plasma to crash:
1.) Grouping in task manager enabled
2.) Open two windows of the same program
3.) Choose another program (give focus to it)
4.) Using task manager, switch to grouped program
5.) Close one of its windows
6.) Bang, you're dead!
Comment 106 Dario Andres 2010-01-28 21:59:13 UTC
*** Bug 224660 has been marked as a duplicate of this bug. ***
Comment 107 Dario Andres 2010-01-29 19:58:55 UTC
*** Bug 224801 has been marked as a duplicate of this bug. ***
Comment 108 Dario Andres 2010-02-04 13:18:02 UTC
*** Bug 225476 has been marked as a duplicate of this bug. ***
Comment 109 Dario Andres 2010-02-10 20:25:22 UTC
*** Bug 226165 has been marked as a duplicate of this bug. ***
Comment 110 Dario Andres 2010-02-10 22:49:06 UTC
*** Bug 226205 has been marked as a duplicate of this bug. ***
Comment 111 Pino Toscano 2010-02-11 11:40:37 UTC
*** Bug 226276 has been marked as a duplicate of this bug. ***
Comment 112 Dario Andres 2010-03-21 23:29:46 UTC
*** Bug 221852 has been marked as a duplicate of this bug. ***
Comment 113 akibukis 2010-03-24 15:44:57 UTC
Created attachment 42234 [details]
New crash information added by DrKonqi

Plasma workspace crash when opening wine app.