Bug 209582 - kded4 QVariant segfault crash on start up [null QVariant, HalPower::brightnessControlsAvailable, Solid::Control::PowerManager::brightnessControlsAvailable]
Summary: kded4 QVariant segfault crash on start up [null QVariant, HalPower::brightnes...
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-daemon (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
: 211930 217512 217805 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-06 00:30 UTC by Keith Rusler
Modified: 2010-10-02 12:04 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Rusler 2009-10-06 00:30:44 UTC
Version:            (using Devel)
Compiler:          GCC-4.4.1 (Linux 2.6.31-gentoo-r1 i686) -march=native -O2 -ggdb
OS:                Linux
Installed from:    Compiled sources

What I was doing when the application crashed:
When starting up kded4. It crashes due to a QVariant::toStringList segfault. I don't know if this has to do with Qt-4.6. As I'm running the latest git version of Qt-4.6. And happens on every startup manually or relogin of KDE4
Comment 1 Dario Andres 2009-10-06 00:55:10 UTC
- Can you post the full backtrace of the crash ?
- What is your KDE SVN version ?
Thanks
Comment 2 Keith Rusler 2009-10-06 01:14:39 UTC
Oppps sorry about not posting a BT.

Application: KDE Daemon (kded4), signal: Segmentation fault
[KCrash Handler]
#6  0xb75e968d in qVariantToHelper<QStringList> (d=..., t=StringList, handler=0xb71da1e0) at kernel/qvariant.cpp:2061
#7  0xb75e5997 in QVariant::toStringList (this=0x0) at kernel/qvariant.cpp:2080
#8  0xb4228f94 in HalPower::brightnessControlsAvailable() () from /usr/lib/kde4/solid_hal_power.so
#9  0xb42967ca in Solid::Control::PowerManager::brightnessControlsAvailable() () from /usr/lib/libsolidcontrol.so.4
#10 0xb4297c8b in Solid::Control::PowerManager::setBrightness(float, QString const&) () from /usr/lib/libsolidcontrol.so.4
#11 0xb43139c8 in PowerDevilDaemon::applyProfile() () from /usr/lib/kde4/kded_powerdevil.so
#12 0xb43142c8 in PowerDevilDaemon::refreshStatus() () from /usr/lib/kde4/kded_powerdevil.so
#13 0xb4317375 in PowerDevilDaemon::PowerDevilDaemon(QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_powerdevil.so
#14 0xb43193b6 in QObject* KPluginFactory::createInstance<PowerDevilDaemon, QObject>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_powerdevil.so
#15 0xb7997b4c in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libkdecore.so.5
#16 0xb8016a5b in Kded::loadModule(KSharedPtr<KService> const&, bool) () from /usr/lib/libkdeinit4_kded4.so
#17 0xb8018317 in Kded::initModules() () from /usr/lib/libkdeinit4_kded4.so
#18 0xb801a59e in KDEDApplication::newInstance() () from /usr/lib/libkdeinit4_kded4.so
#19 0xb7bd0c50 in KUniqueApplicationAdaptor::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkdeui.so.5
#20 0xb7bd1382 in KUniqueApplicationAdaptor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
#21 0xb7738876 in QDBusConnectionPrivate::deliverCall (this=0x80b5698, object=0x8143c50, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#22 0xb77380ae in QDBusConnectionPrivate::activateCall (this=0x80b5698, object=0x8143c50, flags=337, msg=...) at qdbusintegrator.cpp:796
#23 0xb773c6ee in QDBusConnectionPrivate::activateObject (this=0x80b5698, node=..., msg=..., pathStartPos=16) at qdbusintegrator.cpp:1351
#24 0xb773d18d in QDBusActivateObjectEvent::placeMetaCall (this=0x80f1d80) at qdbusintegrator.cpp:1464
#25 0xb75d12d7 in QObject::event (this=0xbfa02cd0, e=0x80f1d80) at kernel/qobject.cpp:1246
#26 0xb75bb4f9 in QCoreApplication::event (this=0xbfa02cd0, e=0x80f1d80) at kernel/qcoreapplication.cpp:1533
#27 0xb6759457 in QApplication::event (this=0xbfa02cd0, e=0x80f1d80) at kernel/qapplication.cpp:2372
#28 0xb675e188 in QApplicationPrivate::notify_helper (this=0x80bc718, receiver=0xbfa02cd0, e=0x80f1d80) at kernel/qapplication.cpp:4198
#29 0xb675c258 in QApplication::notify (this=0xbfa02cd0, receiver=0xbfa02cd0, e=0x80f1d80) at kernel/qapplication.cpp:3682
#30 0xb7bc932a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#31 0xb75b9be5 in QCoreApplication::notifyInternal (this=0xbfa02cd0, receiver=0xbfa02cd0, event=0x80f1d80) at kernel/qcoreapplication.cpp:704
#32 0xb75bd6bd in QCoreApplication::sendEvent (receiver=0xbfa02cd0, event=0x80f1d80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 0xb75bac99 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80a39d0) at kernel/qcoreapplication.cpp:1345
#34 0xb75ba951 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#35 0xb75f1a16 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#36 0xb75f0304 in postEventSourceDispatch (s=0x80be8c0) at kernel/qeventdispatcher_glib.cpp:276
#37 0xb5f6d037 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0xb5f706b0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#39 0xb5f707df in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#40 0xb75f1300 in QEventDispatcherGlib::processEvents (this=0x80bc6d8, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#41 0xb681cbd0 in QGuiEventDispatcherGlib::processEvents (this=0x80bc6d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#42 0xb75b7047 in QEventLoop::processEvents (this=0xbfa02c1c, flags=...) at kernel/qeventloop.cpp:149
#43 0xb75b718c in QEventLoop::exec (this=0xbfa02c1c, flags=...) at kernel/qeventloop.cpp:201
#44 0xb75ba2c1 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#45 0xb675bf10 in QApplication::exec () at kernel/qapplication.cpp:3603
#46 0xb8018f4d in kdemain () from /usr/lib/libkdeinit4_kded4.so
#47 0x080487cb in main ()

Path: .
URL: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdelibs
Repository Root: svn://anonsvn.kde.org/home/kde
Repository UUID: 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Revision: 1031765
Node Kind: directory
Schedule: normal
Last Changed Author: aseigo
Last Changed Rev: 1031762
Last Changed Date: 2009-10-05 17:44:08 -0500 (Mon, 05 Oct 2009)
Comment 3 Dario Andres 2009-10-06 01:18:45 UTC
Reassigning to Solid..
Thanks
Comment 4 Dario Andres 2009-10-06 02:28:33 UTC
More complete backtrace:
---

Application: KDE Daemon (kded4), signal: Aborted
[KCrash Handler]
#6  0xb7f0e424 in __kernel_vsyscall ()
#7  0xb6015fb1 in raise () from /lib/libc.so.6
#8  0xb60176f2 in abort () from /lib/libc.so.6
#9  0xb7273e37 in qt_message_output (msgType=QtFatalMsg, buf=0x92fb2f0 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 439")
    at global/qglobal.cpp:2200
#10 0xb7273ffa in qt_message (msgType=QtFatalMsg, msg=0xb740f5c8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0xbf8152e4 "\257Z.\264\234Z.\264\070X.\264\267\001") at global/qglobal.cpp:2246
#11 0xb7274418 in qFatal (msg=0xb740f5c8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2429
#12 0xb7273a12 in qt_assert_x (where=0xb42e5aaf "QList<T>::at", what=0xb42e5a9c "index out of range", file=0xb42e5838 "/usr/include/qt4/QtCore/qlist.h", line=439) at global/qglobal.cpp:1971
#13 0xb42e33da in QList<QVariant>::at (this=0xbf8154b4, i=0) at /usr/include/qt4/QtCore/qlist.h:439
#14 0xb42df383 in HalPower::brightnessControlsAvailable (this=0x92f3bd0) at /var/tmp/portage/kde-base/solid-9999/work/solid-9999/solid/hal/halpower.cpp:364
#15 0xb43564d7 in Solid::Control::PowerManager::brightnessControlsAvailable () at /var/tmp/portage/kde-base/solid-9999/work/solid-9999/libs/solid/control/powermanager.cpp:147
#16 0xb4356681 in Solid::Control::PowerManager::setBrightness (brightness=100, device=...) at /var/tmp/portage/kde-base/solid-9999/work/solid-9999/libs/solid/control/powermanager.cpp:157
#17 0xb43f29c8 in PowerDevilDaemon::applyProfile() () from /usr/lib/kde4/kded_powerdevil.so
#18 0xb43f32c8 in PowerDevilDaemon::refreshStatus() () from /usr/lib/kde4/kded_powerdevil.so
#19 0xb43f6375 in PowerDevilDaemon::PowerDevilDaemon(QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_powerdevil.so
#20 0xb43f83b6 in QObject* KPluginFactory::createInstance<PowerDevilDaemon, QObject>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_powerdevil.so
#21 0xb7744752 in KPluginFactory::create (this=0x92f07c8, iface=0x9256db0 "\350\274\360\267\360m%\t\350\065%\t\260`%\t\364\063O\267", parentWidget=0x0, parent=0x9256db0, args=..., keyword=...)
    at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdecore/util/kpluginfactory.cpp:191
#22 0xb7f05009 in KPluginFactory::create<KDEDModule> (this=0x92f07c8, parent=0x9256db0, args=...) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdecore/util/kpluginfactory.h:491
#23 0xb7efe824 in Kded::loadModule (this=0x9256db0, s=..., onDemand=false) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kded/kded.cpp:376
#24 0xb7eff5bf in Kded::initModules (this=0x9256db0) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kded/kded.cpp:234
#25 0xb7f054f0 in KDEDApplication::newInstance (this=0xbf8168c8) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kded/kded.cpp:856
#26 0xb79d4c9e in KUniqueApplicationAdaptor::newInstance (this=0x92a0e08, asn_id=..., args=...) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdeui/kernel/kuniqueapplication.cpp:459
#27 0xb79d4d42 in KUniqueApplicationAdaptor::qt_metacall (this=0x92a0e08, _c=InvokeMetaMethod, _id=0, _a=0xbf815d04)
    at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999_build/kdeui/kuniqueapplication_p.moc:81
#28 0xb7511876 in QDBusConnectionPrivate::deliverCall (this=0x9250688, object=0x92a0e08, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#29 0xb75110ae in QDBusConnectionPrivate::activateCall (this=0x9250688, object=0x92a0e08, flags=337, msg=...) at qdbusintegrator.cpp:796
#30 0xb75156ee in QDBusConnectionPrivate::activateObject (this=0x9250688, node=..., msg=..., pathStartPos=16) at qdbusintegrator.cpp:1351
#31 0xb751618d in QDBusActivateObjectEvent::placeMetaCall (this=0x92ab4a0) at qdbusintegrator.cpp:1464
#32 0xb73aa2d7 in QObject::event (this=0xbf8168c8, e=0x92ab4a0) at kernel/qobject.cpp:1246
#33 0xb73944f9 in QCoreApplication::event (this=0xbf8168c8, e=0x92ab4a0) at kernel/qcoreapplication.cpp:1533
#34 0xb6532457 in QApplication::event (this=0xbf8168c8, e=0x92ab4a0) at kernel/qapplication.cpp:2372
#35 0xb6537188 in QApplicationPrivate::notify_helper (this=0x9257700, receiver=0xbf8168c8, e=0x92ab4a0) at kernel/qapplication.cpp:4198
#36 0xb6535258 in QApplication::notify (this=0xbf8168c8, receiver=0xbf8168c8, e=0x92ab4a0) at kernel/qapplication.cpp:3682
#37 0xb79d0080 in KApplication::notify (this=0xbf8168c8, receiver=0xbf8168c8, event=0x92ab4a0) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdeui/kernel/kapplication.cpp:302
#38 0xb7392be5 in QCoreApplication::notifyInternal (this=0xbf8168c8, receiver=0xbf8168c8, event=0x92ab4a0) at kernel/qcoreapplication.cpp:704
#39 0xb73966bd in QCoreApplication::sendEvent (receiver=0xbf8168c8, event=0x92ab4a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 0xb7393c99 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x923e9d0) at kernel/qcoreapplication.cpp:1345
#41 0xb7393951 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#42 0xb73caa16 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 0xb73c9304 in postEventSourceDispatch (s=0x925a2b8) at kernel/qeventdispatcher_glib.cpp:276
#44 0xb5d3a037 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb5d3d6b0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#46 0xb5d3d7df in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb73ca300 in QEventDispatcherGlib::processEvents (this=0x92576c0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#48 0xb65f5bd0 in QGuiEventDispatcherGlib::processEvents (this=0x92576c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#49 0xb7390047 in QEventLoop::processEvents (this=0xbf81680c, flags=...) at kernel/qeventloop.cpp:149
#50 0xb739018c in QEventLoop::exec (this=0xbf81680c, flags=...) at kernel/qeventloop.cpp:201
#51 0xb73932c1 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#52 0xb6534f10 in QApplication::exec () at kernel/qapplication.cpp:3603
#53 0xb7f00659 in kdemain (argc=1, argv=0xbf816a44) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kded/kded.cpp:932
#54 0x080487eb in main (argc=1, argv=0xbf816a44) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999_build/kded/kded4_dummy.cpp:3
Comment 5 Christopher Neufeld 2009-10-20 04:21:43 UTC
I experienced this problem earlier today, it turned out to be due to bad permissions in the dbus, not allowing me into the hald interface.  The hald registers on the system dbus, not the user dbus, so you have to make sure to grant permissions correctly.
Comment 6 Dario Andres 2009-10-26 13:40:39 UTC
From bug 211930:
What I was doing when the application crashed:
Not much to comment, it did work for kde 4.3.0 for me, when i upgraded my
system it started to crash. It might be related to hal and xorg update, but
checking for null pointers in the code should make it more reliable.
Comment 7 Dario Andres 2009-10-26 13:40:39 UTC
*** Bug 211930 has been marked as a duplicate of this bug. ***
Comment 8 popescu liviu 2009-11-11 08:45:11 UTC
same problem
Application: KDE Daemon (kded4), signal: Segmentation fault
[KCrash Handler]
#5  0xb75140e3 in qVariantToHelper<QStringList> (d=@0x0, t=QVariant::StringList, handler=0xb70d8c00) at kernel/qvariant.cpp:2061
#6  0xb750c0e8 in QVariant::toStringList (this=0x0) at kernel/qvariant.cpp:2080
#7  0xb5b25e5e in HalPower::brightnessControlsAvailable (this=0x811b550) at /root/kde/src/KDE/kdebase/workspace/solid/hal/halpower.cpp:364
#8  0xb457ac37 in Solid::Control::PowerManager::brightnessControlsAvailable () at /root/kde/src/KDE/kdebase/workspace/libs/solid/control/powermanager.cpp:147
#9  0xb457ae3f in Solid::Control::PowerManager::setBrightness (brightness=100, device=@0xbf988374) at /root/kde/src/KDE/kdebase/workspace/libs/solid/control/powermanager.cpp:157
#10 0xb45fd5d6 in PowerDevilDaemon::applyProfile (this=0x811a040) at /root/kde/src/KDE/kdebase/workspace/powerdevil/daemon/PowerDevilDaemon.cpp:359
#11 0xb45fbad9 in PowerDevilDaemon::refreshStatus (this=0x811a040) at /root/kde/src/KDE/kdebase/workspace/powerdevil/daemon/PowerDevilDaemon.cpp:303
#12 0xb45fee6a in PowerDevilDaemon (this=0x811a040, parent=0x8085c68) at /root/kde/src/KDE/kdebase/workspace/powerdevil/daemon/PowerDevilDaemon.cpp:200
#13 0xb46022eb in KPluginFactory::createInstance<PowerDevilDaemon, QObject> (parentWidget=0x0, parent=0x8085c68, args=@0xbf988660) at /opt/kde4/include/KDE/../kpluginfactory.h:461
#14 0xb78e669a in KPluginFactory::create (this=0x8119940, iface=0xb7930880 "KDEDModule", parentWidget=0x0, parent=0x8085c68, args=@0xbf988660, keyword=@0xbf988644)
    at /root/kde/src/kdelibs/kdecore/util/kpluginfactory.cpp:191
#15 0xb7f65cea in Kded::loadModule (this=0x8085c68, s=@0xbf988704, onDemand=false) at /root/kde/src/kdelibs/kdecore/util/kpluginfactory.h:491
#16 0xb7f67740 in Kded::initModules (this=0x8085c68) at /root/kde/src/kdelibs/kded/kded.cpp:234
#17 0xb7f692f8 in KDEDApplication::newInstance (this=0xbf9894d0) at /root/kde/src/kdelibs/kded/kded.cpp:856
#18 0xb7b14949 in KUniqueApplicationAdaptor::newInstance (this=0x80e70e8, asn_id=@0x80e54d0, args=@0x80e5150) at /root/kde/src/kdelibs/kdeui/kernel/kuniqueapplication.cpp:459
#19 0xb7b14bfe in KUniqueApplicationAdaptor::qt_metacall (this=0x80e70e8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf988934) at /root/kde/build/kdelibs/kdeui/kuniqueapplication_p.moc:81
#20 0xb7665444 in QDBusConnectionPrivate::deliverCall (this=0x807fab0, object=0x80e70e8, msg=@0x80e54c0, metaTypes=@0xbf988a60, slotIdx=4) at qdbusintegrator.cpp:891
#21 0xb766626a in QDBusConnectionPrivate::activateCall (this=0x807fab0, object=0x80e70e8, flags=337, msg=@0x80e54c0) at qdbusintegrator.cpp:796
#22 0xb76671c8 in QDBusConnectionPrivate::activateObject (this=0x807fab0, node=@0x80e54ac, msg=@0x80e54c0, pathStartPos=16) at qdbusintegrator.cpp:1352
#23 0xb76673c2 in QDBusActivateObjectEvent::placeMetaCall (this=0x80e5480) at qdbusintegrator.cpp:1465
#24 0xb74f88f9 in QObject::event (this=0xbf9894d0, e=0x80e5480) at kernel/qobject.cpp:1246
#25 0xb74e12df in QCoreApplication::event (this=0xbf9894d0, e=0x80e5480) at kernel/qcoreapplication.cpp:1533
#26 0xb65ebfd4 in QApplication::event (this=0xbf9894d0, e=0x80e5480) at kernel/qapplication.cpp:2359
#27 0xb65e66aa in QApplicationPrivate::notify_helper (this=0x8086578, receiver=0xbf9894d0, e=0x80e5480) at kernel/qapplication.cpp:4251
#28 0xb65e6a9d in QApplication::notify (this=0xbf9894d0, receiver=0xbf9894d0, e=0x80e5480) at kernel/qapplication.cpp:3676
#29 0xb7b0ce01 in KApplication::notify (this=0xbf9894d0, receiver=0xbf9894d0, event=0x80e5480) at /root/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:302
#30 0xb74e1d9d in QCoreApplication::notifyInternal (this=0xbf9894d0, receiver=0xbf9894d0, event=0x80e5480) at kernel/qcoreapplication.cpp:704
#31 0xb74e6bba in QCoreApplication::sendEvent (receiver=0xbf9894d0, event=0x80e5480) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 0xb74e2334 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804f7e0) at kernel/qcoreapplication.cpp:1345
#33 0xb74e25ac in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#34 0xb751d837 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#35 0xb751c833 in postEventSourceDispatch (s=0x80888e0) at kernel/qeventdispatcher_glib.cpp:276
#36 0xb5e6e176 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb5e71523 in ?? () from /usr/lib/libglib-2.0.so.0
#38 0x08088858 in ?? ()
#39 0x00000000 in ?? ()
Comment 9 Keith Rusler 2009-11-11 09:12:33 UTC
I fixed the issue. For me it was because hald wasn't running.
Comment 10 popescu liviu 2009-11-11 11:17:31 UTC
at me hald is running 
bash-3.1# lshal |wc -l
1828
bash-3.1#
Comment 11 Andreas Hartmetz 2009-12-03 19:40:27 UTC
SVN commit 1057980 by ahartmetz:

Don't crash when trying to access the first element of an empty list. Check
*all* DBus replies to be sure. Ervin's code was already doing just that,
the more recent code wasn't. Hooray...
CCMAIL: tomjamesgillespie@googlemail.com
BUG: 209582


 M  +41 -24    halpower.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1057980
Comment 12 Dario Andres 2009-12-06 00:33:17 UTC
*** Bug 217512 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2009-12-11 06:41:38 UTC
*** Bug 217805 has been marked as a duplicate of this bug. ***
Comment 14 Dario Andres 2009-12-14 18:41:29 UTC
The reporter of bug 217512 states that the bug could be caused by the user/root not being part of the "plugdev" group (post-installation issue?)