Bug 217805 - kded4 and plasma-desktop processes segfaults at startup
Summary: kded4 and plasma-desktop processes segfaults at startup
Status: RESOLVED DUPLICATE of bug 209582
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 01:33 UTC by Richard Rondu
Modified: 2009-12-11 06:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Rondu 2009-12-08 01:33:24 UTC
Version:            (using KDE 4.3.3)
Compiler:          gcc-4.4.2 
OS:                Linux
Installed from:    Fedora RPMs

In fedora 12, after i logged in in kdm, kde begin to start and a "few" seconds later, kded4 and plasma-desktop processes crash. Krunner is working fine so I can launch several kde apps without any problem but kded4 and plasma-desktop refuse to launch.

Running Qt 4.6 and kde 4.3.3

Laptop: Dell Latitude E6500 (with Intel 4500HD)

kded4 backtrace:

Application: KDE Daemon (kded4), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fc6ff1301ea in QVariant::toDouble(bool*) const () from /usr/lib64/libQtCore.so.4
#6  0x00007fc6edeeecd8 in HalPower::brightness(QString const&) () from /usr/lib64/kde4/solid_hal_power.so
#7  0x00007fc6ee51fd1c in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib64/libsolidcontrol.so.4
#8  0x00007fc6ee520189 in Solid::Control::PowerManager::setBrightness(float, QString const&) () from /usr/lib64/libsolidcontrol.so.4
#9  0x00007fc6ee753be5 in PowerDevilDaemon::applyProfile() () from /usr/lib64/kde4/kded_powerdevil.so
#10 0x00007fc6ee7541a9 in PowerDevilDaemon::acAdapterStateChanged(int, bool) () from /usr/lib64/kde4/kded_powerdevil.so
#11 0x00007fc6ee756968 in PowerDevilDaemon::PowerDevilDaemon(QObject*, QList<QVariant> const&) () from /usr/lib64/kde4/kded_powerdevil.so
#12 0x00007fc6ee75be37 in QObject* KPluginFactory::createInstance<PowerDevilDaemon, QObject>(QWidget*, QObject*, QList<QVariant> const&) () from /usr/lib64/kde4/kded_powerdevil.so
#13 0x00007fc6ff89b3ce in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib64/libkdecore.so.5
#14 0x00007fc70062a4c5 in KLibrary::resolveFunction(char const*) () from /usr/lib64/libkdeinit4_kded4.so
#15 0x00007fc70062bbf5 in KLibrary::resolveFunction(char const*) () from /usr/lib64/libkdeinit4_kded4.so
#16 0x00007fc70062db60 in ?? () from /usr/lib64/libkdeinit4_kded4.so
#17 0x00007fc6ffd4d766 in ?? () from /usr/lib64/libkdeui.so.5
#18 0x00007fc6ffd4dd52 in ?? () from /usr/lib64/libkdeui.so.5
#19 0x00007fc6ff45820e in ?? () from /usr/lib64/libQtDBus.so.4
#20 0x00007fc6ff459507 in ?? () from /usr/lib64/libQtDBus.so.4
#21 0x00007fc6ff459fcd in ?? () from /usr/lib64/libQtDBus.so.4
#22 0x00007fc6ff45a268 in ?? () from /usr/lib64/libQtDBus.so.4
#23 0x00007fc6ff122791 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#24 0x00007fc6fdad9e5d in QApplication::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x00007fc6fdad59cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007fc6fdadbf65 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007fc6ffd46a76 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#28 0x00007fc6ff112a0c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#29 0x00007fc6ff113887 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#30 0x00007fc6ff13c283 in ?? () from /usr/lib64/libQtCore.so.4
#31 0x00007fc6f93a722e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#32 0x00007fc6f93aac18 in ?? () from /lib64/libglib-2.0.so.0
#33 0x00007fc6f93aad3a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#34 0x00007fc6ff13bdc3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#35 0x00007fc6fdb81ebe in ?? () from /usr/lib64/libQtGui.so.4
#36 0x00007fc6ff111342 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#37 0x00007fc6ff11171c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007fc6ff113b39 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#39 0x00007fc70062c6eb in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#40 0x00007fc6fbc90b1d in __libc_start_main () from /lib64/libc.so.6
#41 0x0000000000400709 in _start ()


plasma-desktop backtrace:

Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffe087d2840 (LWP 3486))]

Thread 2 (Thread 0x7ffde0d61710 (LWP 3488)):
#0  0x00007ffe0354604c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffe037cb60b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007ffe0709e2d4 in ?? () from /usr/lib64/libQtNetwork.so.4
#3  0x00007ffe037ca655 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007ffe03541a3a in start_thread () from /lib64/libpthread.so.0
#5  0x00007ffe02b046dd in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffe087d2840 (LWP 3486)):
[KCrash Handler]
#5  0x00007ffe038da1ea in QVariant::toDouble(bool*) const () from /usr/lib64/libQtCore.so.4
#6  0x00007ffde48b4cd8 in HalPower::brightness(QString const&) () from /usr/lib64/kde4/solid_hal_power.so
#7  0x00007ffde71aed1c in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib64/libsolidcontrol.so.4
#8  0x00007ffde5a1f8dd in ?? () from /usr/lib64/kde4/plasma_applet_battery.so
#9  0x00007ffe07e11416 in ?? () from /usr/lib64/libplasma.so.3
#10 0x00007ffe07e124ad in Plasma::Extender::Extender(Plasma::Applet*) () from /usr/lib64/libplasma.so.3
#11 0x00007ffe07dd7a3d in Plasma::Applet::extender() const () from /usr/lib64/libplasma.so.3
#12 0x00007ffde5a22ea9 in ?? () from /usr/lib64/kde4/plasma_applet_battery.so
#13 0x00007ffe07dfdd2a in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#14 0x00007ffe07dfeda2 in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#15 0x00007ffe083cb616 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#16 0x00007ffe083cb8d8 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#17 0x00007ffe083cbaec in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#18 0x00007ffe038cf833 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007ffe038d702f in ?? () from /usr/lib64/libQtCore.so.4
#20 0x00007ffe038cc4ae in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#21 0x00007ffe03ffe9cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007ffe04004f65 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007ffe069c5a76 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007ffe038bca0c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#25 0x00007ffe038e95f2 in ?? () from /usr/lib64/libQtCore.so.4
#26 0x00007ffe038e60d4 in ?? () from /usr/lib64/libQtCore.so.4
#27 0x00007ffdfd8c422e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#28 0x00007ffdfd8c7c18 in ?? () from /lib64/libglib-2.0.so.0
#29 0x00007ffdfd8c7d3a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#30 0x00007ffe038e5dc3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#31 0x00007ffe040aaebe in ?? () from /usr/lib64/libQtGui.so.4
#32 0x00007ffe038bb342 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#33 0x00007ffe038bb71c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#34 0x00007ffe038bdb39 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#35 0x00007ffe083b1f4f in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#36 0x00007ffe02a44b1d in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000400779 in _start ()

Please ask if you need more information.

Regards,

Richard
Comment 1 Christoph Feck 2009-12-08 03:35:32 UTC
Does downgrading your Qt version to Qt 4.5.x help? KDE 4.3.3 may not support the Qt 4.6.0 release.
Comment 2 Christoph Feck 2009-12-08 03:47:06 UTC
If you want to use Qt 4.6 with KDE 4.3, you would have to backport r1035622 and r1057980 to the KDE 4.3 branch to fix this crash.

KDE developers did not backport, as the KDE 4.3 branch is not supposed to be used together with Qt 4.6.
Comment 3 Richard Rondu 2009-12-08 23:52:41 UTC
indeed, downgrading to Qt 4.5 helps. I'll consider backporting those fixes, thanks for the help. Do I need to mark the bug as resolved or something?

Thank you.
Comment 4 Christoph Feck 2009-12-11 06:41:38 UTC

*** This bug has been marked as a duplicate of bug 209582 ***