Bug 208713 - Quicker deletion of multiple duplicate images
Summary: Quicker deletion of multiple duplicate images
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Searches-Similarity (show other bugs)
Version: 1.0.0
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-27 20:05 UTC by Adam Pigg
Modified: 2017-03-01 07:18 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.5.0


Attachments
mockup (12.11 KB, image/png)
2009-09-27 20:06 UTC, Adam Pigg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Pigg 2009-09-27 20:05:12 UTC
Version:           1.0.0-beta4 (using 4.3.1 (KDE 4.3.1), Mandriva Linux release 2010.0 (Cooker) for x86_64)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.31-desktop-2mnb

In the duplicate images search result list, allow multiple images to be selected.

In the main pane, unique images would be shown vertically, with duplicates horizontally.

This way, multiple images can be selected for deletion.
Comment 1 Adam Pigg 2009-09-27 20:06:31 UTC
Created attachment 37201 [details]
mockup
Comment 2 Todd 2010-12-31 18:53:35 UTC
This is a great idea.  The duplicate image search system is very effective, but VERY slow to work with.  

One suggestion: it would be nice if the images were organized by album, so all images from a given album are lined up vertically.  That would easily allow for deleting of all images from a particular album.
Comment 3 caulier.gilles 2011-12-14 16:42:09 UTC
*** Bug 261418 has been marked as a duplicate of this bug. ***
Comment 4 caulier.gilles 2014-08-31 09:18:56 UTC
*** Bug 240738 has been marked as a duplicate of this bug. ***
Comment 5 Mario Frank 2017-02-28 15:06:52 UTC
Choosing multiple duplicates entries from the left sidebar is available since digiKam 5.4.0 (see https://bugs.kde.org/show_bug.cgi?id=366567 ). The reference images are not shown as in the mockup (as mostleft images). But this is not really easy to do. But in upcoming release 5.5.0, the reference images have the mark "Reference image" in their image info and are thus easily recognised. Selection by a selection box is also already available, as is grouping by albums (not vertically but horizontally).

So, I close this file now.
Comment 6 Adam Pigg 2017-02-28 21:19:25 UTC
And only 8+ years later ;)
Comment 7 Mario Frank 2017-03-01 07:18:19 UTC
(In reply to Adam Pigg from comment #6)
> And only 8+ years later ;)

Well, sometimes wishes take a long time to fulfill. And some of the parts of the wish were available at least in 5.0.0. It was just not identified as fixed ;)