Bug 261418 - Improved handling of duplicate images
Summary: Improved handling of duplicate images
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Searches-Similarity (show other bugs)
Version: 1.6.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 23:34 UTC by Eric Seynaeve
Modified: 2019-12-25 07:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seynaeve 2010-12-27 23:34:52 UTC
Version:           1.6.0 (using KDE 4.5.4) 
OS:                Linux

When I want to go through the list of duplicate images, I have to select each item separately and delete one. For a large set of duplicates, this is a time-consuming process.

Maybe it would be better to show a table view, where the rows would be the duplicate items found and the columns would be the different duplicates (possible one column for each folder, it this wouldn't clutter the table). This way, it would be easy to select multiple duplicate items at once before doing an action on them.

Reproducible: Didn't try

Steps to Reproduce:
1. create a large set of duplicate items
2. generate the fingerprints
3. find the duplicates
4. remove the duplicate pictures

Actual Results:  
for each duplicate, following actions are needed:
1. select a picture
2. delete it (delete button, popup, ...)
3. (optional) confirm the delete

Expected Results:  
select multiple duplicate items a once and delete them in one go
Comment 1 caulier.gilles 2011-12-14 16:42:09 UTC

*** This bug has been marked as a duplicate of bug 208713 ***
Comment 2 caulier.gilles 2019-12-25 07:27:33 UTC
Not reproducible using digiKam 7.0.0 beta1.