Bug 206133 - support for Open Street Map
Summary: support for Open Street Map
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Geolocation-Osm (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-03 17:07 UTC by Mikolaj Machowski
Modified: 2017-08-18 16:40 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2009-09-03 17:07:21 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

I'd like to see support for Open Street Map in geolocation plugin. Google Maps are nice (especially search possibility) but they are concentrating on roads. If I want tag place which isn't a road I am out of luck. 
Eg. with OSM I can choose which chapel in St. Pauls in Rome I shoot, with GM I see only grey area.
Comment 1 Michael G. Hansen 2009-09-03 19:43:09 UTC
Do you want to integrate this by embedding HTML directly or via Marble? Integration over Marble would have the advantage that it can also be used offline - at least the full blown Marble client has an offline mode.
Comment 2 caulier.gilles 2009-09-03 19:50:27 UTC
Currently KHTML is used to display googlemaps. 

Note that we need to rewrite googemaps widget to not use a remote web space as relay, since googlemaps api version permit to acess on map without id key. This will be faster and more simple to implement.

Integrating openstreemap over khtml will be easy to add as well, but i'm agree, marble is certainly better than this because we can use it off line.

Perhaps we can create a common widget shared between kipi-plugins and digiKam and hosted in a libs from KDECore (libkexiv2 for example). This widet can include mapwrld support includng marble + googemaps. What do you think about ?

Gilles Caulier
Comment 3 Johannes Wienke 2009-09-25 15:33:35 UTC
#164440 requests the same and suggests this widget: http://www.qt-apps.org/content/show.php/QMapControl?content=72100.

Would that be an option?
Comment 4 caulier.gilles 2009-09-25 15:43:45 UTC
YES

This widget sound cool.

But why iy's not integrated to marblewidget as well ???

Gilles
Comment 5 Michael G. Hansen 2009-11-26 12:41:43 UTC
*** Bug 164440 has been marked as a duplicate of this bug. ***
Comment 6 Torsten Rahn 2009-11-26 22:06:48 UTC
We don't officially offer ready-made Google Maps support.
The reason is that we looked into the Terms of Use for Google Maps as well as the Google Maps API and figured that usage of the Google Maps API inside Marble would be legally problematic. The same is true for several other mapping applications as well (that's why high-profile applications like e.g. Viking and NASA WorldWind don't support Google Maps APIs either). Several Free Software projects have received "warning" letters from Google in the past (like Gaia and Viking) and I'm not keen on receiving something like this for Marble.   

Additionally there is the problem that Google's Terms of Use have been subject to frequent changes in the past which we consider problematic, too.
Also we don't feel keen on supporting non-free maps (as in Free Software).

However technically there's no problem with Marble having support for Google Maps: It works already.
Actually with trunk it's just a matter of changing the Url of an XML file using a text editor.
Comment 7 Torsten Rahn 2009-11-26 22:12:04 UTC
BTW: Marble in trunk has got freely customizable map-tile Urls, so it should be possible to use lots of other map providers as well.
Comment 8 caulier.gilles 2009-11-26 22:16:52 UTC
Great to read that Googlemaps support already exist in marble. I'm very impressioned.

I understand the problematic of license. as marble support plugins, why not to provide googlemaps support by a non offical plugin ? like this you don't take a risk.

Gilles Caulier
Comment 9 Torsten Rahn 2009-11-26 22:30:03 UTC
You don't have to create a plugin. Technically you'd just have to copy over an existing map-dgml file (e.g. the one used by OSM) and then you need to replace the download Url for the tiles by google's server Url. Nothing more. It's just a matter of a text file.
Comment 10 Michael G. Hansen 2010-05-16 21:14:17 UTC
*** Bug 237851 has been marked as a duplicate of this bug. ***
Comment 11 Torsten Rahn 2010-05-17 10:51:44 UTC
BTW: This page shows screenshots of Marble's "inofficial" Google Maps support:

http://edu.kde.org/marble/current_0.9.php
Comment 12 Michael G. Hansen 2010-08-06 18:31:59 UTC
*** Bug 246924 has been marked as a duplicate of this bug. ***
Comment 13 Michael G. Hansen 2010-12-23 19:15:17 UTC
*** Bug 261095 has been marked as a duplicate of this bug. ***
Comment 14 Michael G. Hansen 2011-02-02 22:14:19 UTC
SVN commit 1218561 by mghansen:

Update NEWS. These bugs/wishes are fixed in kipi-plugins 2 beta 2.

FEATURE: 150981
FEATURE: 185143
FEATURE: 195944
FEATURE: 215989
FEATURE: 206133
BUG: 209718



 M  +7 -1      NEWS  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1218561