Bug 199300 - Kbuildsycoca4 crashes after packages update [not null KSycocaEntry::offset, KBuildMimeTypeFactory::save, KBuildSycoca::save]
Summary: Kbuildsycoca4 crashes after packages update [not null KSycocaEntry::offset, K...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 199745 206720 219550 221271 225071 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-07 16:20 UTC by Zdeněk Zikán
Modified: 2010-08-13 22:17 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zdeněk Zikán 2009-07-07 16:20:24 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-13-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
The only thing I was doing was installing new version of Firefox using apt-get ... but I'm really not sure if it can relate to the crash somehow.

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  KSycocaEntry::offset (this=0x9ddeee0) at /build/buildd/kde4libs-4.2.95/kdecore/sycoca/ksycocaentry.cpp:132
#7  0xb4a79b6f in KBuildMimeTypeFactory::save (this=0x9ddeee0, str=@0x9ddee90) at /build/buildd/kde4libs-4.2.95/kded/kbuildmimetypefactory.cpp:306
#8  0xb4a72354 in KBuildSycoca::save (this=0xa2c71c8, str=0x9ddee90) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:525
#9  0xb4a744d5 in KBuildSycoca::recreate (this=0xa2c71c8) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:433
#10 0xb4a764a3 in kdemain (argc=2, argv=0x9d1d548) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:829
#11 0x0804e1c0 in launch (argc=2, _name=0x9d087fc "/usr/bin/kbuildsycoca4", args=0x9d08820 "", cwd=0x0, envc=0, envs=0x9d08825 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x9d08829 "") at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:672
#12 0x0804e99d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1164
#13 0x0804ef25 in handle_requests (waitForPid=0) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1357
#14 0x0804fb0a in main (argc=2, argv=0xbfd1bff4, envp=0xbfd1c000) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1784

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-07 16:45:48 UTC
Did you installed KDE from Ubuntu packages or from any other way?
THanks
Comment 2 Zdeněk Zikán 2009-07-07 17:07:59 UTC
I have them installed from Kubuntu Backports PPA (http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu)
Comment 3 BLeAm 2009-07-11 14:16:54 UTC
I'm not so sure whether does this help, but in my case, I've removed .local and .config which is located in home directory(Additional, I've also removed all FILES in ~/.kde/cache-{systemname}/ and all FILES in ~/.kde/cache-{systemname}/kpc.) then re-login and that crash of kbuildsyscoca4 has gone.
Comment 4 Christoph 2009-08-06 12:33:52 UTC
I also experienced this bug when I updated kde from the kubuntu Backports PPA.
Now I can't start kde or run any kde apps from gnome, I get a kbuildsycoca4 crash.
The "KDE Crash Handler" that automatically starts gives the following information:

Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic x86_64
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: KBuildSycoca (kbuildsycoca4), signal: Segmentation fault
[KCrash Handler]
#5  KSycocaEntry::offset (this=0x0) at /build/buildd/kde4libs-4.3.0/kdecore/sycoca/ksycocaentry.cpp:132
#6  0x00007f71e521f9a8 in KBuildMimeTypeFactory::savePatternLists (this=0x14cc320, str=@0x148ca30) at /build/buildd/kde4libs-4.3.0/kded/kbuildmimetypefactory.cpp:361
#7  0x00007f71e521fe63 in KBuildMimeTypeFactory::save (this=0x14cc320, str=@0x148ca30) at /build/buildd/kde4libs-4.3.0/kded/kbuildmimetypefactory.cpp:307
#8  0x00007f71e5218d61 in KBuildSycoca::save (this=0x14cccb0, str=0x148ca30) at /build/buildd/kde4libs-4.3.0/kded/kbuildsycoca.cpp:525
#9  0x00007f71e521af05 in KBuildSycoca::recreate (this=0x14cccb0) at /build/buildd/kde4libs-4.3.0/kded/kbuildsycoca.cpp:433
#10 0x00007f71e521cd5c in kdemain (argc=1, argv=0x7fffed667b78) at /build/buildd/kde4libs-4.3.0/kded/kbuildsycoca.cpp:829
#11 0x00007f71e1d925a6 in __libc_start_main (main=0x4007d0 <main>, argc=1, ubp_av=0x7fffed667b78, init=0x400800 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffed667b68) at libc-start.c:220
#12 0x0000000000400709 in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 5 Christoph 2009-08-08 13:45:09 UTC
I think bug 202871 is a duplicate of this bug, because if I remove the ~/.local/share/mime/globs file, the problem is resolved. And I can confirm the description of that bug 202871: kbuildsycoca4 also crashes if ~/.local/share/mime/globs is empty.
Comment 6 FiNeX 2009-09-08 11:40:30 UTC
*** Bug 206720 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-10-11 21:46:23 UTC
*** Bug 199745 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-11-14 16:18:48 UTC

*** This bug has been marked as a duplicate of bug 202871 ***
Comment 9 Dario Andres 2009-12-21 17:40:43 UTC
Reopening as this is a different crash.
Christoph's comments (comment 4 and comment 5) are indeed bug 202871 (which is fixed in SC 4.4beta2), but it seems they are unrelated to this (which is still unfixed).
Comment 10 Dario Andres 2009-12-21 17:41:21 UTC
From bug 219550:
---
What I was doing when the application crashed:
I was installing a number of new packages through Add/Remove Applications
including some that required confirmation, such as Sun Java 6.  The message
appeared after to downloads, while the packages were being installed -- but I
can't remember which package was being installed at the time.
Comment 11 Dario Andres 2009-12-21 17:41:24 UTC
*** Bug 219550 has been marked as a duplicate of this bug. ***
Comment 12 David Faure 2009-12-21 17:49:58 UTC
Everyone with this crash: please check if you don't have the umask problem that leads to bug 202871 (I'm still not sure if it's the same bug or not).

More precisely: type
 ls -l ~/.local/share/mime
and check if any directory misses "x" permissions in the 4th character, like
 drw-r--r--

If so, making the directory executable (+x) again will fix the crash, and then this is the same as 202871. Otherwise, I need a way to reproduce this one...
Comment 13 David Faure 2009-12-21 17:51:04 UTC
Also, is anyone here not using Ubuntu? From a quick look, it seems like a Ubuntu-only crash?
Comment 14 Christoph Feck 2010-01-04 21:25:01 UTC
*** Bug 221271 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2010-01-31 23:48:54 UTC
*** Bug 225071 has been marked as a duplicate of this bug. ***
Comment 16 Nicolas L. 2010-08-13 22:17:37 UTC
fixed in kde 4.4