Bug 199745 - Crash on fresh startup, KDE took too long with kinit.
Summary: Crash on fresh startup, KDE took too long with kinit.
Status: RESOLVED DUPLICATE of bug 199300
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-11 05:33 UTC by BLeAm
Modified: 2009-10-11 21:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BLeAm 2009-07-11 05:33:36 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Qt Version: 4.5.0
Operating System: Linux 2.6.30-020630-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  KSycocaEntry::offset (this=0x82eaa50) at /build/buildd/kde4libs-4.2.95/kdecore/sycoca/ksycocaentry.cpp:132
#7  0xb3ba5b6f in KBuildMimeTypeFactory::save (this=0x82eaa50, str=@0x816a870) at /build/buildd/kde4libs-4.2.95/kded/kbuildmimetypefactory.cpp:306
#8  0xb3b9e354 in KBuildSycoca::save (this=0x85f0c58, str=0x816a870) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:525
#9  0xb3ba04d5 in KBuildSycoca::recreate (this=0x85f0c58) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:433
#10 0xb3ba24a3 in kdemain (argc=2, argv=0x80b31f0) at /build/buildd/kde4libs-4.2.95/kded/kbuildsycoca.cpp:829
#11 0x0804e1c0 in launch (argc=2, _name=0x80d2b74 "/usr/bin/kbuildsycoca4", args=0x80d2b98 "", cwd=0x0, envc=1, envs=0x80d2b9d "DISPLAY=:0.0", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80d2bae "iBox;1247282893;519352;3849_TIME0") at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:672
#12 0x0804e99d in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1164
#13 0x0804ef25 in handle_requests (waitForPid=3852) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1357
#14 0x0804faa6 in main (argc=2, argv=0xbfd17124, envp=0xbfd17130) at /build/buildd/kde4libs-4.2.95/kinit/kinit.cpp:1747

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-11 12:58:13 UTC
Did you also used the "Kubuntu Backports PPA" as bug 199300 ?
Thanks
Comment 2 BLeAm 2009-07-11 14:17:35 UTC
I'm not so sure whether does this help, but in my case, I've removed .local and .config which is located in home directory(Additional, I've also removed all FILES in ~/.kde/cache-{systemname}/ and all FILES in ~/.kde/cache-{systemname}/kpc.) then re-login and that crash of kbuildsyscoca4 has gone.
Comment 3 Dario Andres 2009-10-11 21:46:22 UTC

*** This bug has been marked as a duplicate of bug 199300 ***