Bug 195466 - Make tabs reordering nicer (move tabs with left mouse button)
Summary: Make tabs reordering nicer (move tabs with left mouse button)
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: tabbing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: usability
: 195742 230931 247945 249225 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-06 15:31 UTC by Iñaki Baz Castillo
Modified: 2010-12-30 21:30 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iñaki Baz Castillo 2009-06-06 15:31:56 UTC
Version:           4.2.4 (KDE 4.2.4) (using 4.2.4 (KDE 4.2.4), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.28-11-generic

I can't understand with mouse central button is required to move a tab, it doesn't occur in any other web browser. I suggest to use left button for it.

Also, reordering tabs in Konqueror is very poor visually. Please, check how Google Chome makes it cool (you click on a tab, hold it and move around other tabs, so you see the real movement in other tabs).
Comment 1 Frank Reininghaus 2009-06-06 17:13:20 UTC
Thanks for the report! This is related to bug 187895.
Comment 2 Frank Reininghaus 2009-06-09 20:00:47 UTC
*** Bug 195742 has been marked as a duplicate of this bug. ***
Comment 3 Artem S. Tashkinov 2010-01-30 14:07:23 UTC
keyword: HIG!
Comment 4 Iñaki Baz Castillo 2010-01-30 18:38:19 UTC
"HIG" is not a valid keyword acording to the current list: https://bugs.kde.org/describekeywords.cgi

I've set it to "usability".
Comment 5 Artem S. Tashkinov 2010-01-30 19:29:16 UTC
(In reply to comment #4)
> "HIG" is not a valid keyword acording to the current list:
> https://bugs.kde.org/describekeywords.cgi
> 
> I've set it to "usability".

Thank you, and what about confirming this bug? :)
Comment 6 Tommi Tervo 2010-01-30 19:37:06 UTC
happy now ;-D
Comment 7 Artem S. Tashkinov 2010-01-30 21:16:41 UTC
Indeed ;)
Comment 8 Frank Reininghaus 2010-08-18 20:08:44 UTC
*** Bug 230931 has been marked as a duplicate of this bug. ***
Comment 9 Frank Reininghaus 2010-08-18 20:08:52 UTC
*** Bug 247945 has been marked as a duplicate of this bug. ***
Comment 10 Robert Riemann 2010-08-24 10:53:09 UTC
Please make moving tabs easier. I had to look into bugzilla to find out that moving tabs in konqueror is even possible.

Be aware of this recent kde planet blog post about moving tabs. Using this mechanism would also allow to move the tab bar to the right, which would be nice for a lot of wide screen users. ;)

If someone would assist, I would help to solve this wish.
Comment 11 Leonardo La Malfa 2010-08-24 19:30:05 UTC
I was reading this blog post*, and the present bug report came to mind. I don't understand anything about coding, but perhaps Hugo's work may be of help?

* http://hugo-kde.blogspot.com/2010/08/oxygen-rewrite-and-dragging-tabs-around.html
Comment 12 Frank Reininghaus 2010-09-04 10:48:38 UTC
*** Bug 249225 has been marked as a duplicate of this bug. ***
Comment 13 Frank Reininghaus 2010-09-04 10:53:50 UTC
The reason why this is not so easy to implement is the following: Currently, the left mouse button can be used to drag a tab's URL to external applications, and we know that this feature is being used by many users. Making the left mouse button move tabs without breaking this feature is not impossible, but it's not easy to do. There has been some discussion about this on the kfm-devel mailing list:

http://lists.kde.org/?t=125914489100002&r=1&w=2
Comment 14 Mathias Panzenböck 2010-09-04 14:50:52 UTC
It is possible as long as you only animate the moving tabs when the mouse hovers the konqueror window. When you initiate a drag you only get mouse move events as long as the mouse hovers the window you initiated the event in. When you leave the window you could let the tab move back to its origin (and maybe set a drag image). That's basically what I do in Smooth Tasks. It's not ideal but I think it's better than the current situation.
Comment 15 Robert Riemann 2010-09-04 22:42:19 UTC
The most people drag'n'drop the url by dragging the favicon. I think we should stick with the default behavior of other browsers.
Comment 16 oneforall 2010-09-05 03:13:34 UTC
well its not only default for other browsers. It was a default for konq in kde3 too. The middle works but it never clicked in my head to try it all the time I've used kde4 O.o till I was asked on the bug I posted if I had :D. But its still more auto and quicker in our brains to grab with the left button and drag. Anyway its nice to know its being looked into. Firefox does both left to move the tab or move it between 2 windows . You can grab a tab move it out of the window and let go and now you have a new window too. maybe their code has something that could be used .
Comment 17 Iñaki Baz Castillo 2010-09-05 04:12:32 UTC
> --- Comment #16 from  <oneforall gmail com>  2010-09-05 03:13:34 ---
> well its not only default for other browsers. It was a default for konq in kde3

This is not true, KDE3 also uses the middle button for reordering tabs.

> But its still more auto and quicker in our brains to grab with the left button and
> drag.

And IMHO this is the key. I've been using KDE for 5 years and I've
always used Konqueror as web browser. After those 5 yeras, when I want
to move a tab I still press the mouse left button. Something tells me
that this is the logical, intuitive and desirable behavior. Personally
I don't care if dragging with left button has a "special meaning" in
the whole KDE. It shouldn't prevent adopting the most extended and
expected behavior in a web browser.
Comment 18 Robert Riemann 2010-09-05 09:59:05 UTC
What about these people using a Notebook touchpad where there is no easy way to trigger a middle click?
Comment 19 oneforall 2010-09-15 02:40:47 UTC
well seamonkey,firefox etc konsole too you can move the tabs wiht one mouse key wish is much quiker and easier and we don't need to look in docs or bug reports to find out how to do it . As I said firefox,seamonkey does both . you can have 2 windows open drag drop the tabs with the left button and move the tabs between other tabs . Its just strange that it wants to change one of the other tabs to what it has. I was even trying to make sure I was in the middle too lol but no matter each tiem its changes the right or net time the tab to the left of it. I'm sure I moved the tabs in kde3 konq(file mode) never use the broswer mode at all.I'll take you word for it too lazy to reinstall to qemu-system-x86_64 and reboot to my other drive that still has 3.5.9 :). Anyway been nice when it does ;)
Comment 20 Adrián Chaves (Gallaecio) 2010-12-27 15:08:01 UTC
I've noticed this has been "fixed" in KDE 4.6 RC 1. Really nice!
Comment 21 Alexander Potashev 2010-12-30 21:04:08 UTC
I confirm that this was fixed in 4.6 RC1. Please, close the report.
Comment 22 Tommi Tervo 2010-12-30 21:30:36 UTC
Closing as fixed