Bug 191223 - Okular doesn't print the correct range of pages in postscript files
Summary: Okular doesn't print the correct range of pages in postscript files
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: PS backend (show other bugs)
Version: unspecified
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 191590 194742 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-01 11:35 UTC by Stefano Ferri
Modified: 2009-05-31 11:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Ferri 2009-05-01 11:35:55 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Slackware Packages

Okular has a problem when printing postscript files. If a range of pages is selected, Okular always starts to print from the first page. In example, if you specify a range 8-12, Okular prints 1-5. It prints the correct number of pages (5 in this example) but always starts from the first page.
Printing pdf files works fine, only ps have this problem.
Comment 1 Pino Toscano 2009-05-01 13:47:04 UTC
SVN commit 961994 by pino:

export the actual page numbers, instead of the page count
BUG: 191223


 M  +1 -1      generator_ghostview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=961994
Comment 2 Pino Toscano 2009-05-01 13:47:59 UTC
SVN commit 961995 by pino:

backport:
export the actual page numbers, instead of the page count
CCBUG: 191223


 M  +1 -1      generator_ghostview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=961995
Comment 3 Pino Toscano 2009-05-04 15:58:07 UTC
*** Bug 191590 has been marked as a duplicate of this bug. ***
Comment 4 Pino Toscano 2009-05-31 11:37:47 UTC
*** Bug 194742 has been marked as a duplicate of this bug. ***