Bug 190489 - General DPI setting should work and should be more configurable
Summary: General DPI setting should work and should be more configurable
Status: CLOSED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_fonts (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: rik
URL:
Keywords:
: 216666 272792 (view as bug list)
Depends on:
Blocks: 272266
  Show dependency treegraph
 
Reported: 2009-04-24 04:46 UTC by Nicolas Bigaouette
Modified: 2011-09-03 08:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Bigaouette 2009-04-24 04:46:05 UTC
Version:            (using KDE 4.2.2)
Compiler:          gcc 4.3.3 ./configure --prefix=/usr --enable-shared --enable-languages=c,c++,fortran,objc,obj-c++,treelang --enable-threads=posix --mandir=/usr/share/man --infodir=/usr/share/info --enable-__cxa_atexit --disable-multilib --libdir=/usr/lib --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch --with-tune=generic
OS:                Linux
Installed from:    Unspecified Linux

I have a 1920x1200 15' monitor. Ideally, dpi should be 146 or 147 so fonts are readable.

There is an option in System Settings -> Appearence -> Fonts -> Force DPI
with two choices: 96 or 120. Setting it to 120 helps a bit, but I think it is set to 96. Visiting http://mrmazda.no-ip.com/auth/dpi-screen-window.html tells me I'm using 96.
Here is a screenshot:
http://yfrog.com/e9kdedpip

I think it should be configurable to whatever is needed, not only two choices. An option I will try is to add "-dpi 146" to kdmrc's [X-:*-Core]'s ServerArgsLocal.

Maybe it could be a KDM option?

Thanx!
Comment 1 Christoph Feck 2009-11-30 01:59:07 UTC
*** Bug 216666 has been marked as a duplicate of this bug. ***
Comment 2 Bob1024 2010-04-11 15:23:43 UTC
I have exactly the inverse problem with a netbook (needed 80dpi). Replacing the combo-box by a text-box like in gnome or an editable combo-box would be great (or add an "advanced" button)

A workaround: change 

kcmfonts_general_forcefontdpi="80"

in

$HOME/.kde/share/config
Comment 3 Bob1024 2010-04-11 15:26:18 UTC
the file in $HOME/.kde/share/config is startupconfig
Comment 4 Nikos Alexandris 2010-04-11 20:49:07 UTC
plasma-desktop --version
Qt: 4.6.2
KDE Development Platform: 4.4.2 (KDE 4.4.2)
Plasma Workspace: 0.3
OS: (Kubuntu-)Linux 2.6.31-21-generic / 64bit

@Bob1024:

I 've just tried this out on a Macbook Pro 5,1 without success. I've set  "forceFontDPI=110.5" within the file "~/.kde/share/config/kcmfonts" and restarted. I still get:

xdpyinfo | grep dim
  dimensions:    1440x900 pixels (342x222 millimeters)

xdpyinfo | grep res
  resolution:    107x103 dots per inch
Comment 5 Christoph Feck 2011-05-11 21:52:38 UTC
*** Bug 272792 has been marked as a duplicate of this bug. ***
Comment 6 Lukas Sommer 2011-06-01 12:56:25 UTC
I've made a patch for this bug. Please review it at http://git.reviewboard.kde.org/r/101410/
Comment 7 Lukas Sommer 2011-06-11 11:42:57 UTC
Git commit 9e1de272620da40fead11dfdb705cfc3d9a90f10 by Lukas Sommer.
Committed on 11/06/2011 at 11:34.
Pushed by sommer into branch 'master'.

Make font dpi fully configurable by the user

Adopts startkde.cmake to accept dpi values different from 96 and 120.

Adopts the UI in kcontrol to make dpi values from 1 to 1000 possible.
The spinbox uses steps of 24 dpi because the common dpi values 72,
96 and 120 are all multiples of 24. As some fonts are optimized for
these resolutions, this could make fonts look better.
FEATURE: 190489
FIXED-IN: 4.7
REVIEW: 101410
GUI:
DIGEST:

M  +28   -20   kcontrol/fonts/fonts.cpp     
M  +4    -3    kcontrol/fonts/fonts.h     
M  +2    -6    startkde.cmake     

http://commits.kde.org/kde-workspace/9e1de272620da40fead11dfdb705cfc3d9a90f10
Comment 8 Lukas Sommer 2011-06-12 15:47:54 UTC
Reverted and postponed to 4.8 (4.7 was in feature freeze yet).
Comment 9 Lukas Sommer 2011-09-03 08:49:55 UTC
Closing. Is in master for 4.8.