Bug 189464 - Unable to reply to messages in Sent folder
Summary: Unable to reply to messages in Sent folder
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal with 39 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 192271 192414 192608 192746 192771 193659 194995 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-12 16:33 UTC by Andrey Borzenkov
Modified: 2009-06-10 22:14 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2009-04-12 16:33:07 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Mandriva RPMs

4.2.2 with patches from 4.2 branch/Qt4.5. Several POP3 accounts all delivering to the same set of local folders.

I just found that I am unable to reply to mails stored in Sent items. This is actually quite a regression for me - sometimes I find myself in position to add something to already sent message and now the only way is to copy into some other folder and do Reply there.

This definitely worked before, even in 4.2, so it seems recent regression.
Comment 1 Anne Wilson 2009-04-12 18:47:24 UTC
This may well be a Mandriva bug, as I have Fedora's KDE 4.2.2 + qt4.5, and it's possible to use ReplyTo on a message in the Sent folder
Comment 2 Nicolas L. 2009-04-12 20:16:28 UTC
i don't think this can be mandriva bug, but we use some backport patches so i think more that this is a regression because of those patches ( as fedora isn't synced with branch )
Comment 3 Peter Lewis 2009-05-05 12:56:50 UTC
I can confirm this bug in 1.11.90, KDE 4.2.71 (from KDEmod unstable packages).

This is really quite annoying and is a total blocker if, like me, you use your inbox as your sent folder, to get all the messages threaded together. I'm actually unable to reply to any email in this set up!

Help please :-)
Comment 4 Stephan Binner 2009-05-07 12:19:36 UTC
*** Bug 190105 has been marked as a duplicate of this bug. ***
Comment 5 Richard Bos 2009-05-07 13:19:32 UTC
I see the same behaviour, and I think it occured after the upgrade to kde-4.2.3 (that was yesterday).  I did not see this behaviour, while I regurarely reply
on e-mails that are stored in my Sent folder.
Comment 6 Richard Bos 2009-05-07 14:28:33 UTC
My workaround at the moment for this problem is, to copy or move the e-mail from
the Sent folder to my inbox.  It is than possible to reply on the e-mail,
however, this should not be necessary.
Comment 7 eduard 2009-05-07 18:10:23 UTC
I agree it is a blocking bug (I use Mandriva 2009.1) for what is told already here. I use too inbox as my sent folder (I don't know how you, the rest of the world can do different).

So that means that i simply CANNOT REPLY TO ANY MESSAGE FROM INBOX!!! If reply should be disabled (and I don't think so) the FROM address should be the filter and not the folder the message is in.

Anyway, in any case that should be a changeable behaviour. I don't want the system to tell me who I can and who I cannot reply to. I imagine some cases were I maybe want to reply to myself if I use a shared account or I wanna write down a following message that I read afterwards from another IMAP client, for example.
Comment 8 Thomas McGuire 2009-05-07 21:57:59 UTC
SVN commit 965008 by tmcguire:

Allow the user to reply to mails in the sent-mail folder, as often requested.
kolab/issue2150
BUG: 190105


 M  +1 -3      kmheaders.cpp  
 M  +1 -3      kmmainwidget.cpp  
 M  +1 -2      messageactions.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=965008
Comment 9 Thomas McGuire 2009-05-11 21:30:00 UTC
*** Bug 192271 has been marked as a duplicate of this bug. ***
Comment 10 Peter Lewis 2009-05-11 22:09:10 UTC
Thanks Thomas. I can confirm that it's working the way I'm used to again from 4.3 beta 1.

:-)
Comment 11 Thomas McGuire 2009-05-13 23:51:59 UTC
*** Bug 192608 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2009-05-13 23:59:37 UTC
As this bugs seems popular, here a little explanation:

We unfortunately introduced this regression with KDE 4.2.3, because the reply action was in the toolbar, but not in the context menu. Therefore the action was removed from the context menu, to make it more consistent.
Turns out many people actually reply to messages in sent-mail folders, which we didn't anticipate.

So we reverted that behavior and added the reply action back to the toolbar and the context menu.

This fix will be in KDE 4.2.4 and in KDE 4.3 beta 1.
Comment 13 Thomas McGuire 2009-05-15 12:47:21 UTC
*** Bug 192414 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2009-05-15 12:47:32 UTC
*** Bug 192746 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2009-05-15 15:16:38 UTC
*** Bug 192771 has been marked as a duplicate of this bug. ***
Comment 16 Médéric Boquien 2009-05-22 23:46:39 UTC
*** Bug 193659 has been marked as a duplicate of this bug. ***
Comment 17 Thomas McGuire 2009-06-02 16:22:56 UTC
*** Bug 194995 has been marked as a duplicate of this bug. ***