Bug 60075 - Please don't use non-ASCII characters as shortcuts
Summary: Please don't use non-ASCII characters as shortcuts
Status: RESOLVED REMIND
Alias: None
Product: i18n
Classification: Unclassified
Component: de (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Thomas Diehl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-19 17:58 UTC by Malte S. Stretz
Modified: 2003-06-23 13:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malte S. Stretz 2003-06-19 17:58:36 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    Gentoo Packages
OS:          Linux

This bug is mainly about the German translation, but it might apply to all other languages which have special characters (French, Spanish, etc.).

At some places there are German umlauts used as menu and/or button shortcuts. Eg. in Konqueror:
  Bearbeiten->L&
Comment 1 Stephan Binner 2003-06-20 10:10:00 UTC
The KDE style-guide is written for the English language, or better said the 
German translation doesn't follow it. 
Comment 2 Thomas Diehl 2003-06-20 10:45:05 UTC
Who says that "most" German users don't use German keyboards? (Okay: most 
programmers don't but most programmers don't use the German translation either.) What 
about the lots of KDE languages that don't use ASCII characters at all? (Just think of the 
Asian and RTL languages.) 
 
Apart from that, I just have to point out that it is almost impossible for most teams (given 
their manpower) to get those shortcuts in an orderly and usable state (even with Dr. 
Clash). We'd need something much more automated to achieve this. 
 
Therefore, I'd suggest to send a short note to kde-i18n-doc about this (also for inclusion 
into the Translation HOWTO if Kevin thinks it fits). But at the moment I tend to close this 
one with a "won't fix". Sorry. 
Comment 3 Malte S. Stretz 2003-06-20 15:07:06 UTC
Hmmm... Freudian Error -- I wanted to write "some" ;-) 
 
And for some reason did I take out the paragraph excluding non-latin languages 
from the proposal... When you use such a system you most certainly use a 
correct keyboard, else you can't use any shortcuts at all. (Though I think I 
remember some screenshots of whatever system it was where you had latin 
shortcuts in brackets after the non-latin text.) 
 
Whatever, the shortcut management in KDE is AFAIK broken by design (because 
you re-use the strings and never know where you're shortcuts will go and where 
you'll get dups). But taking out the umlauts is something which could improve the 
matter in the near future... 
 
If you tend to close this bug, please use "REMIND" so that I might reopen it in 
some months or so ;-) 
Comment 4 Thomas Diehl 2003-06-20 17:42:44 UTC
Can't promise to take out umlauts in the "near future" but will post a recommendation to 
avoid them as much as possible. 
Comment 5 Maksim Orlovich 2003-06-20 17:46:10 UTC
BTW, scheck in kdesdk besides doing capitalization (only useful for originals) 
and key conflict checking also attempts to auto-suggest accelerators, thanks to
Coolo. If this is useful, I can easily make this a separate mode so you don't 
get all the noise from capitalization stuff... 



Comment 6 Stephan Kulow 2003-06-23 09:57:04 UTC
Yesterday I made dr.klash use these auto hints. Now you press F12 and get a list of 
changes you need to apply to your translations :) 
 
The topic of umlauts (I noticed that even on a german keyboard &
Comment 7 Stanislav Visnovsky 2003-06-23 13:50:12 UTC
Validation added as a wishlist to KBabel (#60267).