Bug 173814 - JJ: add keyboard shortcut for "Edit Track Information..."
Summary: JJ: add keyboard shortcut for "Edit Track Information..."
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Shortcuts (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 200897 226325 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-29 10:08 UTC by Elan Ruusamäe
Modified: 2012-02-15 09:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.6


Attachments
This is a patch that adds a keyboard shortcut for opening the Edit Track Details dialog (2.20 KB, patch)
2012-02-12 19:09 UTC, Jasneet Singh Bhatti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elan Ruusamäe 2008-10-29 10:08:45 UTC
Version:           1.4.10 (using 3.5.10, PLD Linux Distribution)
Compiler:          gcc version 3.3.6 (PLD Linux)
OS:                Linux (x86_64) release 2.6.24.7_desktop-2

currently the item is not listed neither in Configure Shortcuts, nor Configure Global shortcuts...

actually there are more items that can be bind to keyboard shortcut, available by mouse by clicking...
Comment 1 Kevin Funk 2010-02-18 19:30:53 UTC
*** Bug 226325 has been marked as a duplicate of this bug. ***
Comment 2 Kevin Funk 2010-02-18 19:47:43 UTC
*** Bug 200897 has been marked as a duplicate of this bug. ***
Comment 3 Jasneet Singh Bhatti 2012-02-12 19:09:55 UTC
Created attachment 68735 [details]
This is a patch that adds a keyboard shortcut for opening the Edit Track Details dialog

I've basically added a slot in MainWindow.cpp that is called when the shortcut key combination is pressed. In this slot, a call is made to a function that I've defined in playlist/PlaylistDock.cpp. This function, in turn, calls the edit track details function in playlist/view/listview/PrettyListView.cpp to open up the dialog.
Comment 4 Bart Cerneels 2012-02-15 09:35:39 UTC
Git commit c167a8661d25bca35bbf5f6154d7fdf926b1df69 by Bart Cerneels.
Committed on 15/02/2012 at 10:32.
Pushed by shanachie into branch 'master'.

Add keyboard shortcut for Edit Track

Patch by: Jasneet Bhatti
FIXED-IN:2.6

REVIEW: 103960

M  +2    -0    ChangeLog
M  +11   -0    src/MainWindow.cpp
M  +1    -0    src/MainWindow.h
M  +6    -0    src/playlist/PlaylistDock.cpp
M  +1    -0    src/playlist/PlaylistDock.h

http://commits.kde.org/amarok/c167a8661d25bca35bbf5f6154d7fdf926b1df69