Bug 172976 - JJ: make the Context View remember its size
Summary: JJ: make the Context View remember its size
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Context View (show other bugs)
Version: 2.0-SVN
Platform: Unlisted Binaries Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 171512 173217 194293 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-16 18:57 UTC by Lydia Pintscher
Modified: 2009-12-09 11:29 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Saves panel widths for persistance on restart (6.08 KB, patch)
2008-10-20 15:29 UTC, Gary Steinert
Details
Partly fixes collapsed frame problem (3.30 KB, patch)
2008-10-24 13:38 UTC, Gary Steinert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lydia Pintscher 2008-10-16 18:57:22 UTC
The Context View does not remember its size right now across restarts of Amarok. Amarok should restore the size of the CV and other components after a restart.
Comment 1 Mark Kretschmann 2008-10-20 11:48:26 UTC
*** Bug 171512 has been marked as a duplicate of this bug. ***
Comment 2 Gary Steinert 2008-10-20 15:29:39 UTC
Created attachment 28039 [details]
Saves panel widths for persistance on restart

Saves the widths of the three panels on exit, and restores them on restart of Amarok.

Uses the sizeHint() member function of each panel to set the size. Should prevent problems if the main window is a different size when Amarok is restarted.
Comment 3 Mark Kretschmann 2008-10-21 09:51:40 UTC
*** Bug 173217 has been marked as a duplicate of this bug. ***
Comment 4 Mark Kretschmann 2008-10-21 18:21:55 UTC
SVN commit 874449 by markey:

Make Amarok remember its panel sizes over restarts.

Patch by Gary Steinert <fatlardo@gmail.com>.  I've cleaned up the patch a bit before committing.

BUG: 172976


 M  +19 -5     MainWindow.cpp  
 M  +8 -10     MainWindow.h  
 M  +9 -1      Sidebar.h  
 M  +6 -1      playlist/PlaylistWidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=874449
Comment 5 S. Burmeister 2008-10-22 09:23:54 UTC
The patch does not work as expected. If one collapses the pane, i.e. clicks on it if it is opened and restarts amarok, the pane is restored with its minimum size rather than collapsed.
Comment 6 Gary Steinert 2008-10-24 13:38:45 UTC
Created attachment 28107 [details]
Partly fixes collapsed frame problem

This partly fixes the collapsed frame problem. If the entire frame is collapsed (in the case of the sidebar, this includes the buttons), when amarok restarts, it will remain collapsed.
If, however, the sidebar is collapsed with the buttons visible, the minimum size will still be restored. I'm working on that now.
Also, there is functionality in the patch for Mark's idea of a reset to defaults button. I'll work on that for 2.1.
Comment 7 Mark Kretschmann 2008-10-25 14:13:26 UTC
SVN commit 875731 by markey:

New patch from Gary Steinert that improves panel size restoration.

CCBUG: 172976


 M  +17 -7     MainWindow.cpp  
 M  +1 -6      Sidebar.h  
 M  +1 -6      playlist/PlaylistWidget.cpp  
 M  +1 -0      widgets/SidebarWidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=875731
Comment 8 Lydia Pintscher 2008-11-19 01:33:01 UTC
Gary what are your plans for this for 2.0 rc/final?
Comment 9 Gary Steinert 2008-11-28 14:09:18 UTC
Now that I've actually remembered about this one, I've just come across some code that should allow me to get this sorted.

Expect a fix soon =)

Gary
Comment 10 Dan Meltzer 2008-12-02 17:50:19 UTC
Not going to happen for 2.0, retargetting.
Comment 11 Gary Steinert 2008-12-17 03:46:45 UTC
I've looked into every way I can think of to get the collection browser panel to collapse properly. I just don't seem to be able to find the right way.

All that is left to be fixed of this bug is to restore the left hand panel correctly when it has been collapsed (i.e. one of the tab buttons clicked twice to hide the contents of the panel). Unfortunately it is a little over my head =(

Sorry

Gary
Comment 12 Mikko C. 2009-01-10 09:02:21 UTC
This is still valid with current trunk and the new CV.
Comment 13 Mikko C. 2009-03-01 10:50:54 UTC
*** Bug 185860 has been marked as a duplicate of this bug. ***
Comment 14 Kolja 2009-05-25 22:21:18 UTC
semms to fixed in current SVN, am i right?
Comment 15 Mikko C. 2009-05-27 12:15:21 UTC
*** Bug 194293 has been marked as a duplicate of this bug. ***
Comment 16 Lydia Pintscher 2009-05-27 12:16:47 UTC
Works fine here now.
Closing.
Comment 17 S. Burmeister 2009-05-27 12:53:22 UTC
Please re-open, this is not fixed as of Revision 973477. See comment 5 for the remaining issue.