Bug 172090 - CiteSeerX PDF links sometimes not clickable
Summary: CiteSeerX PDF links sometimes not clickable
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.1.1
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Konqueror Developers
URL: http://citeseerx.ist.psu.edu/viewdoc/...
: 175256 177304 (view as bug list)
Depends on:
Reported: 2008-10-03 16:50 UTC by Jakob Petsovits
Modified: 2012-06-18 19:21 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Petsovits 2008-10-03 16:50:36 UTC
I hit this before already from time to time on various CiteSeerX pages, and I think it doesn't always occur - when I tried to reload the page, the problem also disappeared. Just now, it does not disappear on pressing F5 or hitting Enter in the location bar again, so maybe there's a chance you can reproduce it too.

Steps to (maybe) reproduce:
1. Go to http://citeseerx.ist.psu.edu/viewdoc/summary;jsessionid=B2E72BD7BE16ED2D9041C628354D1EC3?doi=
2. On the rather top right-hand side, note the "DOWNLOAD: PDF" text, where "PDF" is a link. Although being displayed correctly, the link does not transform the mouse arrow into the "hand" cursor, and does not show the standard link options (including "Save link as...", which is unfortunate as I have to open the HTML source in that case).

On other CiteSeerX pages, the same "PDF" link worked flawlessly, maybe it will also work on the mentioned page when you try to reproduce it. Browsing through countless papers makes it show up sometimes, though. I would guess that their CSS is sloppy too (the same site also had problems with showing the search field before - that works again now), but maybe the issue is not solely in their responsibility.

Please try and see if you can reproduce that bug. Thanks!
Comment 1 Jakob Petsovits 2008-10-03 16:52:27 UTC

a) of course, you can take that ";jsessionid=(...)" out
b) and of course, directly after doing that and trying again (with or without session id), it worked again. Hrm.
Comment 2 FiNeX 2009-08-16 17:46:15 UTC
*** Bug 177094 has been marked as a duplicate of this bug. ***
Comment 3 FiNeX 2009-08-16 17:46:19 UTC
*** Bug 175256 has been marked as a duplicate of this bug. ***
Comment 4 FiNeX 2009-08-16 17:47:56 UTC
I'm not able to reproduce this bug (using current trunk) on the sites listed on this bug and on the two report I've just marked as dup (comment #2 and comment #3).

Someone is able to reproduce using KDE 4.3 or trunk?
Comment 5 FiNeX 2009-08-16 17:50:22 UTC
*** Bug 177304 has been marked as a duplicate of this bug. ***
Comment 6 Jakob Petsovits 2009-08-16 18:05:37 UTC
Using 4.3, I can't reproduce at the moment. Then again, I couldn't reliably reproduce even when I opened the but. If https://bugs.kde.org/show_bug.cgi?id=175256 is indeed the same bug and its instructions managed to bring up the bug reliably, maybe one should try out those instead of the link above.
Comment 7 Myriam Schweingruber 2012-06-18 19:21:34 UTC
Closing based on comment #4 and #6