Bug 169132 - Kmail dies ungracefully when out of disk space (losing settings and mail data)
Summary: Kmail dies ungracefully when out of disk space (losing settings and mail data)
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.10.0
Platform: unspecified Linux
: NOR grave with 90 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 176871 177704 180323 182637 183724 184587 190115 197895 202114 202790 205828 218634 219706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-14 17:35 UTC by David Baron
Modified: 2010-03-26 12:19 UTC (History)
25 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Baron 2008-08-14 17:35:14 UTC
Version:           1.10.0 (using 4.1.00 (KDE 4.1.0), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.23-rt1-davidb

This was an old bug in kde3 25702

Kmail will simply die with undefined side-effects to its configuration files. The program needs to warn before the critical point is reached and exit gracefully assuring all its existing data.
Comment 1 Dario Andres 2008-12-13 20:20:55 UTC
*** Bug 177704 has been marked as a duplicate of this bug. ***
Comment 2 Dario Andres 2009-01-11 14:43:57 UTC
*** Bug 180323 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2009-01-11 14:44:13 UTC
*** Bug 176871 has been marked as a duplicate of this bug. ***
Comment 4 Paulo Fidalgo 2009-01-21 15:53:20 UTC
I has this problem too... 
And this is not only Kmail related, since I have lost my accounts on Kopete too.

Here are my details:

	KDE Version 	1.10.3 (KDE 4.1.3 (KDE 4.1.3), 4.1.3-4.fc10 Fedora)
	Application 	E-Mail Client
	Operating System 	Linux (x86_64) release 2.6.27.9-159.fc10.x86_64
	Compiler 	gcc

Steps to reproduce:

- have kmail and kopete accounts
- full your home partition
- try to restar the applications, and see that the accounts are gone... even when restarting the computer.
Comment 5 James Hogan 2009-01-30 23:22:30 UTC
Hi, I'm getting the same symptoms, but under slightly different circumstances, so I'm not sure whether it is the same problem:
When kmail closes and it asks for the kwallet password, if i click cancel, then it asks if I want to save the passwords in the config file. Originally at this point I was either in a hurry or it kept coming up, so i pressed ctrl+alt+escape (which i think starts xkill) and clicked on the message box to kill kmail. When i started it up again all accounts are lost. This is repeatable.
Anybody know if this could be the same root cause, or should I open a separate bug report?

Cheers
James
Comment 6 Jaime Torres 2009-02-01 00:08:38 UTC
*** Bug 182637 has been marked as a duplicate of this bug. ***
Comment 7 Jaime Torres 2009-02-08 21:51:50 UTC
*** Bug 183724 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-02-17 11:36:14 UTC
*** Bug 184587 has been marked as a duplicate of this bug. ***
Comment 9 Nico Schlömer 2009-04-07 14:12:42 UTC
Oh man,

I just bumped into the same bug. Hard disk full, Kmail cowardly retreats and loses (almost) all settings! Terrible.

Cheers,
Nico
Comment 10 Dario Andres 2009-04-24 14:24:49 UTC
*** Bug 190115 has been marked as a duplicate of this bug. ***
Comment 11 Henrik Pauli 2009-06-29 02:19:46 UTC
Same here, I think this is the second time for me.
Comment 12 Henrik Pauli 2009-06-29 02:20:15 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Josef Spillner 2009-07-20 11:45:43 UTC
Hit me as well with KDE 4.2.2. The startup worked fine. KMail even told me when trying to fetch mail through POP3 that due to a full hard disk, it would abort. After freeing some space and restarting kmail, the settings were gone.

I'd favour a more adaptive approach of checking each transaction (mail fetching) and subordinate transaction (single mail transmission) separately instead of letting a full hard disk affect the whole application which could still be used in such cases for searching or deleting mail.
Comment 14 Peter Lewis 2009-07-24 11:41:43 UTC
Yes this is really a very serious bug. Merely because the disk is full KMail loses ALL your IMAP emails and email settings with no indication of why.
Comment 15 anze 2009-07-24 12:29:37 UTC
The same happened to me - out of disk, kmail still tries to save kmailrc, rewrites the old one, but can't save the new one in its place.

The proper solution would be to remove the old kmailrc only after the new kmailrc has been successfully written to disk, not before.

This is a very serious bug!
Comment 16 Torgny Nyblom 2009-07-31 18:54:06 UTC
*** Bug 202114 has been marked as a duplicate of this bug. ***
Comment 17 Jaime Torres 2009-08-06 14:13:57 UTC
*** Bug 202790 has been marked as a duplicate of this bug. ***
Comment 18 Christophe Marin 2009-09-02 00:19:30 UTC
*** Bug 205828 has been marked as a duplicate of this bug. ***
Comment 19 Dan Dart 2009-09-08 21:29:01 UTC
This happens with KDE 4.2.4 with ALL the settings! Like desktop, kopete, amarok, my post-its... etc. Gimme them back! I needed those!
Comment 20 Dario Andres 2009-09-09 20:06:06 UTC
err.. Bug 206596 could be related too.
Comment 21 David Faure 2009-09-15 13:52:28 UTC
KConfig's handling of the "disk full" situation fixed in r1023830, for KDE-4.3.2 and later.

I think this fixes this report, since it means the settings are not lost anymore. KMail still has code to warn and exit when it can't write out emails, so I'm not sure about the "dies ungracefully" part of the report, but I think kmail exiting is fine, to avoid losing mails that can't be stored anywhere.
Comment 22 Christophe Marin 2009-09-15 14:00:22 UTC
*** Bug 197895 has been marked as a duplicate of this bug. ***
Comment 23 Arne Babenhauserheide 2009-09-15 15:18:57 UTC
Many thanks! 

But could KMail instead warn that the disk is full and stop disk activity but give the user time to free some space.
Comment 24 David Faure 2009-09-17 17:38:23 UTC
I thought it did exactly that?
I remember that dialog from earlier versions of KMail, at least.
Comment 25 Arne Babenhauserheide 2009-10-25 19:25:22 UTC
What I meant is "shall we exit?" -> buttons: "exit" and "check for free space again" (or so).
Comment 26 Dario Andres 2009-12-22 19:52:35 UTC
*** Bug 219706 has been marked as a duplicate of this bug. ***
Comment 27 Christophe Marin 2010-03-26 12:19:50 UTC
*** Bug 218634 has been marked as a duplicate of this bug. ***