Bug 206596 - Config files get lost if disk is full
Summary: Config files get lost if disk is full
Status: RESOLVED FIXED
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR grave with 1 vote (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 187918 200793 202376 209840 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-07 09:56 UTC by Gerrit Visscher
Modified: 2009-12-26 04:41 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerrit Visscher 2009-09-07 09:56:10 UTC
Version:            (using KDE 4.3.1)
OS:                Linux
Installed from:    Gentoo Packages

I was compiling OpenOffice (which uses up a LOT of disk space) and my disk ran out of space. My system is on one bis partition (which is my fault, I know) so there was no space left on $HOME. After Kopete said it could not save the history for a newly opened chat, I realised that there was a problem. I deleted some temporary files, but KDE got unstable and I was logged out. So far I can live with it, but after I logged in again, my bookmarks, (only) some of the Kopete configuration, Kmail config and lots of other configs (background image) were lost.

How can this happen? If a new configuration cannot be saved because the disk is full, the old one should not get lost.

A friend told me, he had the same thing on his installation (also Gentoo, KDE 4.3.0).
Comment 1 Gerrit Visscher 2009-09-07 10:02:02 UTC
Sorry, I did not mean to get rude if it looked like this. Losing my latest bookmarks was just not the best start today.
Comment 2 Dario Andres 2009-09-07 14:35:49 UTC
This looks related to bug 160980. 
Thanks
Comment 3 Dario Andres 2009-09-09 22:22:58 UTC
There is some discussion in kde-core-devel about this issue:
http://lists.kde.org/?l=kde-core-devel&m=125252651204966&w=2
Comment 4 David Faure 2009-09-15 13:48:13 UTC
Fixed in r1023830 for KDE-4.3.2 and later.
Comment 5 Jonathan Thomas 2009-10-06 18:30:59 UTC
*** Bug 187918 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-10-09 03:37:32 UTC
*** Bug 209840 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-10-11 18:05:16 UTC
*** Bug 202376 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Thomas 2009-12-26 04:41:52 UTC
*** Bug 200793 has been marked as a duplicate of this bug. ***