Bug 160880 - Alt-Tab while in region capture mode prevents exit
Summary: Alt-Tab while in region capture mode prevents exit
Status: RESOLVED UNMAINTAINED
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
: 174181 185375 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-15 22:30 UTC by Leo Spalteholz
Modified: 2018-09-04 04:21 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Spalteholz 2008-04-15 22:30:26 UTC
Version:           0.8.1 (using Devel)
Installed from:    Compiled sources

This is SVN 794641 as packaged in Debian sid/experimental

To reproduce:
Start ksnapshot, click Region mode, no delay.
Click new snapshot.
When the screen for selecting a region comes up, press alt-tab (or whatever your key combo is for switching windows, I did this by accident many many times).
The selection region remains on the screen, and you can still drag and select a region as normal, however neither Enter or Esc works, so you can't accept the selection or cancel.

The only way to get out of this is to CTRL-ALT-FX to another terminal and killall ksnapshot.  There is no way to escape from the region selection mode otherwise.
Comment 1 Dario Andres 2008-12-21 20:57:08 UTC
Can you still reproduce this bug with a recent KDE version? (4.1.3 / 4.2beta2 / 4.2svn) ?  Thanks :) 
Comment 2 Leo Spalteholz 2008-12-22 21:02:19 UTC
Still valid in 4.1.3. 

Dario: While I appreciate your attempt to clear out old reports, you should at least try to reproduce on your machine and report the results here instead of just posting a reminder to recheck with no evidence that anything has changed.
Comment 3 Dario Andres 2008-12-22 22:39:27 UTC
@Leo: Yes, I know about that. Sometimes I do the checking in my own system, but, sometimes I don't have the time to test it or I don't have the apps compiled. Anyway, sometimes bugs are fixed when fixing another bugs, or may be the developer noticed the same bug and then he fixed it without even knowing there was a bug report about it (this bug report had not a reply in 8 months (I realize that the bug tracker needed some love)). 
Anyway, I'm sorry for bothering. 
I'm going to compile the latest kdegraphics in 4.2 trunk and see if this is happening in the SVN version too. :)
Comment 4 Leo Spalteholz 2008-12-23 01:11:35 UTC
np.  Just tested in 4.1.85+svn899359 (debian packages) and this bug still applies
Comment 5 Dario Andres 2008-12-23 01:18:07 UTC
This bug is present here using:

Qt: 4.4.3
KDE: 4.1.86 (KDE 4.1.86 (KDE 4.2 >= 20081221))
kdelibs svn rev. 900437 / kdebase svn rev. 900437
kdegraphics svn rev. 900471
on ArchLinux x86_64 - Kernel 2.6.27.8

Just as a workaround you can double click on the selection rectangle ("region") of the screenshot. 

KSnapshot should prevent Alt+Tab stealing its focus when editing and selecting a region in the screenshot
Comment 6 Keith Rusler 2008-12-29 01:41:49 UTC
I just submitted a patch for this hopefully it will be accepted.The reason is due to a X11 window flag being set that doesn't handle input when the focus is lost.
Comment 7 Leo Spalteholz 2009-07-14 22:53:46 UTC
Still applies in 4.3RC2.   That patch didn't get in I take it?
Comment 8 Dario Andres 2009-07-14 23:00:59 UTC
Where the patch was sent to ?
Comment 9 FiNeX 2009-09-21 21:28:31 UTC
*** Bug 185375 has been marked as a duplicate of this bug. ***
Comment 10 FiNeX 2009-09-21 21:32:19 UTC
I'm not able to reproduce this bug using current trunk: when I press ALT+TAB (before, while and after selecting a region), nothing strange happens.
Comment 11 FiNeX 2009-09-21 21:33:32 UTC
*** Bug 174181 has been marked as a duplicate of this bug. ***
Comment 12 Andrew Crouthamel 2018-09-04 04:21:35 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years and I will be closing this bug. Spectacle is the replacement for ksnapshot now. Please test again and file a new bug for Spectacle if you still have issues. Thank you!