Bug 174181 - Can't exit of KSnapshot zone selection
Summary: Can't exit of KSnapshot zone selection
Status: RESOLVED DUPLICATE of bug 160880
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-03 17:27 UTC by Jean-Philippe Fleury
Modified: 2009-09-21 21:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Philippe Fleury 2008-11-03 17:27:48 UTC
Version:            (using KDE 4.1.2)
OS:                Linux
Installed from:    Ubuntu Packages

Often I can't exit of a zone selection. There's a message in the top of the screen to tell me that I can press "Enter" to capture or press "Esc" to exit, but both of them do nothing, so I just can't exit. I must Ctrl+Alt+F1 and killall ksnapshot to can continue to use my session.
Comment 1 Sergei Andreev 2008-12-27 18:09:41 UTC
I get once in this situation - but for me double clicking worked.
But now, using kde 4.1.3 amd64-build I can not reproduce this bug.
Comment 2 Richard Bos 2009-01-02 15:55:04 UTC
I have this problem continuesly on kde4.1.86
This is with openSUSE_11.1 rpms.  Please let me know what can be done to
debug this problem.  Using ksnapshot from kde3 work just fine.

Might this be related to the videocard/driver?
Comment 3 Jared 2009-01-28 19:26:17 UTC
Same problem when trying to take a screen shot of a region.  After clicking "New Snapshot" with "Capture Mode" set at "Region", both monitors turn completely gray -- no icons, no windows, just the mouse crosshair.  I can only exit by hitting <esc>.  Problem existed for me in both KDE4.1 and now KDE4.2.

$ ksnapshot --version
Qt: 4.4.3
KDE: 4.2.00 (KDE 4.2.0)
KSnapshot: 0.8.1
Comment 4 Geoff Cutter 2009-05-01 08:08:35 UTC
Qt: 4.4.3
KDE: 4.2.2 (KDE 4.2.2) "release 112"
KSnapshot: 0.8.1

Normally works well but if I include a webcam (ski.com.au) the cross cursor never leaves. I then switch the PC off to recover.
Comment 5 Geoff Cutter 2009-05-07 05:54:56 UTC
kde4-ksnapshot-4.2.3-92.3 - Screen Capture Program

ksnapshot --version
Qt: 4.4.3
KDE: 4.2.3 (KDE 4.2.3) "release 116"
KSnapshot: 0.8.1

Now works over webcam, thanks.
Comment 6 Dario Andres 2009-08-21 20:29:28 UTC
Can you check if this is related to bug 183742 / bug 160880; to merge them ?
Thanks
Comment 7 FiNeX 2009-09-21 21:33:32 UTC

*** This bug has been marked as a duplicate of bug 160880 ***