Bug 155858 - Multiple dialogs popups when searching and nothing found
Summary: Multiple dialogs popups when searching and nothing found
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 168252 183906 186333 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-15 21:17 UTC by Giedrius Stanevicius
Modified: 2010-01-09 17:48 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Disable the search dialogs (578 bytes, patch)
2008-05-10 23:26 UTC, kde2eran
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giedrius Stanevicius 2008-01-15 21:17:42 UTC
Version:            (using KDE KDE 4.0.0)
Installed from:    Ubuntu Packages

When searching for the text in the document and nothing is found, two dialog windows popup: "Searching for ..." and "No matches found for ...". One dialog would be enough (if any needed) :)
Comment 1 Giedrius Stanevicius 2008-01-15 21:29:27 UTC
Actually after performing more searches I can say that they can be really annoying. So I think there shouldn't be any dialogs popuping when nothing found (like on firefox for example). 
Comment 2 Albert Astals Cid 2008-01-16 00:06:36 UTC
That's actually a wish
Comment 3 vadim krasovsky 2008-01-16 14:48:06 UTC
But how you will know if searching is finished???
Comment 4 Giedrius Stanevicius 2008-01-16 15:06:56 UTC
>  But how you will know if searching is finished??? 
Well, you can look to how firefox have done it. I really prefer firefox search because it is clear enough and not intrusive
Comment 5 Frederick Alexander Thomssen 2008-05-10 22:00:36 UTC
I, too, think that there should be no popup at all (or at least an option to turn it off). The bar gets coloured red after an unsuccessful search, anyway!
Comment 6 kde2eran 2008-05-10 23:26:31 UTC
Created attachment 24701 [details]
Disable the search dialogs

This one-line patch tells Okular not to use pop-up dialogs when searching from
the command line. This mode already exists, it just needs to be toggled.
Comment 7 Pino Toscano 2008-08-03 21:06:24 UTC
*** Bug 168252 has been marked as a duplicate of this bug. ***
Comment 8 Jan Binder 2008-09-05 14:00:45 UTC
Well, then merge for 4.2 or 4.1.2 or are there reasons not to do so?
Comment 9 Pino Toscano 2008-10-11 17:05:14 UTC
The attached in comment #6 is wrong and it will not be applied.
Rationale: blindly disabling all the notifications is bad as having all of them active. Instead, better solutions (as give feedback in a non-intrusive way) must be implemented, and will hopefully be for KDE 4.2.
Comment 10 Kristjan Ugrin 2008-10-13 14:07:03 UTC
You might take a look how kwrite did it.
It's search and replace inline function works very well and it is not intrusive.
Comment 11 Pino Toscano 2008-12-01 00:17:46 UTC
In KDE 4.2 at least the "no results found" dialog is gone, replaced by "negative" colouring of the search line edit.
Comment 12 Pino Toscano 2009-02-10 13:26:38 UTC
*** Bug 183906 has been marked as a duplicate of this bug. ***
Comment 13 Pino Toscano 2009-02-15 01:36:35 UTC
SVN commit 926300 by pino:

replace the search line edit with the search "widget"
this way, we get a small animation while the search is in progress
CCBUG: 155858


 M  +20 -20    findbar.cpp  
 M  +2 -2      findbar.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=926300
Comment 14 Pino Toscano 2009-02-15 01:38:24 UTC
SVN commit 926301 by pino:

now that we have a small "progress" animation next to the search line edit in the find bar, there's no need for the "searching for ..." dialog
feedback about this new "notification" is much welcome
CCBUG: 155858


 M  +2 -0      document.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=926301
Comment 15 Ismael Barros 2009-02-21 00:02:43 UTC
New notification is much nicer than the old one, and seems to work alright.

Maybe it would be nicer to place the notification somewhere where it doesn't modify the layout and the position of other buttons while it's showing (like Firefox's awesome bar notification, which takes the place of the favicon) but I don't really see a quick alternative right now, and it's cool anyway.
Comment 16 Pino Toscano 2009-03-07 14:12:11 UTC
*** Bug 186333 has been marked as a duplicate of this bug. ***
Comment 17 Maciej Pilichowski 2009-03-07 14:25:20 UTC
Just in case I paste my wish:

Please provide reliable, cumulative, static information about searching and
completion of the search so user:
a) will be informed _always_
b) his/her actions would be taken into account immediately,
c) could read the message in his/her own pace (currently a11y abuse).

My suggestion: busy cursor while searching and status bar info saying (examples) "searching for the next occurence of "xxxx". If user presses F3 again, while search is not complete, info should change "searching for the 2nd next occurrence...". And so on. When phrase is found the info should change to
"searching ... < copy of the last message > : done".
if the phrase is not found:
"searching ... < copy of the last message > : not found".

In the last case (not found) the message dialog would appropriate too, I think.
Comment 18 Pino Toscano 2009-03-07 14:35:01 UTC
> Just in case I paste my wish:

*sigh*, give a read to what's been written, please.

> My suggestion: busy cursor while searching and status bar info saying

As I already told you, we don't use status bar, neither plan to.
And busy cursor is _already_ there.

As already written, a "busy animation" (similar to the one of the web browsers) appears next to the line edit now (always after 0.5s, to avoid the appear-disappear game with fast results).
Comment 19 Maciej Pilichowski 2009-03-07 15:19:02 UTC
> give a read to what's been written, please.

I did.

> As I already told you, we don't use status bar, neither plan to.

Yes you did, and on the other hand I don't plan to invent yet another name to the already existing zoo -- comboxes, panels, plasmoids, widgets, decorations, checkboxes, panes, toolboxes... This counter bar looks like status bar, can be used for the same purpose as status bar, it is placed as status bar, phrase "this pane in the bottom" is much longer than "status bar", thus... statusbar (and you know exactly about what piece I am talking about so I understanding the game you are playing).
Comment 20 Pino Toscano 2009-03-07 15:29:24 UTC
(In reply to comment #19)
> > As I already told you, we don't use status bar, neither plan to.
> 
> Yes you did, and on the other hand I don't plan to invent yet another name to
> the already existing zoo -- comboxes, panels, plasmoids, widgets, decorations,
> checkboxes, panes, toolboxes... This counter bar looks like status bar, can be
> used for the same purpose as status bar, it is placed as status bar, phrase
> "this pane in the bottom" is much longer than "status bar", thus... statusbar

A status bar is static, and just provide informations.
You don't need to invent a new name, as has already one: "find bar", created long before Okular got one (think about Firefox' one).

> (and you know exactly about what piece I am talking about so I understanding
> the game you are playing).

If you tell "status bar" referring to something that is not a status bar, hardly my fault.

And now, please stop this discussion, thanks.
Comment 21 Maciej Pilichowski 2009-03-07 15:49:30 UTC
Pino, when I said "status bar" I was not talking about find pane. I was saying about status bar -- in Okular it is the one that resides at the bottom, as most status bars, and display page number. Maybe it is now counter bar, I don't know.
Comment 22 Jan Binder 2009-08-19 12:49:26 UTC
I consider this bug fixed in KDE 4.3.0, as there are no more popups when
searching with okular.
Please close as RESOLVED.
Comment 23 Pino Toscano 2010-01-09 17:48:39 UTC
This was solved in KDE 4.3.0, as users noticed as well. Closing.