Bug 186333 - find: provide informative feedback
Summary: find: provide informative feedback
Status: RESOLVED DUPLICATE of bug 155858
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-06 13:23 UTC by Maciej Pilichowski
Modified: 2009-03-07 14:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2009-03-06 13:23:28 UTC
Version:            (using KDE 4.2.0)
Installed from:    SuSE RPMs

The problem + wish in general -- searching takes time so it is important to inform user what is going on. Please provide informative, visual feedback then.

My suggestion: busy cursor + tooltip saying (examples) "searching for the next occurence of "xxxx". If user presses F3 again, while search is not complete, tooltip should change "searching for the 2nd next occurrence...". And so on.
Comment 1 Pino Toscano 2009-03-06 15:30:31 UTC
(In reply to comment #0)
> The problem + wish in general -- searching takes time so it is important to
> inform user what is going on. Please provide informative, visual feedback then.

Uh? Isn't there a dialog telling "searching for foobar" already, other than the busy cursor?
Comment 2 Maciej Pilichowski 2009-03-06 21:03:02 UTC
You mean pane at the bottom? It is visible, sure -- but this pane does not tell if the searching is _currently_ performed. I can zoom in, zoom out, select something, and once opened, the find-pane sits still. 

So there is no visual difference, when I press F3 (find next) and when I press (zoom-in). The static pane tells nothing then.

There is no busy cursor.
Comment 3 Pino Toscano 2009-03-06 21:14:42 UTC
(In reply to comment #2)
> You mean pane at the bottom?

No.
For long (>= 0.5s) searches appears a small dialog telling "searching for foobar".
For very short searches, such a dialog does not appear, as it can be quite intrusive. Like it would be intrusive doing very quick changes in the interface.
(And this "searching for foobar" dialog is gone in KDE 4.3, replaced by a notification in the find bar, always appearing after 0.5s.)

> There is no busy cursor.

There is, just not when the next search result is on the current page as well.
Comment 4 Maciej Pilichowski 2009-03-06 23:48:25 UTC
I have CPU 2.8GHz, profile dynamic, the search took longer than 1 second for sure, and I didn't see anything more than scrolling pages. No extra dialog, not busy cursor.

Tooltip was of course just a suggestion, statusbar is not intrusive at all, so it would be possible to remove the timer and have reliable feedback (because as I said I have none).

Another issue, assuming it works, is this info cumulative?
Comment 5 Pino Toscano 2009-03-06 23:59:19 UTC
(In reply to comment #4)
> I have CPU 2.8GHz, profile dynamic, the search took longer than 1 second for
> sure, and I didn't see anything more than scrolling pages. No extra dialog, not
> busy cursor.

Wait, you are confusing what is the actual search and what is done to reach the search result (that does not last for me than 2 seconds anyway).
Open a document with many pages (like 200+) and find something that is only at the end, you will see what I mean.

> Tooltip was of course just a suggestion, statusbar is not intrusive at all,

We don't use status bar in Okular.
Tooltip means text, that becomes immediately pointless for very quick operations (no time to read in less than 1s, or at most less than 2s, something new that appears on screen).

> so it would be possible to remove the timer and have reliable feedback
> (because as I said I have none).

There is reliable feedback already.
Comment 6 Maciej Pilichowski 2009-03-07 14:03:35 UTC
Uh, my wish was tragedy but current implementation is also bad. Thank you for the info, now I see what you are talking about.

The "safe place" for showing the info about the search is a must because it is necessary to show info about finished job. So It would be great to reuse this statusbar(-like) and there show:
* searching for xxx....
and when it is done
* searching for xxx.... found.

Why? Because this dialog is big distraction and it simply blinks. I have no chance to read it all, I saw only a frame. Was it an error? A warning? What it did say? User cannot tell. 

So I rephrase -- the wish is:
Please provide reliable, cumulative, static information about searching and completion of the search so user:
a) will be informed _always_
b) his/her actions would be taken into account immediately,
c) could read the message in his/her own pace.

I posted an update for HIG about not forcing user to work in computer pace but I don't remember if this hit the main page.
Comment 7 Pino Toscano 2009-03-07 14:12:11 UTC
Okay, this is covered by #155858 then.

*** This bug has been marked as a duplicate of bug 155858 ***