Bug 154499 - Add a little eject symbol next to mounted volumes/disks/CDs/etc in Dolphin's Places panel
Summary: Add a little eject symbol next to mounted volumes/disks/CDs/etc in Dolphin's ...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: panels: places (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: VHI wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
: 255790 305050 377259 383678 421222 425149 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-12-22 22:47 UTC by Krenar Qehaja
Modified: 2022-01-10 19:46 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.91


Attachments
removing drives, mockup (144.14 KB, image/png)
2007-12-22 22:54 UTC, Krenar Qehaja
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Krenar Qehaja 2007-12-22 22:47:26 UTC
Version:           0.9.5 (using KDE KDE 3.97.0)
Installed from:    Ubuntu Packages

Hi Peter,

first of all thank you for your work on dolphin (it's becoming a killer app) and anybody else involved on kde 4,

Now, my wish:

I know that we already can unmount removable drives with right-click->unmount, but there should be an easier way to do that instead of right-clicking, think of gwenview's dolphin kpart, onMouseOver() of an image you are greeted with three options on a nice black and rounded background (fullscreen and to rotated image on the left or on the right), in dolphins case regarding removable drives we'd be greeted with: "eject/unmount/remove, delete and edit" lets say, 

maybe this mouse-over thing could be applied on all items of Places Panel.

thank you
Comment 1 Krenar Qehaja 2007-12-22 22:54:35 UTC
Created attachment 22659 [details]
removing drives, mockup

I made a mockup of my idea, to make my wish more visible for you =)
Comment 2 Peter Penz 2007-12-22 23:28:51 UTC
Nice to hear that you like Dolphin :-) Regarding your wish I've added Kevin Ottens to CC, as he is the maintainer of the places panel. I personally like the idea judging from the mockup, let's see what we can do in future...
Comment 3 Kevin Ottens 2007-12-23 19:02:39 UTC
Will hopefully be for 4.1.
Comment 4 Elias Probst 2009-08-21 02:37:18 UTC
Any news on this? Plans implementing it in 4.4?
Does it make sense from a usability POV? Or is this a no-go?
Comment 5 Kevin Ottens 2009-08-21 07:52:18 UTC
Well, will hopefully be implemented. I think it's an interesting idea, it's quite some work to get it right though...
Comment 6 Christoph Feck 2012-01-03 21:12:16 UTC
*** Bug 255790 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2017-09-02 21:59:29 UTC
*** Bug 383678 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2017-09-02 22:00:14 UTC
*** Bug 377259 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2017-09-02 22:01:10 UTC
Definitely. My vote goes to adding a little eject symbol next to mounted volumes in Dolphin's Places panel.
Comment 10 Nate Graham 2017-09-03 01:51:18 UTC
*** Bug 305050 has been marked as a duplicate of this bug. ***
Comment 11 manuel_songokuh 2018-02-18 14:00:26 UTC
hi

this bug  154499  is ready fixed? if yesthis bug will be close..right?

 see here:https://phabricator.kde.org/D8348
Comment 12 Nate Graham 2018-02-18 23:23:54 UTC
No, that patch just added the Removable Devices section to file dialogs. We still don't have an eject button there, which is what this bug tracks.
Comment 13 Jason Walker 2019-08-30 06:11:13 UTC
I started looking into this (first dive into KDE code) and it looks like the PlacesItem class is only capable of displaying one icon, which renders on the left, and the text, which renders on the right. Furthermore, it seems like the whole PlacesItem is clicked and activated as a unit. To implement this, we'll have to add the option for PlacesItem to render a second icon that is activated separately from the main icon/text.

On the plus side, all of the code to unmount the drive and enable/disable the icon is already present for the context menu, and easy to pull out.
Comment 14 Nate Graham 2019-08-30 12:58:09 UTC
That's very cool, Jason. Let me know if you run into any roadblocks along the way! I'd love to help.
Comment 15 Julian Steinmann 2020-05-10 15:18:57 UTC
*** Bug 421222 has been marked as a duplicate of this bug. ***
Comment 16 Claudius Ellsel 2020-08-08 20:34:46 UTC
*** Bug 425149 has been marked as a duplicate of this bug. ***
Comment 17 Claudius Ellsel 2020-08-08 20:35:42 UTC
Changed to dolphin as a product. Seems to make more sense to me.
Comment 18 Nate Graham 2020-08-08 22:43:24 UTC
regarding where this bug report should live, let me provide a bit of background.

The actual model for the paces panel lives in KIO, but there are two implementations of its visual presentation: one in KIO, which you can see in the file dialog, Gwenview, Kate, and many other places; and another one specific to Dolphin.

So with the current state of affairs, we'd technically need two bug reports: one tracking implementing this in the general KIO version, and another one tracking implementing it just for Dolphin.

However what we ideally should do is port Dolphin to use the KIO implementation so that all the code is centralized in one place and we don't need to implement the same feature in two places (KIO and Dolphin. See https://phabricator.kde.org/T9795. Then we can implement the eject button in KIO once and all apps that show a Places panel will get it for free.

Kai started working on doing this last year: https://phabricator.kde.org/D26067

Unfortunately the work seems to have stalled recently. :( I think it would be good to get that going again and move this bug back to KIO so that the feature can be implemented there, and then once Kai's patch gets merged, Dolphin will get the feature for free. What do you think?

Oh and thanks for all the bug triaging, BTW. :)
Comment 19 Claudius Ellsel 2020-08-09 16:50:17 UTC
Thanks for the explanation. I was unaware of the different implementations of the places panel.

You are right, it probably makes sense to try not to have duplicate code and thus use the already existing implementation also in Dolphin. The only thing I am not sure about is whether it is sensible to have unmount buttons also in the other contexts where the places panel is used in. But I guess that could also maybe be circumvented with some sort of switch dependent on the context, if this should turn out to be a problem.
Comment 20 Nate Graham 2020-08-09 21:43:59 UTC
Cool, glad to be able to provide that background.

Are you okay with moving this back to KIO?
Comment 21 Claudius Ellsel 2020-08-12 14:18:14 UTC
(In reply to Nate Graham from comment #20)
> Cool, glad to be able to provide that background.
> 
> Are you okay with moving this back to KIO?

I don't know what the right place would be. Basically this issue wants to see the functionality integrated in Dolphin and doesn't really care how this is achieved technically. To get this done technically in the proposed way, one would need actually two issues, one for integrating this in KIO and one to use KIO places in Dolphin. So I think one could maybe add those two issues (if not already there) and link them to this one, with having KIO places in Dolphin as a dependency for this one. This has the benefit that there are open issue for every involved product, so the awareness for this on the relevant sides might be higher. Also it offers some more granularity and modularity.
Comment 22 Kai Uwe Broulik 2022-01-09 18:51:57 UTC
Finally some progress!

* The KIO enablement for porting back Dolphin to KFilePlacesView has just been merged
* The Dolphin patch is still pending but should be safe to go in in a few days
* and now there's a patch to add a little eject icon :) https://invent.kde.org/frameworks/kio/-/merge_requests/697
Comment 23 Kai Uwe Broulik 2022-01-10 17:07:37 UTC
Git commit b59404eb70469195732dd31a9ac0f94728a6d942 by Kai Uwe Broulik.
Committed on 10/01/2022 at 13:14.
Pushed by broulik into branch 'master'.

[KFilePlacesView] Add inline eject button

M  +142  -12   src/filewidgets/kfileplacesview.cpp
M  +72   -8    src/filewidgets/kfileplacesview_p.h

https://invent.kde.org/frameworks/kio/commit/b59404eb70469195732dd31a9ac0f94728a6d942