Bug 152117 - Crashes when trying to delete or move a message
Summary: Crashes when trying to delete or move a message
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.10
Platform: OpenSUSE Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 150827 152206 152422 152815 153328 156619 157018 159079 160596 160712 160754 161529 163640 165572 167720 167791 172257 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-10 17:45 UTC by Tony Casey
Modified: 2009-04-07 19:05 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Casey 2007-11-10 17:45:24 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

Crash occurs when trying to delete a particular *spam* message without opening it. This occurred repeatedly. However, opening the message and deleting (delete key) it worked.

Backtrace follows:

System configuration startup check disabled.

[?1034h(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x2ba1a2456300 (LWP 24985)]
[New Thread 0x42003950 (LWP 24989)]
[New Thread 0x41802950 (LWP 24988)]
[New Thread 0x41001950 (LWP 24987)]
[New Thread 0x40800950 (LWP 24986)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00002ba1a719dbd0 in KMFolder::open ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002ba1a72e6898 in KMMoveCommand::execute ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002ba1a72d8770 in KMCommand::slotPostTransfer ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002ba1a72dead2 in KMCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002ba1a72deca9 in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#10 0x00002ba1a72ded00 in KMMoveCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#11 0x00002ba1a72ded69 in KMDeleteMsgCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#12 0x00002ba19ba72e6c in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002ba1a72d7a6c in KMCommand::messagesTransfered ()
   from /opt/kde3/lib64/libkmailprivate.so
#14 0x00002ba1a72df4f2 in KMCommand::transferSelectedMsgs ()
   from /opt/kde3/lib64/libkmailprivate.so
#15 0x00002ba1a72deabd in KMCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#16 0x00002ba1a72deca9 in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#17 0x00002ba1a72ded00 in KMMoveCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#18 0x00002ba1a72ded69 in KMDeleteMsgCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#19 0x00002ba19ba72e6c in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x00002ba19bd58452 in QSignal::signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002ba19ba8b1ed in QSignal::activate ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002ba19ba91728 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#23 0x00002ba19ba1c6dd in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#24 0x00002ba19ba1d3f8 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002ba19b2043dd in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#26 0x00002ba19ba12d77 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00002ba19b9d29b5 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x00002ba19ba30f53 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#29 0x00002ba19ba30e02 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#30 0x0000000000418649 in QWidget::setUpdatesEnabled ()
#31 0x00002ba19c488b54 in __libc_start_main () from /lib64/libc.so.6
#32 0x0000000000417e09 in QWidget::setUpdatesEnabled ()
#33 0x00007fff11b3ea28 in ?? ()
#34 0x0000000000000000 in ?? ()
Comment 1 Thomas McGuire 2007-11-10 18:33:25 UTC
Just out of interest: How can you delete messages without opening them?
Comment 2 Tony Casey 2007-11-10 19:54:36 UTC
On Saturday 10 November 2007 17:33:25 Thomas McGuire wrote:
[bugs.kde.org quoted mail]

Hi Thomas,

I am using an imap account and have set up kmail without a reading pane, thus 
requiring me to open the message to read it. Pressing [delete key] on the 
message or right click->move to wastebin then deletes it without opening.

What I found with this message was that I had to double-click to open before I 
could delete it - which it did without trouble, otherwise kmail crashed 
immediately.

Apologies if this is an existing bug. I am a new Linux/KDE user and although I 
checked the buglist and found similar bugs, they claimed it was resolved.

My system is:
AMD Athlon64
SuSe 10.3 x86-64
KDE 3.5.7
KMail 1.9.6

Hope this is helpful.

Regards,
Tony
Comment 3 Thomas McGuire 2007-11-12 16:46:47 UTC
*** Bug 152206 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2007-11-16 14:21:09 UTC
*** Bug 152422 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-11-24 15:15:57 UTC
*** Bug 152815 has been marked as a duplicate of this bug. ***
Comment 6 Thomas McGuire 2007-12-03 18:48:14 UTC
*** Bug 153328 has been marked as a duplicate of this bug. ***
Comment 7 Thomas McGuire 2008-01-26 18:39:25 UTC
*** Bug 156619 has been marked as a duplicate of this bug. ***
Comment 8 Thomas McGuire 2008-02-04 18:10:28 UTC
*** Bug 157018 has been marked as a duplicate of this bug. ***
Comment 9 Thomas McGuire 2008-02-17 01:33:34 UTC
*** Bug 150827 has been marked as a duplicate of this bug. ***
Comment 10 Thomas McGuire 2008-03-13 18:50:01 UTC
*** Bug 159079 has been marked as a duplicate of this bug. ***
Comment 11 Terry Herckenrath 2008-03-13 21:07:52 UTC
I just had the same problem, but this time with the preview window open.

I was in another IMAP folder before this happened.
I then clicked on the Inbox entry in my favorites, clicked on the email to delete, then when I pressed the Delete key, the crash occured. The email to be deleted was the first of three emails in the list, with the other two emails being in one thread and I'm using the Threaded message list option.

I'm running Kmail 1.9.6 under Gnome in Ubuntu Gutsy (KDE 3.5.8).

Stack trace:
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1251387184 (LWP 14124)]
[New Thread -1279734896 (LWP 14128)]
[New Thread -1271342192 (LWP 14127)]
[New Thread -1262949488 (LWP 14126)]
[New Thread -1254556784 (LWP 14125)]
[KCrash handler]
#6  0xb7be8b09 in KMFolder::open (this=0x0, owner=0xb7ee803f "kmmovecommand")
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmfolder.cpp:472
#7  0xb7d51989 in KMMoveCommand::execute (this=0x848dc80)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmcommands.cpp:2154
#8  0xb7d41469 in KMCommand::slotPostTransfer (this=0x848dc80, 
    result=KMCommand::OK)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmcommands.cpp:260
#9  0xb7d48f86 in KMCommand::qt_invoke (this=0x848dc80, _id=5, _o=0xbfd49ec4)
    at ./kmcommands.moc:148
#10 0xb7d492ab in KMMenuCommand::qt_invoke (this=0x848dc80, _id=5, 
    _o=0xbfd49ec4) at ./kmcommands.moc:2801
#11 0xb7d49337 in KMMoveCommand::qt_invoke (this=0x848dc80, _id=5, 
    _o=0xbfd49ec4) at ./kmcommands.moc:2987
#12 0xb7d493ab in KMDeleteMsgCommand::qt_invoke (this=0x848dc80, _id=5, 
    _o=0xbfd49ec4) at ./kmcommands.moc:3062
#13 0xb5f42893 in QObject::activate_signal (this=0x848dc80, clist=0x851be00, 
    o=0xbfd49ec4) at kernel/qobject.cpp:2356
#14 0xb7d3ffde in KMCommand::messagesTransfered (this=0x848dc80, 
    t0=KMCommand::OK) at ./kmcommands.moc:126
#15 0xb7d49f81 in KMCommand::transferSelectedMsgs (this=0x848dc80)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmcommands.cpp:355
#16 0xb7d4a0e7 in KMCommand::slotStart (this=0x848dc80)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/kmcommands.cpp:252
#17 0xb7d48f98 in KMCommand::qt_invoke (this=0x848dc80, _id=4, _o=0xbfd4a068)
    at ./kmcommands.moc:147
#18 0xb7d492ab in KMMenuCommand::qt_invoke (this=0x848dc80, _id=4, 
    _o=0xbfd4a068) at ./kmcommands.moc:2801
#19 0xb7d49337 in KMMoveCommand::qt_invoke (this=0x848dc80, _id=4, 
    _o=0xbfd4a068) at ./kmcommands.moc:2987
#20 0xb7d493ab in KMDeleteMsgCommand::qt_invoke (this=0x848dc80, _id=4, 
    _o=0xbfd4a068) at ./kmcommands.moc:3062
#21 0xb5f42893 in QObject::activate_signal (this=0x83a7030, clist=0x819b020, 
    o=0xbfd4a068) at kernel/qobject.cpp:2356
#22 0xb62ce8ec in QSignal::signal (this=0x83a7030, t0=@0x83a7058)
    at .moc/debug-shared-mt/moc_qsignal.cpp:100
#23 0xb5f62842 in QSignal::activate (this=0x83a7030) at kernel/qsignal.cpp:212
#24 0xb5f6a258 in QSingleShotTimer::event (this=0x83a7008)
    at kernel/qtimer.cpp:286
#25 0xb5ed9af0 in QApplication::internalNotify (this=0xbfd4a744, 
    receiver=0x83a7008, e=0xbfd4a3b8) at kernel/qapplication.cpp:2635
#26 0xb5edb91f in QApplication::notify (this=0xbfd4a744, receiver=0x83a7008, 
    e=0xbfd4a3b8) at kernel/qapplication.cpp:2358
#27 0xb669fcd2 in KApplication::notify (this=0xbfd4a744, receiver=0x83a7008, 
    event=0xbfd4a3b8)
    at /build/buildd/kdelibs-3.5.8/./kdecore/kapplication.cpp:550
#28 0xb5e6c209 in QApplication::sendEvent (receiver=0x83a7008, 
    event=0xbfd4a3b8) at ../include/qapplication.h:520
#29 0xb5ecc53b in QEventLoop::activateTimers (this=0x8090c68)
    at kernel/qeventloop_unix.cpp:556
#30 0xb5e80d49 in QEventLoop::processEvents (this=0x8090c68, flags=4)
    at kernel/qeventloop_x11.cpp:389
#31 0xb5ef41ce in QEventLoop::enterLoop (this=0x8090c68)
    at kernel/qeventloop.cpp:198
#32 0xb5ef3fde in QEventLoop::exec (this=0x8090c68)
    at kernel/qeventloop.cpp:145
#33 0xb5edb699 in QApplication::exec (this=0xbfd4a744)
    at kernel/qapplication.cpp:2758
#34 0x0804a5fe in main (argc=-1215541784, argv=0x862b420)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kmail/main.cpp:110
#35 0xb56dd050 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#36 0x0804a381 in _start ()
Comment 12 Bram Schoenmakers 2008-04-11 18:28:48 UTC
*** Bug 160596 has been marked as a duplicate of this bug. ***
Comment 13 Bram Schoenmakers 2008-04-11 18:29:21 UTC
*** Bug 160712 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2008-04-14 00:26:21 UTC
*** Bug 160754 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2008-05-02 23:35:15 UTC
*** Bug 161529 has been marked as a duplicate of this bug. ***
Comment 16 Thomas McGuire 2008-06-10 17:01:02 UTC
*** Bug 163640 has been marked as a duplicate of this bug. ***
Comment 17 Thomas McGuire 2008-07-08 16:30:42 UTC
*** Bug 165572 has been marked as a duplicate of this bug. ***
Comment 18 Thomas McGuire 2008-07-30 13:04:00 UTC
*** Bug 167720 has been marked as a duplicate of this bug. ***
Comment 19 Thomas McGuire 2008-08-01 00:34:42 UTC
*** Bug 167791 has been marked as a duplicate of this bug. ***
Comment 20 Saurabh Barjatiya 2008-08-29 18:30:39 UTC
Sometimes I cant see the contents of some emails. When I try to move those emails KDE crashes with similar backtrace as listed above.
Comment 21 Nicolás Alvarez 2009-01-17 20:06:52 UTC
I'm having the same problem.

I have the preview panel disabled. I opened three messages (forum notifications), so each opened on its own window. Pressed the delete key on the three windows. When I got back to the inbox window, only one message was deleted, the other two were still there (one of them even marked as unread).

I tried delete one of them by pressing the delete key while the message was selected in the inbox window. KMail segfaulted.

Now it's totally reproducible. I open KMail, those two messages are still there. I delete either of them, and KMail segfaults. Sometimes one of the two leftover messages shows twice (so three of them show), checking for new mail makes one of them disappear.

KMail 1.9.10, KDE 3.5.10, Kubuntu Hardy (8.04), 64-bit.

Stacktrace below:

[Thread debugging using libthread_db enabled]
[New Thread 0x7f52ab1766f0 (LWP 18209)]
[New Thread 0x43521950 (LWP 18217)]
[New Thread 0x42d20950 (LWP 18216)]
[New Thread 0x4251f950 (LWP 18215)]
[New Thread 0x41d1e950 (LWP 18214)]
[KCrash handler]
#5  KMFolder::open (this=0x0, owner=0x7f52aac848ca "kmmovecommand") at /build/buildd/kdepim-3.5.10/./kmail/kmfolder.cpp:477
#6  0x00007f52aab1b1e8 in KMMoveCommand::execute (this=0xc45360) at /build/buildd/kdepim-3.5.10/./kmail/kmcommands.cpp:2158
#7  0x00007f52aab0c0e0 in KMCommand::slotPostTransfer (this=0xc45360, result=KMCommand::OK) at /build/buildd/kdepim-3.5.10/./kmail/kmcommands.cpp:263
#8  0x00007f52aab14e82 in KMCommand::qt_invoke (this=0xc45360, _id=5, _o=0x7fffb31afc40) at ./kmcommands.moc:148
#9  0x00007f52aab15059 in KMMenuCommand::qt_invoke (this=0x0, _id=-1429714742, _o=0x0) at ./kmcommands.moc:2801
#10 0x00007f52aab150b0 in KMMoveCommand::qt_invoke (this=0xc45360, _id=5, _o=0x7fffb31afc40) at ./kmcommands.moc:2987
#11 0x00007f52aab15119 in KMDeleteMsgCommand::qt_invoke (this=0x0, _id=-1429714742, _o=0x0) at ./kmcommands.moc:3062
#12 0x00007f52a3b75fd0 in QObject::activate_signal (this=0xc45360, clist=0xd7b940, o=0x7fffb31afc40) at kernel/qobject.cpp:2359
#13 0x00007f52aab0b4ac in KMCommand::messagesTransfered (this=0x0, t0=KMCommand::OK) at ./kmcommands.moc:126
#14 0x00007f52aab159d2 in KMCommand::transferSelectedMsgs (this=0xc45360) at /build/buildd/kdepim-3.5.10/./kmail/kmcommands.cpp:358
#15 0x00007f52aab14e6d in KMCommand::qt_invoke (this=0xc45360, _id=4, _o=0x7fffb31afe30) at ./kmcommands.moc:147
#16 0x00007f52aab15059 in KMMenuCommand::qt_invoke (this=0x0, _id=-1429714742, _o=0x0) at ./kmcommands.moc:2801
#17 0x00007f52aab150b0 in KMMoveCommand::qt_invoke (this=0xc45360, _id=4, _o=0x7fffb31afe30) at ./kmcommands.moc:2987
#18 0x00007f52aab15119 in KMDeleteMsgCommand::qt_invoke (this=0x0, _id=-1429714742, _o=0x0) at ./kmcommands.moc:3062
#19 0x00007f52a3b75fd0 in QObject::activate_signal (this=0xb065a0, clist=0xd4e0e0, o=0x7fffb31afe30) at kernel/qobject.cpp:2359
#20 0x00007f52a3eee181 in QSignal::signal (this=0xb065a0, t0=@0xb065f0) at .moc/debug-shared-mt/moc_qsignal.cpp:100
#21 0x00007f52a3b941a3 in QSignal::activate (this=0xb065a0) at kernel/qsignal.cpp:215
#22 0x00007f52a3b9b9e4 in QSingleShotTimer::event (this=0xb06550) at kernel/qtimer.cpp:289
#23 0x00007f52a3b0e33a in QApplication::internalNotify (this=0x7fffb31b0860, receiver=0xb06550, e=0x7fffb31b02d0) at kernel/qapplication.cpp:2638
#24 0x00007f52a3b10093 in QApplication::notify (this=0x7fffb31b0860, receiver=0xb06550, e=0x7fffb31b02d0) at kernel/qapplication.cpp:2361
#25 0x00007f52a52446bd in KApplication::notify (this=0x7fffb31b0860, receiver=0xb06550, event=0x7fffb31b02d0) at /build/buildd/kdelibs-3.5.10/./kdecore/kapplication.cpp:550
#26 0x00007f52a3a9f20e in QApplication::sendEvent (receiver=0xb06550, event=0x7fffb31b02d0) at ../include/qapplication.h:523
#27 0x00007f52a3b01abc in QEventLoop::activateTimers (this=0x67ae80) at kernel/qeventloop_unix.cpp:559
#28 0x00007f52a3ab4107 in QEventLoop::processEvents (this=0x67ae80, flags=4) at kernel/qeventloop_x11.cpp:392
#29 0x00007f52a3b285bf in QEventLoop::enterLoop (this=0x67ae80) at kernel/qeventloop.cpp:201
#30 0x00007f52a3b282ab in QEventLoop::exec (this=0x67ae80) at kernel/qeventloop.cpp:148
#31 0x00007f52a3b0fe00 in QApplication::exec (this=0x7fffb31b0860) at kernel/qapplication.cpp:2761
#32 0x0000000000402eb4 in main (argc=1, argv=<value optimized out>) at /build/buildd/kdepim-3.5.10/./kmail/main.cpp:110
Comment 22 Dario Andres 2009-01-20 00:45:03 UTC
*** Bug 172257 has been marked as a duplicate of this bug. ***
Comment 23 Ruchir Brahmbhatt 2009-04-06 18:54:29 UTC
I can reproduce it on 1.9.10. Sometimes when mail is deleted,  and message list not refreshed, if we try to delete already deleted mails appearing in message list, kmail crashes.
Comment 24 Ruchir Brahmbhatt 2009-04-07 19:05:12 UTC
I can not reproduce on 1.11.2. Deleting mails immediately reflects in message list and there's no chance of deleting same mail again.