Bug 160596 - Crash on deleting one particular mail
Summary: Crash on deleting one particular mail
Status: RESOLVED DUPLICATE of bug 152117
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-09 08:41 UTC by Pavel Lastovicka
Modified: 2008-04-11 18:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Lastovicka 2008-04-09 08:41:10 UTC
Version:           1.9.6 (enterprise 20070904.708012) (using 3.5.9 "release 53.4" , openSUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.22.17-0.1-default

Hello,
today I saw that one mail in inbox was received twice. One of the two mails failed to display so I wanted to deleted. -> crash
The mail is displayed in the inbox as new, unread with two question marks before name in the list. The account is POP3.
  Unfortunately I cannot send you the mail because Save as function does not work on that mail.
  Also please note, my KDE is version 3.5.9 but I currently use kdepim3 version 3.5.7. But this shouldn't be a problem.

Here is the backtrace:
System configuration startup check disabled.

 [?1034h(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x2aef35f1c2d0 (LWP 4681)]
[New Thread 0x42003950 (LWP 4685)]
[New Thread 0x41802950 (LWP 4684)]
[New Thread 0x41001950 (LWP 4683)]
[New Thread 0x40800950 (LWP 4682)]
[KCrash handler]
#5  0x00002aef3ab3dbd0 in KMFolder::open ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002aef3ac86898 in KMMoveCommand::execute ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002aef3ac78770 in KMCommand::slotPostTransfer ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002aef3ac7ead2 in KMCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002aef3ac7eca9 in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#10 0x00002aef3ac7ed00 in KMMoveCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#11 0x00002aef3ac7ed69 in KMDeleteMsgCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#12 0x00002aef2f5353dc in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002aef3ac77a6c in KMCommand::messagesTransfered ()
   from /opt/kde3/lib64/libkmailprivate.so
#14 0x00002aef3ac7f4f2 in KMCommand::transferSelectedMsgs ()
   from /opt/kde3/lib64/libkmailprivate.so
#15 0x00002aef3ac7eabd in KMCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#16 0x00002aef3ac7eca9 in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#17 0x00002aef3ac7ed00 in KMMoveCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#18 0x00002aef3ac7ed69 in KMDeleteMsgCommand::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#19 0x00002aef2f5353dc in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x00002aef2f81a6a2 in QSignal::signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002aef2f54de65 in QSignal::activate ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002aef2f554478 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#23 0x00002aef2f4de275 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#24 0x00002aef2f4deea7 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002aef2eced8dd in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#26 0x00002aef2f4d48bf in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00002aef2f49439d in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x00002aef2f4f2e23 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#29 0x00002aef2f4f2cd2 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#30 0x0000000000418649 in QWidget::setUpdatesEnabled ()
#31 0x00002aef2ff4cb54 in __libc_start_main () from /lib64/libc.so.6
#32 0x0000000000417e09 in QWidget::setUpdatesEnabled ()
#33 0x00007fff7e05bd68 in ?? ()
#34 0x0000000000000000 in ?? ()
Comment 1 Pavel Lastovicka 2008-04-09 08:43:08 UTC
The platform of kmail is openSUSE 10.3 official distribution.
Comment 2 Bram Schoenmakers 2008-04-11 18:28:46 UTC

*** This bug has been marked as a duplicate of 152117 ***