Bug 151626 - regression: dragging file over directory shall open the dir
Summary: regression: dragging file over directory shall open the dir
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 152214 163031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-31 18:38 UTC by Martin Koller
Modified: 2009-03-11 16:02 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2007-10-31 18:38:39 UTC
Version:           unknown (using KDE 3.95.00 (KDE 4.0 Beta4))
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.7-default

In KDE3 I could drag a file over a target directory and wait a bit where then konqueror immediately opened the target directory where I then could even navigate further down still while doing the dragNdrop operation and finally decide where to drop the file.

This is now missing in dolphin
Comment 1 Peter Penz 2007-10-31 19:55:28 UTC
Thanks for the report! I've changed the severity to 'wishlist' as we did not implement this behavior on purpose. But we'll try to add an option in Dolphin for KDE 4.1 to support this feature.
Comment 2 Peter Penz 2007-11-13 08:59:04 UTC
*** Bug 152214 has been marked as a duplicate of this bug. ***
Comment 3 FiNeX 2007-11-23 11:14:09 UTC
This is a very useful feature! Moreover I know some people who use often this feature!
Comment 4 Peter Penz 2008-06-01 22:38:12 UTC
*** Bug 163031 has been marked as a duplicate of this bug. ***
Comment 5 Salvatore Brigaglia 2008-06-02 01:47:00 UTC
in 4.1 beta1 this useful feature is still missing. please re-implement it!
Comment 6 Peter Penz 2008-06-02 07:35:09 UTC
> in 4.1 beta1 this useful feature is still missing. please re-implement it! 

We'll implement it, but it's too late already for 4.1 (feature freeze) :-(
Comment 7 Maciej Pilichowski 2008-06-25 16:41:38 UTC
No-no. This is serious A11Y abuse  -- if you really intend to add this feature, make this optional.
Comment 8 Peter Penz 2008-06-25 16:50:52 UTC
> if you really intend to add this feature, make this optional

It will be optional and not turned on per default.
Comment 9 Felix Möller 2008-10-19 03:06:42 UTC
I just wanted to report this as I really miss it. Please implement it, thanks for your work.

I am using KDE 4.1.2
Comment 10 Peter Penz 2008-10-19 23:01:12 UTC
It has been implemented already for KDE 4.2, but it is not enabled yet because of a minor issue that must be fixed...
Comment 11 Salvatore Brigaglia 2009-01-15 00:31:43 UTC
this bug should be closed as the function is back to dolphin now!
Comment 12 FiNeX 2009-01-15 09:22:03 UTC
@Peter: about adding the option to konqueror too: I don't remember if it has already been planned.
Comment 13 Peter Penz 2009-01-16 11:12:55 UTC
@FiNeX: I'm currently working on a relayout of Dolphin's settings dialog, so that all non-Dolphin specific settings will also be available in Konqueror. Currently in 4.2 this option must be enabled in Dolphin to also get it in Konqueror :-( I'd suggest to set this issue to solved after I've done this relayout.
Comment 14 Angel Blue01 2009-03-11 15:59:52 UTC
Thi does seem to have been resolved in 4.2.1
Comment 15 FiNeX 2009-03-11 16:02:41 UTC
Right, the option is working on both dolphin and konqueror. Thanks!