Bug 148743 - re-editing HTML e-mails with the external editor feature makes these show HTML source
Summary: re-editing HTML e-mails with the external editor feature makes these show HTM...
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 149700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-11 15:51 UTC by Matthias Ansorg
Modified: 2008-06-17 22:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Ansorg 2007-08-11 15:51:30 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

What happens is this:
-- Configured "kate %f" as external editor for kmail.
-- Re-edit an HTML e-mail you saved as draft before configuring kmail for an external editor.
-- The external editor shows the HTML source; that's pretty fine and I thought it's possible that way to insert all the HTML stuff I cannot insert via the integrated WYSIWYG composer.
-- However, after saving the e-mail to drafts, the HTML source is shown as text (!) of the e-mail, i.e. no visual markup is done but the user sees the HTML source!
Comment 1 Thomas McGuire 2007-08-12 13:31:11 UTC
See also:
bug 128986
bug 121251
bug 86423
Comment 2 Thomas McGuire 2007-09-20 20:22:40 UTC
*** Bug 149700 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Stachowski 2008-06-17 22:22:39 UTC
SVN commit 821562 by qbast:

Make external editor work again.

BUG: 162279
BUG: 148743



 M  +73 -6     kmeditor.cpp  
 M  +1 -0      kmeditor.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=821562