Bug 128986 - Can't Paste HTML-formatted text into Kmail mail editor window
Summary: Can't Paste HTML-formatted text into Kmail mail editor window
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.1
Platform: Mandriva RPMs Linux
: NOR wishlist with 125 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-11 11:54 UTC by Bartosz Malinowski
Modified: 2009-07-18 12:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Malinowski 2006-06-11 11:54:14 UTC
Version:           1.9.1 (using KDE KDE 3.5.2)
Installed from:    Mandriva RPMs
OS:                Linux

As of Kmail 1.9.1 (kde 3.5.2) I still can't paste rich text/images into Kmail 
composer window (Mandriva 2006, SoS rpms with kde). All text gets pasted as plain, with no images. 
 
This is an attempt to "reopen" "Bug 89057: Rich Konqueror to KMail copy/paste not implemented", which has been closed without reason. The HTML-formatted text copying has been enabled for copying from Konqueror (with a severe encoding problem persisting if I copy non-latin (eg. Polish) text into eg. Openoffice: Bug 123865 Encoding/khtml: Copying from Konqueror to Openoffice as html - non-latin-1 characters get corrupted), but no HTML-formatted text can be pasted into Kmail mail composer window.

This is a really wanted feature, it would save some time to many people. It seems to be present in many other popular e-mail clients.

Cheers, 
b.
Comment 1 Bartosz Malinowski 2006-06-11 11:58:27 UTC
I've typed "copy non-latin", should be "copy non-latin-1".

b.

Comment 2 Casper Planken 2006-06-16 20:24:06 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Bartosz Malinowski 2006-06-17 11:52:54 UTC
Hello,

There seems to be another wishlist item concerning a KDE-wide solution for copying/pasting rich text/images. Whereas I don't consider this bug report to be a duplicate (there may be completely different amounts of work needed for fixing of one those), I invite you to cast your votes for that bug as well:  
Bug 78955: Copy and Paste of HTML Text, Images, and Tables from Webpages into KDE Apps

Kind regards,
b.
Comment 4 Garth Drummond 2007-01-09 08:06:07 UTC
This is the ONLY reason I am not using Kmail. I have been testing it for a week now, and I love it. I tried Evolution, and its nice, but I definitely prefer Kmail. So now I am going back to Thunderbird or Evolution until I know this can be done. Even if it is not by default, but at least have the option. eg: edit, Paste as HTML. I notice in the documentation of Kmail it says many people consider HTML email an annoyance, and we should avoid sending HTML email. They didn't give any good reasons for this annoyance, or provide good reasons for not sending HTML email. I can understand not allowing external references to HTML, but normal HTML and allowing embedded images helps a great deal when sending email that is easy to read. I have numerous business and personal uses for sending HTML email with and without embedded images. I also like to create templates in HTML to resend product info. All of this is standard in Thunderbird, but not Kmail? That all been said, well done to the developers of Kmail. It is AMAZING.
Comment 5 Thomas McGuire 2007-07-29 02:45:03 UTC
See also bug 121251.
Comment 6 Edwin Schepers 2007-12-11 20:37:00 UTC
implemented in KDE4
Comment 7 Frédéric COIFFIER 2009-07-18 12:36:38 UTC
I can copy HTML text in Firefox and paste it in KMail, but it doesn't work with Konqueror : Is there someone who know why ?