Bug 141414 - KMail shows sometimes empty mails using online IMAP
Summary: KMail shows sometimes empty mails using online IMAP
Status: RESOLVED DUPLICATE of bug 135904
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 143593 147041 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-08 20:53 UTC by Wallaby Pouch
Modified: 2007-07-31 11:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wallaby Pouch 2007-02-08 20:53:57 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages

I"m using online imap to access my emails.
Sometimes it happens that KMails displays an email message just fine but later that message is not displayed at all (the message part remains white) or just appears empty (i.e. just the header informations in the message window part without the email's text).
The message is NOT deleted from the server, it's all fine on the server side. Others programs like Thunderbird can load the message just fine.
KMail usually shows the text again after some time (sometimes hours, mostly after one or two days), usually after restarting the application.

Most messages of my inbox are displayed just fine, but often a few are displayed empty.

I know that this is not enough information to fix that bug, but I'm unable to see a pattern how that happens. Sometimes KMails also crashses if I click on some empty messages, but that's probably another bug.

I will submit as much information as possible if you tell me what to send.
Comment 1 Thomas McGuire 2007-02-08 22:55:24 UTC
This looks a lot like bug #94184, but that one is supposed to be fixed...
Comment 2 Wallaby Pouch 2007-02-08 23:16:00 UTC
Hm,
#94184 gave me the idea to do some ethernet sniffing. 
To do that I turned the TLS of the imap account in KMail and clicked on the problematic message.
But the message appeared fine now. That's strange.

I turned TLS on again and will report if I get that bug again.
Is it possible that this bug is related to the SSL/TLS support?
Comment 3 Wallaby Pouch 2007-02-16 22:24:21 UTC
This bug occured again for several times, now.
Most of the time it also helps to logout and -in again. Maybe some tmp files are cleared?
Comment 4 Thomas McGuire 2007-03-29 18:07:06 UTC
*** Bug 143593 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Nagl 2007-04-16 00:03:41 UTC
Same problem here: from one kmail start to the next neither preview nor opened view-email-windows show anything but a header and an empty mail (it didn't disappear but I didn't try for several hours or days). switching off tls "solves" the problem.

Matthias
Comment 6 Thomas McGuire 2007-06-22 13:57:08 UTC
*** Bug 147041 has been marked as a duplicate of this bug. ***
Comment 7 Bram Schoenmakers 2007-07-31 11:04:52 UTC

*** This bug has been marked as a duplicate of 135904 ***