Bug 135904 - Sometimes some emails are displayed as empty
Summary: Sometimes some emails are displayed as empty
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.10.0
Platform: OpenSUSE Linux
: NOR normal with 100 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 136644 141414 148383 148459 159453 161483 169717 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-18 15:01 UTC by Torquil Macdonald Sørensen
Modified: 2009-12-30 00:25 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
messages in discussion tree are not blanked (61.02 KB, image/png)
2008-09-11 16:52 UTC, Xavier Brochard
Details
kmail freeze on that email (4.76 KB, text/plain)
2008-09-11 16:53 UTC, Xavier Brochard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torquil Macdonald Sørensen 2006-10-18 15:01:14 UTC
Version:           1.9.5 (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Hello,

Sometimes some emails in my IMAP inbox are displayed with no contents. I.e. the subject. sender and date are preserved, but the body of the email is blank. I know that the emails are not empty, since I also have a webmail interface to the IMAP server, where they are displayed correctly at all times. In Kmail, emails are always visible the first time I view them. But sometimes when I want to view them again later, they are displayed as blank. It only happens very rarely.

Using "View Source" in those cases show an empty body, and also modified headers from what  see through the webmail interface. For details on how the source of the email looks compared to what it looks like through the webmail interface, please have a look at bug report #130265 (which I have closed because I originally misdiagnosed the problem).

Some observations:
* Only happens in my IMAP folders
* IMAP server is Cyrus IMAPD 2.2.12
* Happens with emails from different email programs (at least Pine and Outlook Express)
* After moving the email to another folder on the same IMAP server (using Kmail), the email contents becomes visible again
* Tens of thousands of people use the same IMAP server (it is the mail server at my university), and the administrators have not had similar reports, even though there must be quite a few Kmail users, since many machines here are running linux with KDE.

I originally sumitted this in bug #130265, but I misdiagnosed it somewhat, so I closed it and opened this report instead.

It is not the same as bug #84896, since in that case the sender and subject disappears. And as I understood it, in that case one could swee the email contents using "View Source", which I cannot. And #129803 is with POP3, not IMAP, and also in that case the subject and sender was missing, wihch is not the case for me.

Best regards,
Torquil M. Sørensen
Comment 1 Hans Meier 2006-12-28 07:11:19 UTC
I can confirm this bug, I've reported it in bug #136644 (which could be closed because it is a duplicate). Bug #133871 also seems to be the same problem/bug. It is very annoying for me, because it does not happen very rarely as for the original reporter - at the moment, I have 5-7 mails that I cannot read. Moreover, if I click on those mails without a body, the program crashes after 3-4 clicks, so I would recommend to tag this bug with crash instead of normal.
Comment 2 Torquil Macdonald Sørensen 2007-01-13 15:10:59 UTC
Could you please check what kind of IMAP server you are connecting to? For me it was "Cyrus IMAPD 2.2.12". Maybe it is printed when you run the command 'telnet hostname 143' (or 993), although in my case it is not printed. I had to contact the IT-department to get that info.
Comment 3 Hans Meier 2007-01-15 20:34:46 UTC
It's a Cyrus IMAP4 v2.2.13 server according to 'telnet hostname 143'.
Comment 4 Torquil Macdonald Sørensen 2007-01-16 11:04:24 UTC
Ok, that was very interesting. I sent an email with a link to this bug to the cyrus-info mailing list, asking if they have received any such reports from kmail users. If it results in a fruitful discussion, I will post a link to the cyrus-info thread here.
Comment 5 Philip Rodrigues 2007-02-07 23:26:57 UTC
*** Bug 136644 has been marked as a duplicate of this bug. ***
Comment 6 Hans Meier 2007-03-01 20:06:05 UTC
Have you received any news from the Cyrus people? This bug is really getting on my nerve - I'm going to use Thunderbird, because KMail is unusable. Can anyone set the status to confirmed please? This is a severe bug and should get a high priority.
Comment 7 Torquil Macdonald Sørensen 2007-03-01 20:35:46 UTC
Sorry, I didn't get any replies from the Cyrus-list. Btw, I also converted to Thunderbird because of this. I will change back to KMail when this bug is fixed.
Comment 8 Antonio Batovanja 2007-03-23 00:58:33 UTC
I can confirm this bug in KMail 1.9.5 and 1.9.6 using online IMAP (Courier)
Comment 9 Antonio Batovanja 2007-03-23 00:59:00 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 Torquil Macdonald Sørensen 2007-05-21 18:45:21 UTC
I am trying kmail again (version 1.9.6), and now I am optimistic. I haven't seen the bug yet, and now it has been almost a week. The IMAP server is still Cyrus 2.2.12 as before. The Debian version numbers are (todays Debian Sid/Unstable):

kmail 4:3.5.6.dfsg.1-2
kdelibs4c2a 4:3.5.7.dfsg.1-1
kdebase-kio-plugins 4:3.5.6.dfsg.2-2

Are there anyone else using Debian Sid/Unstable for which this bug has disappeared?
Comment 11 Herbert Engelmann 2007-06-10 11:07:40 UTC
I have seen this with 1.9.5 and it is very annoying.

It seems to me, that it happens, when I delete several mails at the end of
my inbox (the newest mails). Then the last remaining mail gets corrupted.
Sometimes I can see it uncorrupted by way of a web-interface, that runs
at my provider. Sometimes it is there corrupted also.

I am using opensuse 10.2.

The server says :
         [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE
         THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA
         IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready.
         Copyright 1998-2005 Double Precision, Inc.

I hope you can work that out soon.

regards

Herbert Engelmann
Comment 12 Herbert Engelmann 2007-07-25 22:29:58 UTC
I just got news from my provider. They changed the server from Courier
to Dovecot. There are no detailed reasons, but it sounds like other
people has similar problems. I will test the new configuration. maybe
it was on the server-side. 

I will report when I know more.

Comment 13 Hans Meier 2007-07-26 11:31:50 UTC
Seems to be fixed in 1.9.7 - I haven't experienced these problems during the last couple of weeks, and I was using KMail heavily. However, the server was also updated to Cyrus IMAP 2.3.8 (as opposed to 2.2.13), so it could also due to this recent upgrade. Anyway, I guess this bug can be marked as fixed although we're not sure what really solved the problem :-).
Comment 14 Bram Schoenmakers 2007-07-31 11:02:40 UTC
*** Bug 148383 has been marked as a duplicate of this bug. ***
Comment 15 Bram Schoenmakers 2007-07-31 11:04:53 UTC
*** Bug 141414 has been marked as a duplicate of this bug. ***
Comment 16 Aere Greenway 2007-08-01 02:17:10 UTC
I'm not sure if the problem I reported is a duplicate of this problem.  My problem happens every time, with every e-mail.  It happens in every folder.

My suspicion is that an online update didn't get properly installed.  

There were updates in the system tray, which I clicked on to install.  However, it took forever (I finally gave up and shut down for the evening) in the "parsing files" stage.  Perhaps those updates never got installed.  
Comment 17 Aere Greenway 2007-08-01 02:25:05 UTC
I'm dubious that the problem I reported is a duplicate of Bug 135904.  The 
problem I experience happens all the time - not just occasionally, and it 
happens in every folder.  

The e-mail I am responding to was visible only using 'view source', yet the 
content appears below.  

Perhaps clicking 'reply' gives me a better way to view the original e-mail.  

My suspicion is that a system update didn't get applied properly.  

There were updates available in the system tray, which I clicked-on to 
install.  However the process seemed to hang 'forever' (more than 15 minutes) 
in the "parsing files" stage, and I finally gave up on it and shut the system 
down for the evening.  I suspect those updates didn't get installed, yet the 
patch record on my system thinks they were installed.  

 - Aere Greenway

On Tuesday 31 July 2007 03:04, owner@bugs.kde.org wrote:
[bugs.kde.org quoted mail]
com
> 
> 
> 
> ------- Additional Comments From bramschoenmakers kde nl  2007-07-31 

11:04 -------
> *** Bug 141414 has been marked as a duplicate of this bug. ***
> 

Comment 18 Thomas McGuire 2007-08-02 20:27:57 UTC
*** Bug 148459 has been marked as a duplicate of this bug. ***
Comment 19 Thomas McGuire 2007-09-20 20:20:16 UTC
*** Bug 149715 has been marked as a duplicate of this bug. ***
Comment 20 Bastian Kames 2007-10-17 09:43:42 UTC
I can confirm this bug in KMail 1.9.5 and 1.9.6 using online IMAP.

Basic: Opensuse 10.2 und Opensuse 10.3
Comment 21 John E 2007-11-01 20:31:34 UTC
Just to say that I had this problem as said on Bug 151580 but I am not using IMAP.
Comment 22 Lophiomys 2008-02-09 15:13:59 UTC
Confirming it using imap.gmx.net and Kontact 1.2.6
under Kubuntu 7.10 all Updates:  2.6.22-14-generic #1 SMP Fri Feb 1 04:59:50 UTC 2008 i686 GNU/Linux
Was working for a month and then started showing empty messages.
Comment 23 Torquil Macdonald Sørensen 2008-02-10 15:14:54 UTC
After I wrote comment #10 I did not see more of this bug until today. I moved a message from the "Local Folders" inbox to the IMAP inbox, and I can no longer see its contents now, and "View source" shows the source code of an email without any "body"-text.

But, It may not be the same bug, because when I look at the email from the webmail interface to the IMAP server, the contents are gone there aswell, so I guess the email really was changed on the server side. As opposed to the problem in my original report, this time it is of course not possible to see the contents by moving the email to another IMAP-folder.

Debian Sid:
kmail 4:3.5.8-1
kdebase-kio-plugins 4:3.5.8.dfsg.1-7
kdelibs4c2a 4:3.5.8.dfsg.1-7
Comment 24 Matthias Heinz 2008-03-19 23:53:29 UTC
1.9.9, still there.

And its easy to "fix" this bug.

kmail keeps an INBOX file in ~/.kde/share/apps/kmail/imap/.somenumber.directory/. Deleting it will force kmail to recreate the index and redownload every header from the server.

I guess somehow the INBOX file gets corrupted (maybe because kmail crashed or wasn't closed properly e.g. because of a xserver crash)

And this corruption may be related to the imap server. Maybe the server changes something, kmail doesn't save this (because of the above mentioned crash) and the index file gets corrupted (kmail doesnt find the mail on the server anymore).
Comment 25 Hans Meier 2008-03-20 11:05:30 UTC
Yes, it's still there - I was wrong in proclaiming that it didn't occur anymore. Thanks for the hint Matthias, I will try that next time I encounter this issue. I hope with this knowledge the bug will be fixed as soon as possible.
Comment 26 Matthias Heinz 2008-04-30 19:45:23 UTC
Ok, i found a better workaround for this problem.

Just delete the .INBOX.index file. You wont loose the directory settings this way and the mails are displayed properly again.
Comment 27 Torquil Macdonald Sørensen 2008-07-18 15:13:46 UTC
Don't know if this is related, since this is a problem with the "Local Folders" inbox.

Right now I'm trying KDE4RC1, and I have one email in my "Local Folders" inbox, but kmail displays three blank emails. Two of them have unkonwn sender and subject. The third one looks correct in the email list, but kmail does not show any contents when I click on it. The email can be read manually by looking at the file:

/home/tmac/.kde4/share/apps/kmail/mail/inbox/cur/1216379436.6730.MYa2a

Deleting /home/tmac/.kde4/share/apps/kmail/mail/.inbox* fixes the problem. The next time it happens I will try to attach the .inbox* files and the email files in the cur/ folder.
Comment 28 Glenn McCarthy 2008-08-22 00:18:18 UTC
I am still noticing this with kmail from KDE 4.1  It seems to happen most often if I read emails from my inbox, but don't move or delete them.  When I close kmail and re-open it, the messages will be blank when I try to read them, and kmail will crash if I try to move them.  IMAP server I am using is courier-imap-4.4.1
Comment 29 Thomas McGuire 2008-08-22 00:22:16 UTC
KDE 4.1.1 will have a patch that _could_ possibly fix this, see bug 149715. But maybe this is a different issue.
Comment 30 Thomas McGuire 2008-08-22 00:23:16 UTC
KDE 4.1.1 will have a patch that _could_ possibly fix this, see bug 149715. But maybe this is a different issue.
Comment 31 Glenn McCarthy 2008-08-22 11:44:00 UTC
Thanks Thomas.  I patched kmail 1.9.9 (KDE 3.5.9) by hand, but still the same empty messages.
Comment 32 Bram Schoenmakers 2008-08-24 13:28:10 UTC
*** Bug 159453 has been marked as a duplicate of this bug. ***
Comment 33 Bram Schoenmakers 2008-08-24 13:28:56 UTC
*** Bug 161483 has been marked as a duplicate of this bug. ***
Comment 34 Bram Schoenmakers 2008-08-24 13:29:14 UTC
*** Bug 169717 has been marked as a duplicate of this bug. ***
Comment 35 Xavier Brochard 2008-09-11 16:52:15 UTC
Created attachment 27369 [details]
messages in discussion tree are not blanked
Comment 36 Xavier Brochard 2008-09-11 16:52:39 UTC
Hello
This is another blank email report. It occured after a crash (no debug window launched but I have kdepim-dbg package installed). Below, I've tried to remember all things I've done. 

It is an imap account with the trashcan in a local folder, not imap
I use kontact, not kmail only
It happened only in incoming mails folder, not in others imap folders.


1. kontact freeze (not only kmail part) while reading a message (short message, which mas correctly displayed) see attachments.

2. kill kontact, relaunch:
- all changed made in previous session disappeared (emails already read marked as unread, deleted ones still here, "important" marks removed) but moved messages in imap folder still moved;
- re-read the same message, freeze, kill kontact

3. after kontact relaunch:
- Kmail messages in wrong order: some old messages in front of today's ones. A click on the "date" column change nothing. Reading old messages change their dates to something in 2006.
- Synchronize, kmail crash.

4. relaunch:
- type something in Kjots (launched in kontact);
- synchronize kmail, kontact crash

5. relaunch:
- changed made in Kjots lost (kjots was launched in kontact);
- emails in wrong order: some old messages in front of today's ones;
- a lot of duplicated emails;  
- removed duplicated emails with Ctrl + * ;
- browsing recent and old emails blank them;
- emails in closed discussion trees not blanked (see attachments).

6. browsing my imap account by webmail:
- looks like there is missing messages (need to be confirmed later);
- contains 2 blank emails (in kmail I have 50 ones);
- wrong order: some old messages in front of today's ones;
- the incoming folder contains 5 spam messages with 2 Date fields with different values:
-----------------------------------------
Return-Path: <vrpxkkowebg@bodyofwater.com>
Delivery-Date: Thu, 11 Sep 2008 13:31:58 +0200
[snip]
Date: Thu, 11 Sep   Westeuropäische Sommerzeit
MIME-Version: 1.0
Content-Type: text/plain;
        format=flowed;
        charset="Windows-1252";
        reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-SpamScore: 1.8
        tests= INVALID_DATE RDNS_DYNAMIC
---------------------------

In attachments:
- a picture of message list, with emails in discussion tree still here;
- the email (incomplete, obtained from webmail) which freeze kontact.
Comment 37 Xavier Brochard 2008-09-11 16:53:48 UTC
Created attachment 27371 [details]
kmail freeze on that email
Comment 38 Xavier Brochard 2008-09-11 16:57:37 UTC
Sorry, i forgot to say i'm using KDE 4.1.1 in Debian Sid for AMD64
Comment 39 Xavier Brochard 2008-09-11 17:09:25 UTC
I've relaunched kontact through GDB, synchronized my imap account: this time it didn't crashed.

While synchronizing my imap account, I can see all blanked messages re-ordering (going to the end of the list).
I forgot to say previously that all blanked messages got the same strange date: february 07, 2006 (but labeled in french). I don't have email from 2006 in that folder.

My blanked emails are lost, they didn't reappear. I know I should have deleted kmail index first,  but previously it was working without doing that.
Comment 40 Phil Bradshaw 2008-12-13 20:38:27 UTC
I've experienced empty emails (just header) using kmail 1.9.10. Symptom can be triggered by sending one mail to empty IMAP inbox. HTH
Comment 41 Holger Lehmann 2009-02-05 14:47:40 UTC
I can confirm this for KMail 1.9.10 _and_ earlier versions.
I am using an open-exchange 5.0 (cyrus 2.2.3) as an imap server.
Other tools like, e.g.:
- thunderbird
- claws mail
- ox webfrontend
have *not* shown empty messages.

For me it seems to be connected to an outdated local imap cache, it often happens after cleaning up my inbox from, say, 100 emails.
Comment 42 Holger Lehmann 2009-02-05 14:49:08 UTC
Oh and BTW, moving the "blank" email in question results in a crash of kmail ....
Comment 43 Emil Obermayr 2009-04-25 11:07:00 UTC
happens here with POP3 from time to time as well

kmail (1.9.6) ignores any actions (move, delete...)  with the message; sometimes crashes
Comment 44 Björn Ruberg 2009-12-30 00:25:23 UTC
Hello. I looked through this bug and considered it fixed as  Thomas McGuire stated in comment #29. I don't see this bug in KDE 4.2 and 4.3. There are no reports of the original bug after 4.1. Xaviers observation in comment #36 is another bug.

So. I'm closing this. Please report when you see empty mails in KDE 4.3 without having a crash before. Then I reopen immediatly.